Discoloration in some XFCE icons and window borders

Bug #1656620 reported by Shahar Or on 2017-01-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LLVM
Fix Released
Undecided
Unassigned
Mesa
Fix Released
Undecided
Unassigned
Gentoo Linux
Fix Released
Medium
llvm-toolchain-3.9 (Ubuntu)
Undecided
Unassigned
xfce4 (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading from yakkety to zesty (LLVM 3.9.0 to LLVM 3.9.1) some UI components are now wrongly colored. See attached screenshot. I got a tip to look at LLVM here: https://www.reddit.com/r/xfce/comments/5klusr/problem_with_system_icon_colors/

I did not confirm this by downgrading to 3.9.0.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: libllvm3.9 1:3.9.1-2ubuntu1
ProcVersionSignature: Ubuntu 4.9.0-11.12-generic 4.9.0
Uname: Linux 4.9.0-11-generic x86_64
ApportVersion: 2.20.4-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Jan 15 09:31:33 2017
InstallationDate: Installed on 2010-10-12 (2286 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: llvm-toolchain-3.9
UpgradeStatus: Upgraded to zesty on 2017-01-14 (0 days ago)

Shahar Or (mightyiam) wrote :
Shahar Or (mightyiam) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in llvm-toolchain-3.9 (Ubuntu):
status: New → Confirmed
Changed in xfce4 (Ubuntu):
status: New → Confirmed
calexil (calexil) wrote :
calexil (calexil) wrote :

This issue occurs regardless of desktop environment, suggest removing xfce as an affected package

no longer affects: mate-desktop
calexil (calexil) on 2017-01-20
Changed in xfce4 (Ubuntu):
status: Confirmed → Incomplete
calexil (calexil) wrote :

The offending commit can be found here, please be sure to comment on it and notify llvm team of the need for it to be reverted:

https://github.com/llvm-mirror/llvm/commit/c280d74837d8239fc6cf567576b766ca3f4844c5

Shahar Or (mightyiam) wrote :

I've heard a rumor that this is fixed in llvm trunk. If so, it should be in this PPA:
https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

I may try this tomorrow or so.

calexil (calexil) wrote :

for users wanting stable driver releases. oibaf is not really a solution

Shahar Or (mightyiam) wrote :

@calexil that seems worth mentioning. The reason for me trying it is only for confirming it is solved upstream. Yet, are there plans to release Ubuntu 17.04 with llvm4.0 dependent drivers?

calexil (calexil) wrote :

Shahar, I believe mesa 17+llvm4.0 is the next major release

Nicolai Hähnle (nha) wrote :

radeonsi developer here. So, the unfortunate situation here is that the fix is in trunk ("AMDGPU: Do not clobber SCC in SIWholeQuadMode"), but it's non-trivial to backport on its own, unless you also take "AMDGPU: Reduce the duration of whole-quad-mode".

Backporting both of those commits _probably_ fixes this and all stippling-related bugs, but it's untested. Reverting the bad commit identified by calexil will fix the discoloration, but leave some (much lower impact) bugs around (IIRC, some Kodi configurations were affected).

Shahar Or (mightyiam) wrote :

Nicolai, can you assess the range of hardware that this affects?

Changed in mesa:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gentoo:
importance: Unknown → Medium
status: Unknown → Fix Released
Curt (nannerpuss) wrote :

Can confirm this just started for me with Cinnamon 3.2.7 after the update this morning. I tried forcing the llvm-toolchain package back to the previous version, but haven't tested or done anything beyond.

It also happened to me with Oibaf a couple weeks ago, fwiw

calexil (calexil) wrote :

sooo, any news on a fix for this?

users with amd cards wanting the latest stable version of mesa... do not have a good option right now.

Shahar Or (mightyiam) wrote :

Users who use unstable version of stuff is one thing. The most serious issue here is that 17.04 has this for all users of some hardware. I don't know which hardware.

Sam Rosewood (samrosewood) wrote :

Does somebody know will this bug affect to Ubuntu 16.0.2 that will be released in a week (http://news.softpedia.com/news/ubuntu-16-04-2-lts-delayed-until-february-9-due-to-serious-boot-regression-512445.shtml)? Or they have a time to fix it?
As I know, it will include new mesa etc.
I checked Lubuntu 17.04, this bug affects it.

calexil (calexil) wrote :

is this getting fixed?

calexil (calexil) wrote :

this issue is now many months old, is it being fixed any time soon?

Changed in xfce4 (Ubuntu):
status: Incomplete → Invalid
supaiku (supaiku-dev) wrote :

Any news?

Timo Aaltonen (tjaalton) wrote :

this issue is three weeks old on launchpad, and will be fixed in zesty once it moves to mesa 17+llvm-4.0

Timo Aaltonen (tjaalton) wrote :

oh and a merge of debian where this got fixed is in zesty-proposed

https://launchpad.net/ubuntu/+source/llvm-toolchain-3.9/1:3.9.1-4ubuntu1

stuck there because lldb-3.9 added a dependency on python-lldb-3.9 which is in universe..

im building mesa 17.0 rc3 with llvm 4.0 rc2 in my stable padoka ppa.

For me, this bug will be an non issue. It all depends on the version
your distro is using.

bests
| Paulo Dias
| <email address hidden>

Tempora mutantur, nos et mutamur in illis.

On Tue, Feb 7, 2017 at 4:45 PM, Timo Aaltonen <email address hidden> wrote:
> oh and a merge of debian where this got fixed is in zesty-proposed
>
> https://launchpad.net/ubuntu/+source/llvm-toolchain-3.9/1:3.9.1-4ubuntu1
>
> stuck there because lldb-3.9 added a dependency on python-lldb-3.9 which
> is in universe..
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1656620
>
> Title:
> Discoloration in some XFCE icons and window borders
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/llvm/+bug/1656620/+subscriptions

Paulo Dias (paulo-miguel-dias) wrote :

you welcome, enjoy 😊

On Feb 10, 2017 22:30, "calexil" <email address hidden> wrote:

> @Paulo ....thanks you so much!! I was losin my mind.
>
> https://www.reddit.com/r/linux_gaming/comments/5tadbv/
> padoka_stable_mesa_pkppa_now_has_mesa_17rc3_and/
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1656620
>
> Title:
> Discoloration in some XFCE icons and window borders
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/llvm/+bug/1656620/+subscriptions
>

calexil (calexil) wrote :

This can be closed

dino99 (9d9) wrote :

Closing per #22 & #26

Changed in llvm-toolchain-3.9 (Ubuntu):
status: Confirmed → Fix Released
Changed in llvm:
importance: Unknown → Undecided
status: Unknown → New
status: New → Fix Released
Changed in mesa:
importance: Medium → Undecided
status: Confirmed → New
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.