[Regression] "LLVM ERROR: Do not know how to split the result of this operator!" in executing Ubuntu UI Toolkit tests on x86

Bug #1360241 reported by Timo Jyrinki
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
llvm-toolchain-3.5 (Ubuntu)
Undecided
Unassigned
mesa (Ubuntu)
Undecided
Unassigned

Bug Description

With upgrade to LLVM 3.5, UITK tests start failing with LLVM error. This was reported earlier and the change to 3.5 reverted, but now 3.5 landed again.

So we're seeing errors like this:
https://launchpadlibrarian.net/182951835/buildlog_ubuntu-utopic-i386.ubuntu-ui-toolkit_1.1.1206%2B14.10.20140822-0ubuntu1_FAILEDTOBUILD.txt.gz

To reproduce, simply bzr branch lp:ubuntu-ui-toolkit and run bzr bd which also executes the unit tests.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in llvm-toolchain-3.5 (Ubuntu):
status: New → Confirmed
Changed in mesa (Ubuntu):
status: New → Confirmed
summary: - [Regression] LLVM error in executing Ubuntu UI Toolkit tests on x86
+ [Regression] "LLVM ERROR: Do not know how to split the result of this
+ operator!" in executing Ubuntu UI Toolkit tests on x86
Revision history for this message
Martin Pitt (pitti) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mesa - 10.2.6-1ubuntu3

---------------
mesa (10.2.6-1ubuntu3) utopic; urgency=medium

  * And revert again for now.. (LP: #1360241)
 -- Maarten Lankhorst <email address hidden> Fri, 22 Aug 2014 15:02:30 +0200

Changed in mesa (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Happened now on ubuntu-system-settings-online-accounts autopkgtests, preventing qtbase from moving from -proposed to -release:

https://jenkins.qa.ubuntu.com/view/Utopic/view/AutoPkgTest/job/utopic-adt-ubuntu-system-settings-online-accounts/lastBuild/ARCH=i386,label=adt/console

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :
Revision history for this message
Gustavo Pichorim Boiko (boiko) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers