lts-raring sru bug

Bug #1177679 reported by Maarten Lankhorst on 2013-05-08
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
llvm-3.2 (Ubuntu)
High
Maarten Lankhorst
mesa-lts-raring (Ubuntu)
Undecided
Unassigned

Bug Description

All dependencies in precise are ready. libdrm is recent enough, the only thing remaining is the actual copying of packages from precise.

Because there is no support in the lts-stack for arm, I forced the packages to only build on x86, by replacing architecture: (linux-)any with i386 amd64.

llvm-3.2 is copied without renaming, there is no risk since this is a new package, similar to how llvm-3.1 was copied for lts-quantal. The rest of the stack will follow the same naming convention used by lts-quantal.

Changed in llvm-3.2 (Ubuntu):
importance: Undecided → High
Matthias Klose (doko) wrote :

I'm missing some context here ... why this update, and why limit it to x86? because it's just a port is not a good answer. Are there technical reasons to disable arm and powerpc support?

Maarten Lankhorst (mlankhorst) wrote :

I can't verify it will even work at all, because the kernel team does not offer support for those kernels on arm and powerpc. Furthermore, on arm the pandaboard hasn't received an updated kernel for raring, and it is no longer receiving updates from TI.

Maarten Lankhorst (mlankhorst) wrote :

With the kernels I mean the linux-generic-lts-raring kernels. They do the same thing in their linux-generic-lts-raring kernels.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in llvm-3.2 (Ubuntu):
status: New → Confirmed
Changed in ubuntu (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

I don't know what kind of testing will be conducted, but I'm now happily running upgraded precise after apt-get install linux-generic-lts-raring xserver-xorg-lts-raring libgl1-mesa-dri-lts-raring libegl1-mesa-drivers-lts-raring libgl1-mesa-glx-lts-raring:i386 + installing the (still in NEW queue) video drivers of my choice from https://launchpad.net/ubuntu/precise/+queue?queue_state=0&queue_text=

Hello Maarten, or anyone else affected,

Accepted mesa-lts-raring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mesa-lts-raring/9.1.4-0ubuntu0.1~precise1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Maarten Lankhorst (mlankhorst) wrote :

Ok it's been running nicely on my main machine, andI haven't noticed any issues in installing, so marking this as verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package llvm-3.2 - 3.2-2ubuntu5~precise1

---------------
llvm-3.2 (3.2-2ubuntu5~precise1) precise-proposed; urgency=low

  * Copy to precise. (LP: #1177679)
  * Drop dh-exec build-depends, not available on precise, and unused.
  * Only build i386 and amd64.
 -- Maarten Lankhorst <email address hidden> Wed, 08 May 2013 08:57:17 +0200

Changed in llvm-3.2 (Ubuntu):
status: Confirmed → Fix Released
affects: ubuntu (Ubuntu) → mesa-lts-raring (Ubuntu)
Changed in mesa-lts-raring (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers