Exception table fix

Bug #1160587 reported by Conrad Steenberg on 2013-03-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
llvm-3.2 (Ubuntu)
Undecided
Unassigned

Bug Description

The attached patch fixes a segfault in the exception table of the JIT code emitter.

The patch is required for the crack-language llvm back-end and has been submitted to the llvm project. The original source is at http://code.google.com/p/crack-language/source/browse/extras/JITEmitter.patch

Sylvestre Ledru (sylvestre) wrote :

Could you provide a way to reproduce the bug ?

PS: next time, please report the bug in the Debian bug tracker, it is where the maintenance is done.

The attachment "JITEmitter.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

Please see the llvm bug report at http://llvm.org/bugs/show_bug.cgi?id=13678

I'll file a bug with debian for this if you prefer to address it there.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package llvm-3.2 - 3.2-2ubuntu5

---------------
llvm-3.2 (3.2-2ubuntu5) raring; urgency=low

  * Fix a segfault in the exception table of the JIT code emitter.
    LP: #1160587.
  * debian/rules (llvm_source_package): Unset QUILT_PATCHES.
 -- Matthias Klose <email address hidden> Thu, 18 Apr 2013 10:49:33 +0200

Changed in llvm-3.2 (Ubuntu):
status: New → Fix Released

Thanks, much appreciated :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.