Sync lives 1.3.2-2 (universe) from Debian unstable (main)

Bug #537516 reported by Harry Rickards
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lives (Ubuntu)
Wishlist
Unassigned
Declined for Lucid by StefanPotyra

Bug Description

Please sync lives 1.3.2-2 (universe) from Debian unstable (main)

Changelog entries since current lucid version 1.1.8-2:

 lives (1.3.2-2) unstable; urgency=low

   [ Harry Rickards ]
   * Added patch from upstream that fixes the mipsel build.
   * Added packaging exception for frei0r-plugins-dev so package builds
     on sparc64

   [ Alessio Treglia ]
   * debian/patches/makefile_am.diff: Add patch tags as per DEP-3.

 -- Alessio Treglia <email address hidden> Sun, 11 Apr 2010 12:40:32 +0200

lives (1.3.2-1) unstable; urgency=low

   [ Harry Rickards ]
   * Updated packaging exceptions so package builds on avr32, m68k and
     sparc64.

   [ Alessio Treglia ]
   * New upstream release.
   * Refresh debian/patches/cdda2wav_to_icedax.diff patch.
   * debian/patches/removepy.diff.
     - Refresh.
     - Correct a small typo.

 -- Alessio Treglia <email address hidden> Sun, 21 Mar 2010 23:08:46 +0100

lives (1.2.1-1) unstable; urgency=low

  * New upstream release.
  * debian/lives.1: Fix hyphen-used-as-minus-sign lintian warning.
  * Bump Standards.
  * Update debian/copyright.
  * Refresh all patches, drop imageloading.diff, applied by upstream.

 -- Alessio Treglia <email address hidden> Sun, 28 Feb 2010 12:24:13 +0100

Revision history for this message
Daniel Holbach (dholbach) wrote :
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Thanks Daniel!

Harry, I've uploaded the package to my testing PPA:
https://launchpad.net/~quadrispro/+archive/testing

Please test when ready and attach here the following:
 1. the install log
 2. one or more screenshots of the application

For now, that's the new ChangeLog entries:

Version 1.2.1 (27 Feb 2010)
---------------------------
Fix crash when opening ogg/theora files (regression).
Updated translations to Catalan, Finnish, Hungarian, and Spanish.

Version 1.2.0 (21 Feb 2010)
---------------------------
GUI updates for multitrack mode.
Implement drag and drop effects in multitrack mode.
Allow continuous mouse movement on multitrack timeline.
Allow timecode to be edited in multitrack mode.
Switching to->from multitrack mode maintains the layout in memory.
Allow startup in mt mode.
Better scrolling of tracks in multitrack.
Implement progressive image loading.
Change multitrack "snap mode" to "gravity left" / "gravity normal"
Allow jack transport to set play start position.
Add option of resizing frames to fit in clip editor interface.
Removed "File/Encode" ("File/Encode as" is safer)
New startup wizard for first time users.
Added Help/Troubleshoot.
Faster frame generation for realtime generators.
Add python 3 support to multi_encoder.
Add OSC commands /clip/close,/clip/copy,/clip/selection/copy,/clip/selection/cut,/clip/selection/delete,/clipboard/paste,/clipboard/insert_before,/clipboard/insert_after.
Fixed a possible bootstrap issue with weed plugins. *
Fixed an encoder/png problem. *
Fixed image loading (regression).
Fixed problem with crash recovery restoring a file twice. *
Fixed some minor memory leaks. *
Handle SIGABRT correctly. *

Initial translations to Telugu, Ukranian and Romanian. Updated translations to Arabic, Catalan, Simplified Chinese, Czech, Estonian, Finnish, Galician, Hungarian, Polish, Russian, Slovak, Turkish, Uzbek and others.

* Backported to 1.0.9

Revision history for this message
Alessio Treglia (quadrispro) wrote :
Revision history for this message
Harry Rickards (hrickards) wrote :

At Daniel: Sorry should have followed that but I incorrectly assumed that requestsync would prompt me for everything. Turned out I needed to add the -e option.

1.2.1 and 1.2.0 fix quite a few bugs that have been causing people problems (take a look at the LiVES bug tracker on Sourceforge for examples), as well as adding useful new features.

Install log:
hrickards@lucid-desktop:~$ sudo dpkg -i Downloads/li*.deb
Selecting previously deselected package libweed0.
(Reading database ... 241516 files and directories currently installed.)
Unpacking libweed0 (from .../libweed0_1.2.1-1~ppa1_i386.deb) ...
Selecting previously deselected package libweed-dev.
Unpacking libweed-dev (from .../libweed-dev_1.2.1-1~ppa1_i386.deb) ...
Selecting previously deselected package lives.
Unpacking lives (from .../lives_1.2.1-1~ppa1_i386.deb) ...
Selecting previously deselected package lives-data.
Unpacking lives-data (from .../lives-data_1.2.1-1~ppa1_all.deb) ...
Setting up libweed0 (1.2.1-1~ppa1) ...

Setting up libweed-dev (1.2.1-1~ppa1) ...
Setting up lives-data (1.2.1-1~ppa1) ...
Processing triggers for man-db ...
Setting up lives (1.2.1-1~ppa1) ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_GB.utf8.cache...
Processing triggers for desktop-file-utils ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...

Screenshot of startup window is attached. Is there a way to add more than one attachment per comment in Launchpad?

Revision history for this message
Harry Rickards (hrickards) wrote :

Screenshot of main window is attached.?field.comment=Screenshot of main window is attached.

Revision history for this message
Alessio Treglia (quadrispro) wrote :

Subscribed ubuntu-release.
Harry, thanks for your work!

Revision history for this message
salsaman (salsaman) wrote :

If you are going to sync (which I would urge you to), please apply the following high priority patches:

http://lives.svn.sourceforge.net/viewvc/lives/trunk/src/multitrack.c?r1=437&r2=456
(add offset=0 at 11195) - fixes crash in multitrack "remove first gaps"

http://lives.svn.sourceforge.net/viewvc/lives/trunk/src/events.c?r1=435&r2=481&view=patch
(fixes audio hang bug in multitrack)

http://lives.svn.sourceforge.net/viewvc/lives/trunk/src/gui.c?r1=462&r2=476
(lines 1559 and 1567 only) - fixes gui instability for some l10n translations

Thanks,
Salsaman, main developer, LiVES.

Revision history for this message
Harry Rickards (hrickards) wrote :

Could we perhaps sync 1.3.2-1 instead, which I assume includes these patches?

Revision history for this message
Alessio Treglia (quadrispro) wrote : Re: [Bug 537516] Re: Sync lives 1.2.1-1 (universe) from Debian testing (main)

On Wed, Mar 24, 2010 at 5:32 PM, Harry Rickards <email address hidden> wrote:
> Could we perhaps sync 1.3.2-1 instead, which I assume includes these
> patches?
>

Please update this report according to
https://wiki.ubuntu.com/FreezeExceptionProcess and add all missing
information.

--
Alessio Treglia <email address hidden>
Ubuntu MOTU Developer | Homepage: http://www.alessiotreglia.com
0FEC 59A5 E18E E04F 6D40 593B 45D4 8C7C DCFC 3FD0

Revision history for this message
Harry Rickards (hrickards) wrote : Re: Sync lives 1.2.1-1 (universe) from Debian testing (main)
Download full text (4.1 KiB)

Please sync 1.3.2-1 (universe) from Debian unstable (will migrate to testing in 7 days) (main).

As well as adding new features, this releases fixes quite a few bugs since the current Ubuntu version (1.1.8-2).

Upstream changelog since version 1.1.8:
Version 1.3.2 (21 Mar 2010)
---------------------------
Fix jack/pulse audio breakage in multitrack.
Add (experimental) support for firewire and TV card inputs
Faster, lossless recording of generators/inputs
Implement record pause when disc is low (user definable)
Some interface improvements for translated versions.
(Translators - please see: http://lives.sourceforge.net/TRANS-README.txt)
Fix multi_encoder file permissions
Fix minor problem with post encoding cleanup *
Fix crash in multitrack "remove first gaps" *
Fix for audio block gravity *
Fix mt auto backup thread concurrency problem
Update OSC control to work better with puredata.
Implement new player transport
Add "Gravity: Right" in multitrack
Change default extension for ogg video from "ogg" to "ogv"

Updated translations to Arabic, Brazilian Portuguese, Simplified Chinese, GB English, Estonian, French, German, Hebrew, Hungarian, Italian, Portuguese, Russian, Slovak and Ukranian.

Initial translations to Danish and Occitan.

* backported to 1.0.10

Version 1.2.2
-------------
Skipped - due to minor issues in 1.0.9 -> 1.0.10

Version 1.2.1 (27 Feb 2010)
---------------------------
Fix crash when opening ogg/theora files (regression).
Updated translations to Catalan, Finnish, Hungarian, and Spanish.

Version 1.2.0 (21 Feb 2010)
---------------------------
GUI updates for multitrack mode.
Implement drag and drop effects in multitrack mode.
Allow continuous mouse movement on multitrack timeline.
Allow timecode to be edited in multitrack mode.
Switching to->from multitrack mode maintains the layout in memory.
Allow startup in mt mode.
Better scrolling of tracks in multitrack.
Implement progressive image loading.
Change multitrack "snap mode" to "gravity left" / "gravity normal"
Allow jack transport to set play start position.
Add option of resizing frames to fit in clip editor interface.
Removed "File/Encode" ("File/Encode as" is safer)
New startup wizard for first time users.
Added Help/Troubleshoot.
Faster frame generation for realtime generators.
Add python 3 support to multi_encoder.
Add OSC commands /clip/close,/clip/copy,/clip/selection/copy,/clip/selection/cut,/clip/selection/delete,/clipboard/paste,/clipboard/insert_before,/clipboard/insert_after.
Fixed a possible bootstrap issue with weed plugins. *
Fixed an encoder/png problem. *
Fixed image loading (regression).
Fixed problem with crash recovery restoring a file twice. *
Fixed some minor memory leaks. *
Handle SIGABRT correctly. *

Initial translations to Telugu, Ukranian and Romanian. Updated translations to Arabic, Catalan, Simplified Chinese, Czech, Estonian, Finnish, Galician, Hungarian, Polish, Russian, Slovak, Turkish, Uzbek and others.

* Backported to 1.0.9

See the attached build log.

Install log:
$ sudo dpkg -i /var/cache/pbuilder/result/li*.deb
(Reading database ... 264062 files and directories currently installed.)
Preparing to replace libweed0 ...

Read more...

Revision history for this message
Harry Rickards (hrickards) wrote :

See attached screenshot of main window.

Revision history for this message
salsaman (salsaman) wrote :

Hi,
I would really like to get this synced for Lucid. Previous versions of LiVES have all had problems running on ubuntu. 1.3.2 is the first version which runs really smoothly out of the box.

Regards,
Salsaman.

Revision history for this message
StefanPotyra (sistpoty) wrote :

ACK for 1.3.2-1, please go ahead. (side note: I'm rejecting the nomination, because we use FFe bug reports instead of nominations for the current development release)

Changed in lives (Ubuntu):
status: New → Confirmed
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Thank you, Stefan!

Could you take a look at the latest debian revision and, in case it's fine, give your ACK?

 lives (1.3.2-2) unstable; urgency=low

   [ Harry Rickards ]
   * Added patch from upstream that fixes the mipsel build.
   * Added packaging exception for frei0r-plugins-dev so package builds
     on sparc64

   [ Alessio Treglia ]
   * debian/patches/makefile_am.diff: Add patch tags as per DEP-3.

summary: - Sync lives 1.2.1-1 (universe) from Debian testing (main)
+ Sync lives 1.3.2-2 (universe) from Debian testing (main)
description: updated
Changed in lives (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Harry Rickards (hrickards) wrote : Re: Sync lives 1.3.2-2 (universe) from Debian testing (main)

If we could get this synced before the Final Freeze on Thursday it would be great.

Revision history for this message
Iulian Udrea (iulian) wrote : Re: [Bug 537516] Re: Sync lives 1.2.1-1 (universe) from Debian testing (main)

You don't need another approval. The latest upload includes only patches.

Revision history for this message
Harry Rickards (hrickards) wrote : Re: Sync lives 1.3.2-2 (universe) from Debian testing (main)

Okay great. Alessio, can you sync this?

summary: - Sync lives 1.3.2-2 (universe) from Debian testing (main)
+ Sync lives 1.3.2-2 (universe) from Debian unstable (main)
description: updated
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Harry, archive-admins will do the sync.

Revision history for this message
Alessio Treglia (quadrispro) wrote :

Finally: sync request ACK'd.

Revision history for this message
Steve Langasek (vorlon) wrote :

[Updating] lives (1.1.8-2 [Ubuntu] < 1.3.2-2 [Debian])
 * Trying to add lives...
2010-04-13 00:29:00 INFO - <lives_1.3.2-2.dsc: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:29:00 INFO - <lives_1.3.2-2.diff.gz: downloading from http://ftp.debian.org/debian/>
2010-04-13 00:29:00 INFO - <lives_1.3.2.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: lives [universe] -> lives_1.1.8-2 [universe].
I: lives [universe] -> libweed0_1.1.8-2 [universe].
I: lives [universe] -> libweed-dev_1.1.8-2 [universe].
I: lives [universe] -> lives-data_1.1.8-2 [universe].

Changed in lives (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers