Unity-greeter installed by default on Lubuntu, crashing on start

Bug #918401 reported by Julien Lavergne on 2012-01-18
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Colin Watson
livecd-rootfs (Ubuntu)
High
Colin Watson
ubiquity (Ubuntu)
High
Colin Watson
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

**Workaround**
Install lxdm from tty

A simple how to for those not sure how to install from tty is:
1 - when the screen goes blank press control+alt+F1 to bring up the tty1 terminal.
2 - log into this console using your normal username and password
3 - type in "sudo apt-get install lxdm" and enter in your password
4 - type "sudo reboot"
5 - when it reboots you will need to press alt+L to get past the issue one more time
6 - change the session to Lubuntu
7 - login

It should now function as normally expected from here on in

Ubiquity crash on Lubuntu ISO daily-live 20120118

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.4
ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2
Uname: Linux 3.2.0-1-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CasperVersion: 1.291
Date: Wed Jan 18 21:36:50 2012
LiveMediaBuild: Lubuntu 12.04 "Precise Pangolin" - Alpha i386 (20111124)
ProcEnviron:
 LANGUAGE=fr_FR.UTF-8
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Julien Lavergne (gilir) wrote :
Julien Lavergne (gilir) wrote :

Removing unity-greeter solve the problem. It should not be installed on Lubuntu, I'll look at this issue.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

It doesn't look like the latest daily. Build id of this report is 20111124 and the version of ubiquity in this report is 2.9.4 while 2.9.10 is on latest daily.
Could you please double check that you used the latest daily ?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Phill Whiteside (phillw) wrote :

I used installer dated 18th Jan as built by zsync from http://cdimage.ubuntu.com/lubuntu/daily-live/current/
Also confirmed by njin (from QA-team) on 'real' hardware..

unity-greeter[1589] trap int3 ip:7fec4fbe4b3b sp:7fff55e32490 error:0

also the build useed to report the bug is 17

same errors for me in 18 on real hardware

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-meta (Ubuntu):
status: New → Confirmed
Phill Whiteside (phillw) wrote :

I'm using the amd-64 build

Phill Whiteside (phillw) on 2012-01-18
description: updated
Julien Lavergne (gilir) wrote :

Hum, right, tetsing with the real lastest, and ubiquity stop crashing.
However, unity-greeter is still installed, and lightdm is crashing when starting the new installation.

Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
summary: - Crash when installing Lubuntu
+ Unity-greeter installed by default on Lubuntu, crashing on start
Julien Lavergne (gilir) wrote :

Upgrading lightdm-gtk-greeter to 1.1.1 seems to fixed the crash problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) wrote :

@gilir, that must be in proposed?

either way i don't think it will fix the problem. originally it was described as a blank screen. this is what i got. however, if i typed in my password, i'd login. the way i see it, this is the greeter failing but the dm functioning. am i confuzzled?

Jonathan Marsden (jmarsden) wrote :

> @gilir, that must be in proposed?

No, precise-proposed is empty, which is what I would expect -- during development, -proposed is not used, as far as I know. You can't test updates to something that isn't released, you just work on the development codebase and upload. Once Precise is released, precise-proposed will be used to allow testing of proposed updates to it.

Phill Whiteside (phillw) wrote :

I grabbed and un-zipped the 1.1.1 And it *nearly* installed (Story of my life). The output is at http://pastebin.com/HKS1k1hD if someone would tell me what I'm doing wrong.

Phill Whiteside (phillw) wrote :

I can confirm post #10, the screen is blank but you can type in your password and it launches okay.

Julien Lavergne (gilir) wrote :

I uploaded teh new version temporarly to lubuntu-dev PPA : https://launchpad.net/~lubuntu-dev/+archive/staging until it's in Ubuntu repository.
Please be sure to upgrade to this version, and to remove unity-greeter

Phill Whiteside (phillw) wrote :

@Julien, how long before it arrives on ~staging?

On Thu, 19 Jan 2012, Phill Whiteside <email address hidden> wrote:

> I can confirm post #10, the screen is blank but you can type in your
> password and it launches okay.

Brings a whole new meaning to "security by obscurity" :)

Jonathan

amjjawad  (amjjawad) wrote :

Hello Everyone,

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

After running the above commands on Lubuntu 12.04 (No, I'm not testing the daily iso, this installing was done 2 weeks or more), I logged out to check the wallpaper and it's ALL black now with light gray bar at the top. I can't see anything but these two colors + the mouse cursor. That is all.

I rebooted my machine and same thing happened. Automatic Login is enabled in my case so I had to log out to see that. So, for me, I have no problem but not sure if someone with Automatic Login disabled if he/she can login or not?

Thanks!

I'm not sure if this is relevant but thought to report it here.

amjjawad  (amjjawad) wrote :

Update:
I logged out, saw the totally black screen again, typed my password, pressed Enter and I'm back to my desktop. So, entering the password blindly does work but of course that's a temp solution.

bcbc (bcbc) wrote :

I got a grey blank screen - logged in blind - system reported a crash in package colord but wouldn't report it. Probably not related but thought I'd mention it just in case. Using latest daily (19th) and wubi.

Phill Whiteside (phillw) wrote :

Wubi, so I was told, is quite unstable until about beta1 time. Although someone had successfully installed it before this bug appeared. My advice would be to subscribe to the bug and try again once the bug is fixed and the daily iso has been tested as ok.

Phill Whiteside (phillw) wrote :

I have tried installing lightdm v1.1.1 from staging and deleting unity-greeter. I could not log on. Re-installing unity-greeter via "Alt F2 - terminal" at least got me back to the black screen so I could log on. It appears that replacing unity-greeter with the lightdm-gtk-greeter v1.1.1 does not resolve this issue.

Walter Lapchynski (wxl) wrote :

Confirmed. Installing lightdm-gtk-greeter 1.1.1 provides no change. Removing unity-greeter makes it impossible to log in at all. Like Phill said, using virtual terminal to install unity-greeter and restart gets us back to where we started. This fix actually provides a new problem.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/918243

tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

Still not working, can I have my system running just installing lxdm from tty

description: updated
tags: added: workaround
Walter Lapchynski (wxl) wrote :

updates this morning:
http://paste.ubuntu.com/816825/

included:
2012-01-25 10:21:13 configure unity 5.0.0-0ubuntu3 <none>
2012-01-25 10:21:13 configure unity-greeter 0.2.0-0ubuntu5 <none>

caused repeating crash:
Jan 25 10:30:51 lubuntu acpid: client 3274[0:0] has disconnected
Jan 25 10:30:51 lubuntu acpid: client connected from 3332[0:0]
Jan 25 10:30:51 lubuntu acpid: 1 client rule loaded
Jan 25 10:30:53 lubuntu kernel: [ 241.219985] unity-greeter[3352]: segfault at c ip 00ed0090 sp bfa02690 error 4 in libindicator3.so.7.0.0[ecc000+c000]

so now the issue isn't that the greeter isn't working but lightdm still allows functionality-- it is just plain broken.

removing unity-greeter did not improve the situation.

installing unity-greeter=0.2.0-0ubuntu4 doesn't prove successful because it can't find it though it is apparently in packages:
http://packages.ubuntu.com/precise/unity-greeter

Fabio Marconi (fabiomarconi) wrote :

From today's build:

Jan 26 20:23:06 precious-lobu1 kernel: [ 103.272392] unity-greeter[4548]: segfault at 18 ip 00007faaba2bdf6c sp 00007fff4c9fd370 error 4 in libindicator3.so.7.0.0[7faaba2b9000+d000]
Jan 26 20:23:06 precious-lobu1 acpid: client 4527[0:0] has disconnected
Jan 26 20:23:06 precious-lobu1 acpid: client connected from 4584[0:0]
Jan 26 20:23:06 precious-lobu1 acpid: 1 client rule loaded
Jan 26 20:23:07 precious-lobu1 kernel: [ 104.712839] unity-greeter[4605]: segfault at 18 ip 00007f831acc1f6c sp 00007fff4ca27f80 error 4 in libindicator3.so.7.0.0[7f831acbd000+d000]
Jan 26 20:23:08 precious-lobu1 acpid: client 4584[0:0] has disconnected

repeated many times
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Walter Lapchynski (wxl) wrote :

still problems with the latest daily in its native state, with new lightdm-gtk-greeter and without unity-greeter. not fixed.

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
no longer affects: ubiquity (Ubuntu)
description: updated
Colin Watson (cjwatson) wrote :

The presence of unity-greeter in current builds is very odd. I can see it happening in the livefs build log, but germinate output doesn't show it anywhere relevant, and it doesn't have "Task: lubuntu-desktop".

I reverted the attempted seed workaround because Extra-Exclude doesn't have the semantics that the committer expected and the seed workaround in fact tests out as having no effect on the output.

Colin Watson (cjwatson) wrote :

Ah. The problem here is that the Lubuntu seeds use the "no-follow-recommends" feature, but this is not reflected in livecd-rootfs' live-build configuration. They need to match.

I'm going to attempt to fix this.

affects: lubuntu-meta (Ubuntu) → livecd-rootfs (Ubuntu)
Changed in livecd-rootfs (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.55

---------------
livecd-rootfs (2.55) precise; urgency=low

  * Build Lubuntu with --no-install-recommends, to match its seed structure
    (LP: #918401).
 -- Colin Watson <email address hidden> Thu, 02 Feb 2012 14:15:07 +0000

Changed in livecd-rootfs (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1746
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Thu 2012-02-02 14:30:30 +0000
message:
  Disable Recommends for Lubuntu installations (LP: #918401).

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Fix Released
Colin Watson (cjwatson) wrote :

A forums thread reports that some people got unity on upgrades from alpha-1 as well, which as far as I can tell is not the intention of the Lubuntu developers. I think the only solution to this for upgraders is to make a manual configuration change:

  echo 'APT::Install-Recommends "false";' | sudo tee /etc/apt/apt.conf.d/00InstallRecommends

I've reconfigured the Lubuntu alternate CDs to install this way by default, and I think you should respin Alpha 2 for that change or you'll have problems later. The desktop CDs will take a bit more work.

Colin Watson (cjwatson) on 2012-02-02
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.16

---------------
ubiquity (2.9.16) precise; urgency=low

  * Bump fallback Ubuntu version number in ubi-language to 12.04.
  * Behave a little more usefully when running over ssh with X forwarding
    such that ubiquity is unable to talk to NetworkManager. This
    configuration isn't actually supported, but is occasionally useful for
    debugging so it helps to be able to start ubiquity at the very least.
  * Configure the target system to disable installation of Recommends if
    base-installer/install-recommends is preseeded to false (LP: #918401).
  * Automatic update of included source packages: flash-kernel 2.28ubuntu39,
    partman-auto 93ubuntu19.
 -- Colin Watson <email address hidden> Thu, 02 Feb 2012 14:53:26 +0000

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
Walter Lapchynski (wxl) wrote :

i'll call this one fixed. tested it out in daily-live 20120215. unity-greeter and unity are nowhere in sight! horray!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers