Ubuntu

fresh Ubuntu install marks all packages as manually installed

Reported by Nizar Kerkeni on 2009-09-05
158
This bug affects 29 people
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Medium
Unassigned
Declined for Karmic by Robbie Williamson
Declined for Lucid by Robbie Williamson
Declined for Maverick by Robbie Williamson

Bug Description

Binary package hint: synaptic

After today update od synaptic a new state is displayed "installed (manual)" the packages displayed on this state are the same as in the "installed" state.
Joined a screen capture.

ProblemType: Bug
Architecture: amd64
Date: Sat Sep 5 02:08:54 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/sbin/synaptic
NonfreeKernelModules: nvidia
Package: synaptic 0.62.7ubuntu3
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
SourcePackage: synaptic
Uname: Linux 2.6.31-9-generic x86_64

Nizar Kerkeni (nizarus) wrote :
Nizar Kerkeni (nizarus) wrote :

package information on each state
installed (manual) : 1163 package listed, 1720 installed
installed : 1720 package listed, 1720 installed

Changed in synaptic (Ubuntu):
status: New → Confirmed

Also confirming. Redundant. I would understand if it were a list of manually installed deb files but this just lists the regular package list from the vanilla Ubuntu repos.

Was using an up-to-date Alpha 5

I tried changing the status of the packages under 'Manual' to 'Automatically Installed' by using the option in the 'Package' menu entry.

For most of them they changed without a fuss. However a few packages uninstalled key parts of the system. The only problematic packages I managed to catch were:

ubuntu-desktop
ubuntu-minimal
ubuntu-standard

There are others as well that removed more than they should have but I didn't bother remembering their names because the packages they asked to remove seemed 'reasonable' to me at the time. However, the 3 listed above will suggest you autoremove your entire system when their status is changed to 'Automatically Installed' in Synaptic, especially ubuntu-desktop.

More packages not disappearing from the 'Manual' section List so far:

couchdb
language-pack-en
language-pack-en-base
language-pack-gnome-en
language-pack-gnome-en-base
language-support-en
language-support-writing-en
linux-generic
openoffice.org-hyphenation
openoffice.org-hyphenation-en-us
openoffice.org-thesaurus-en-au
openoffice.org-thesaurus-en-us
ubuntu-desktop
ubuntu-minimal
ubuntu-standard

UF thread here: http://ubuntuforums.org/showthread.php?p=7987288#post7987288

Bug still present in the Beta.

A recent update seemed to eliminate most of the entries (which match my last post) but after rebooting they returned.

DanielRoesler (diafygi) wrote :

I can confirm this bug still exists with most updated beta. Any idea what is caused it?

Patrice Vetsel (vetsel-patrice) wrote :

Someone know where this new state come from ?

Changed in synaptic (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
Vitaliy Pomazyonkov (vitorg) wrote :

Just installed Karmic release and got this bug.
Patrice Vetsel, why is this importance is "Low"? It is megacritical bug, because it's effect can't be reverted! I'm very upset :(

Vitaliy Pomazyonkov (vitorg) wrote :

Patrice Vetsel, please, set this bug importance to "High" and assign it. This bug is 2 months old, but you still done nothing :(

Vitaliy Pomazyonkov (vitorg) wrote :

Just reinstalled Ubuntu 9.10 release and find that all packages marked as "installed (manual)" right after first system boot, so maybe it is a problem of Ubuntu installator?

Edgar Cherkasov (edgar2705) wrote :

I have the same problem.
I try install karmic in VirtualBox and packages have "Installed (manual)" status
I think, it is apt bug, because I try remove qemu packages, but its dependencies qemu-kvm not removed and not have "Installed (auto removable) status in Synaptic

P.S. I use ru.archive.ubuntu.com mirror
P.P.S. I think this bug must have "high or critical" importance

Vitaliy Pomazyonkov (vitorg) wrote :

Please, move this bug from "synaptic" to Ubuntu installator, because it is NOT Synaptic bug and so it can't be fixed by Synaptic developers.

See Michael Vogt's comment on this (emailed to me):
    This is a new state that shows what is considered manual
    installed. Its a bit confusing because during the install of ubuntu
    the installer installed stuff as "manual". This is the opposite of
    "automatic" where e.g. openoffice.org pulls in a bunch of libraries.
    If the two sets are exactly the same, then there is a bug somewhere
    (probably in the install, not in synaptic) because libraries should be
    marked as automatic.

    Cheers,
     Michael

affects: synaptic (Ubuntu) → ubiquity (Ubuntu)
Colin Watson (cjwatson) wrote :

The way things are supposed to work, as far as I can remember, is that apt is supposed to remember that we installed the ubuntu-desktop *task* (etc.) and arrange for as much of the task as possible to remain installed. I don't recall whether it in fact acts this way right now. It may be difficult to do anything about this bug.

Changed in ubiquity (Ubuntu):
importance: Low → Medium
Colin Watson (cjwatson) on 2009-11-09
affects: ubiquity (Ubuntu) → livecd-rootfs (Ubuntu)
Vitaliy Pomazyonkov (vitorg) wrote :

Is there any way to install Karmic correct way?
To fix this issue Karmic LiveCD must be rebuild with fixed version of ubiquity.

the bug is still here... how can we fix this BIG problem?

David Tombs (dgtombs) on 2010-01-08
summary: - new state "installed (manual)" on synaptic
+ fresh Ubuntu install marks all packages as manually installed
Vitaliy Pomazyonkov (vitorg) wrote :

Note that this bug is still reproduces in Lucid Alpha3. It is very critical bug for LTS because it makes all packages in system inconsistent and it can't be fixed after release.
Also it seems that this bug can be easily fixed now. Please, assign this bug to developers.

Colin Watson (cjwatson) wrote :

"It seems that this bug can be easily fixed now" - if you know of an easy fix, do enlighten us, please, preferably in the form of a patch? As far as I know my comment 14 still stands, and there is no straightforward way to fix this bug right now.

We have lived with this bug for some time, across two previous LTS releases (apt only gained the auto-mark changes in Ubuntu 6.10, but before that the installer used aptitude to install tasks and that had a similar feature). It is unfortunate, and it is a bug, and we will fix it if somebody comes up with a way to do so cleanly while getting the semantics correct, but it isn't critical (much less "megacritical" - please don't dilute the value of words by exaggerating!) and it's not worth attempting to hack a fix in when we're not certain that it has the right semantics. Leaving all packages as manually installed is unsightly but the consequences of this bug are generally limited to not managing to be clever enough to remove packages that aren't needed any more. A flaw in the reverse direction would be much worse, because it could cause packages to be removed when they are still needed. Given that there does not seem to be a clearly correct fix available, it's better to air on the side of caution.

So, please stop leaving comments about how the priority of this bug should be increased; it should not. That does not mean it is not a bug, and it does not mean that it does not matter, but it does mean that the risk of a botched "fix" is high enough, and the problems with the current situation comparatively small enough, that it does not merit High or Critical priority. Other bugs are more important. Medium priority is appropriate here, and that's what the bug has.

Colin Watson (cjwatson) wrote :

That should have been "it's better to err on the side of caution", of course. I appear to be short on sleep.

Vitaliy Pomazyonkov (vitorg) wrote :

>We have lived with this bug for some time, across two previous LTS releases
No we not. Ubuntu 8.04 (previous LTS) doesn't has this bug. It seems that bug appear only in Jaunty (i will check it in Intrepid).

Colin, please, stop leaving comments about how you don't want to know about this bug, just try to find it's cause, maybe it will not take to much time, if not, you can stop anytime.

I know several people who still using Ubuntu 8.04 because of this bug. It seems that right way to install Lucid will be: install Hardy and upgrade it to Lucid.

On Wed, Mar 17, 2010 at 07:37:37AM -0000, Vitaliy Pomazyonkov wrote:
> No we not. Ubuntu 8.04 (previous LTS) doesn't has this bug. It seems
> that bug appear only in Jaunty (i will check it in Intrepid).

We have never saved the information you're asking for in the installer.
Sure, it may be that it didn't matter much in the UI before Jaunty.

The design was always supposed to be that we'd install tasks, and apt
would remember that those tasks should stay installed. It appears that
it does not remember this - but the alternatives open to the installer
carry a variety of risks. In particular, installing metapackages would
be a pain since not all the tasks we install during installation have a
metapackage, and inconsistency carries its own risks; not to mention
that it is not clear in all cases what would happen with Recommends.

> Colin, please, stop leaving comments about how you don't want to know
> about this bug, just try to find it's cause, maybe it will not take to
> much time, if not, you can stop anytime.

You are putting words into my mouth. I did not say that I did not want
to know about this bug; I merely explained that it is not critical, and
gave my reasoning, in response to several comments asking for increased
importance. You said that it was an easy fix, and I am asking you to
back this statement up with a detailed explanation of that fix, since
having such a detailed explanation would no doubt speed up resolution of
this bug.

Note that any fix needs to make sure to defend against accidentally
declaring packages to be autoremovable when they are not.

SoRDiD (jan-sordid) wrote :

i have this bug too, its in Xubuntu 10.04 beta 2
i think i have an hint to solving this bug.
it might be related to having other languages installed (in my case German) within the installer.
if i have the time, i will try to install the same ISO with just English and see if it happens there too.

David Clayton (dcstar) wrote :

Ok, after reading the various comments and doing experiments it seems obvious that this "bug" is caused by the install process not having the appropriate "root" meta-packages that will result in all the appropriate installed packages not being categorised as "Manual".

Basically someone at Ubuntu need to create a overall meta-package for each flavour of Ubuntu (that may/may not appear in the "Installed (manual)" category) that includes all the other meta-packages etc that are installed by default.

When that is done I expect all we will then see in the "Installed (manual)" category are packages (and dependencies) that the user has installed manually - just like it is supposed to do.

I have reduced the list in my 10.04 system by manually marking most packages as "Automatically installed" in Synaptic - with the exceptions of packages listed in post #5. Basically you must leave any installed meta-package as Manual else all the installed packages inside these meta-packages will appear in the "auto-removable" list when set to "Automatically installed".

zarshark (zarshark) wrote :

I agree on David (above). I observed this bug after upgrading from karmic to lucid. Also i observed that though "Recommended Package" is selected by default in my apt configuration, there exist some package by which the relative "recommended packages" are not installed at all. Moreover, I was surprised that some package has an obviously list of recommended packages, most of them are not installed. As instance, i found the package kdm recommends metacity, e16 and a lot of packages which are clearly different neither dependent on not used by kdm at all.
So i am asking whether is it possible a lack of some recommended package determines that there are packages installed without their complete dependent package list, and so meta-packages fail?

At first sight, i don't think the problem is hard to solve and it is not related to a specific program (apt, synaptic, installer), but in a mistaken metapackage list in some meta-package. i think there is one or more metapackage with an incomplete list of dependencies OR a metapackage previously used has been discarded in the new ubuntu/kubuntu version and this was not the case for many other packages which still require that root-metapackage.
So, a solution could be to compute the graph of dependency and compare that with the list of package installed. in the graph of dependency should appear "new packages" which link the "installed (manually)" directly. These new packages are the metapackages that must be rebuild. With this solution, I don't think there would be problems (a part of course conflicts in the installation of packages) because it adds new package and does not remove existing dependencies.

I think it might be a serious problem, especially because, during upgrading from a version to the next one, if a dependency change at metapackage level for a "package suffering of this problem", there could be inchoerences in the new version for that package (e.g. it does not have all dependence installed) and the system could break. I hope to be wrong and to much pessimist, however i think it is a bug which requires to be solved asap.
Anyway, as Colin Watson said, i agree on the risk of "correcting badly that bug" could seriously damage the system, more that what it is now with this bug.

hope to be useful,

p.s.
thanks the ubuntu/kubuntu team. you are doing a good work! :D

Alexander Betaev (infestator) wrote :

still present in Natty

I found a useful workaround for this bug, at least for my purposes (adding and installing desktops cleanly).

You can start out (on a clean build) by marking everything as automatically installed, then mark your choice of manual packages afterward, checking that everything you want is retained as expected. In my case it looked like this. To mark all current 'manually installed' packages as automatic (don't leave your packages this way, else the next apt-get autoremove will wipe your system) run the following command...

aptitude --display-format '%p' search '~i!~M' | xargs -n100 sudo apt-mark auto

...and after a few iterations of...

sudo apt-get --simulate autoremove

...I verified I could use the following command to retain everything in my Ubuntu Precise system which was installed at the time. The command simply lists a few packages and metapackages to be set as manually installed, causing everything else which they depend upon to be retained.

sudo apt-mark manual ubuntu-desktop ubuntu-standard ubuntu-minimal language-pack-en-base language-pack-gnome-en language-pack-gnome-en-base libreoffice-help-en-gb thunderbird-locale-en-gb thunderbird-locale-en-us libreoffice-gnome libidl0 liborbit2 linux-headers-generic-pae hyphen-en-us installation-report linux-generic-pae mythes-en-au openoffice.org-hyphenation libreoffice-l10n-en-za linux-firmware-nonfree ubuntu-restricted-extras arduino geany gparted chromium-browser google-earth-stable google-chrome-stable synaptic

This includes some elective packages which I had installed beyond the ubuntu-desktop, (all the ones after libreoffice-l10n-en-za) and it may be that there's a better 'dependency tree' than this, especially given how many localisation packages seem to be explicitly set, but it's good enough for me. I now recognise everything in the manually installed status list in Synaptic, and can work from here to the system I explicitly want.

Kenneth Wrede (kennethwrede) wrote :

This bug seems old, but I face the same issue today in Xubuntu 12.04.3, i386.

It shouldn't affect anything(?), but just in case... I used the alt-installer and used expert mode. I didn't change the installation of packages the slightest. Just the base system and xubuntu-desktop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers