livecd-rootfs incorrectly installs core snap as implicit dep of other base snaps

Bug #1957123 reported by Steve Langasek
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
High
Steve Langasek
Focal
High
Steve Langasek

Bug Description

[Justification]
The focal and jammy desktop images include a gtk-common-themes snap which uses base: bare. This is obviously supposed to mean the snap has no external dependencies on a particular core snap. Unfortunately, the logic in livecd-rootfs is broken, and when processing the bare snap itself, seeing that it has no base: declared in its own metadata, interprets this as meaning there is an implicit dependency on the core snap and pulls in a whole separate root filesystem pointlessly.

We should:
- fix livecd-rootfs to not look for base snaps of snaps which are themselves type: base
- make it a fatal build error for focal an later to try to build an image that pulls in the core snap, since this is legacy (the Ubuntu 16.04 rootfs should not be used in Ubuntu 20.04 and later images) and it's a bad bug if it does get pulled in.

[Test case]
All daily images should build successfully for all flavors with the updated livecd-rootfs. If this change introduces any build failures, it should be reverted until the underlying problem (seeding a snap that requires 'core' as a base) can be resolved.

Related branches

Steve Langasek (vorlon)
description: updated
Steve Langasek (vorlon)
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu Focal):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Changed in livecd-rootfs (Ubuntu Focal):
assignee: nobody → Steve Langasek (vorlon)
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.751

---------------
livecd-rootfs (2.751) jammy; urgency=medium

  * Revert patch for unmounting in local builds as it is causing autopkgtest
    regressions

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 12 Jan 2022 13:43:24 -0600

Changed in livecd-rootfs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers