Unmounting fails for local builds

Bug #1952921 reported by Heinrich Schuchardt
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned

Bug Description

livecd-rootfs creates non-private mounts. When building locally using
the auto/build script unmounting fails.

To unmount dev/pts it is insufficient to make the mount private. Its
parents must be private too.

Please, change teardown_mountpoint() accordingly. Patch appended.

Related branches

Revision history for this message
Heinrich Schuchardt (xypron) wrote :
tags: added: fr-1894
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "0001-functions-fix-unmounting-for-local-builds.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
William Wilson (jawn-smith) wrote :

I had to revert this change as it was causing failures in autopkgtests. Can you look into a method for fixing this that doesn't cause autopkgtest failures?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.751

---------------
livecd-rootfs (2.751) jammy; urgency=medium

  * Revert patch for unmounting in local builds as it is causing autopkgtest
    regressions

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 12 Jan 2022 13:43:24 -0600

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers