riscv64: ensure reasonable partition alignment

Bug #1952916 reported by Heinrich Schuchardt
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned

Bug Description

Currently the RISC-V preinstalled server images come with partitions that are only 1 KiB aligned. Ext4 may use 4 KiB block size. The existing misalignment leads to decreased performance.

Please, decrease the size of the loader2 partition by 34 512-byte blocks. This results in 1 MiB alignment of the EFI and root partitions.

The remaining loader2 partition size of close to 4 MiB is still large enough for U-Boot or a future EDK II.

Related branches

Revision history for this message
Heinrich Schuchardt (xypron) wrote :
tags: added: riscv64
tags: added: fr-1893
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "0001-riscv64-ensure-reasonable-partition-alignment.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Heinrich Schuchardt (xypron) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.751

---------------
livecd-rootfs (2.751) jammy; urgency=medium

  * Revert patch for unmounting in local builds as it is causing autopkgtest
    regressions

 -- William 'jawn-smith' Wilson <email address hidden> Wed, 12 Jan 2022 13:43:24 -0600

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers