RISC-V 64 images support

Bug #1903034 reported by Dimitri John Ledkov
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Fix Released
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
Groovy
Fix Released
Undecided
Unassigned
Hirsute
Fix Released
Undecided
Unassigned

Bug Description

[Impact]

 * Add support to build risc-v 64 cpc & buildd images for LXD, cloud-images, buildd and hifive (focal-only) preinstalled image targets.

[Test Case]

 * Execute a riscv64 livefs build for the buildd subproject of ubuntu-base

 * Execute a riscv64 livefs build for the ubuntu-cpc project

 * Execute a riscv64 livefs build for the ubuntu-server preinstalled project

 * Build should succeed since we have lxd builders, and the required packages to produce the above images.

[Regression Potential]

 * Care has been taken to modify riscv64 code paths only, and correct some mistakes in the common hooks that are used to determine which image types to build (i.e. MBR images were built on ARM when they are not needed, and AMD64 MBR image is in fact needed!). This changes are now tested extensively in hirsute to ensure other image types are unaffected, and these images work correctly.

Changed in livecd-rootfs (Ubuntu Hirsute):
status: New → Fix Released
Changed in livecd-rootfs (Ubuntu Groovy):
status: New → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted livecd-rootfs into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.694.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
tags: added: verification-done verification-done-groovy
removed: verification-needed verification-needed-groovy
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Aaaaa why did you remove the groovy livefs builder before the package got released! You wiped the build history and now I can't confirm if the builds were successful as you mention they are! Oh well, I trust you though, so it's fine.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.694.1

---------------
livecd-rootfs (2.694.1) groovy; urgency=medium

  * livecd-rootfs SRU of change up to 2.699 from hirsute to groovy.

  = hyperv gallery image =
  [ Jinming Wu, Patrick ]
  * hyper-v hook: Fix writing of pkla file out to correct scratch
    directory for image build. LP: #1901846
  [ Dimitri John Ledkov ]
  * auto/config: seed ubuntu-desktop when building hyperv image LP: #1901846
  * auto/config: scope ubuntu:desktop-preinstalled:raspi image options LP: #1901846

  = CPC cloud images =
  [ Dimitri John Ledkov & Joshua Powers ]
  * amd64: always install grub-pc with shim-signed (LP: #1901906), and
    ensure to autoremove packages
  [ John Chittum ]
  * Ensure vmtools version entered into vmdk header (LP: #1893898)

  = RISC-V port =
  * control: install qemu-utils & snapd on riscv64. (LP: #1903034)

 -- Dimitri John Ledkov <email address hidden> Thu, 05 Nov 2020 11:54:14 +0000

Changed in livecd-rootfs (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Will try to not remove the livefs build for focal verification!

description: updated
Changed in livecd-rootfs (Ubuntu Focal):
status: New → In Progress
milestone: none → ubuntu-20.04.2
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Dimitri, or anyone else affected,

Accepted livecd-rootfs into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.664.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
removed: verification-done
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (livecd-rootfs/2.664.12)

All autopkgtests for the newly accepted livecd-rootfs (2.664.12) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

livecd-rootfs/2.664.12 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#livecd-rootfs

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Buildd build is a success!

The others fail because somehow ubuntu-drivers-common is not installable..... investigating.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

After tweaking seeds; and getting ubuntu-drivers-common SRU into proposed, one can now build the other two images too

SiFive https://launchpad.net/~xnox/+livefs/ubuntu/focal/any/+build/256884
CPC https://launchpad.net/~xnox/+livefs/ubuntu/focal/any/+build/256885

So this is verified.

Before turning this on, in cdimage we will need to get ubuntu-drivers-common SRU out, or build with proposed.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.664.12

---------------
livecd-rootfs (2.664.12) focal; urgency=medium

  * riscv64: backport HiFive unleashed & cloud-image building support
    (LP: #1903034)

 -- Dimitri John Ledkov <email address hidden> Fri, 15 Jan 2021 17:07:20 +0000

Changed in livecd-rootfs (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers