Generate HyperV Image Gallery Builds in Bionic and Disco

Bug #1837088 reported by David Krauser on 2019-07-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Disco
High
Unassigned

Bug Description

[Overview]

We can generate HyperV Image Gallery builds for Eoan images with livecd-rootfs, but not for Bionic and Disco. These images are necessary for users to install Ubuntu on their Windows machines from the HyperV Image Gallery:

https://ubuntu.com/blog/optimised-ubuntu-desktop-images-available-in-microsoft-hyper-v-gallery

To support this, three commits need to be backported from ubuntu/master to ubuntu/disco and ubuntu/bionic:

https://git.launchpad.net/livecd-rootfs/commit/?id=0e3b1e206b8ac24e22b49b40a0de1e16e3d412dd
https://git.launchpad.net/livecd-rootfs/commit/?id=124d07410161427222c002bec023b7d2ca03a465
https://git.launchpad.net/livecd-rootfs/commit/?id=5a2b49950af9bf407b333363ea6a5488500fbcc4

[Test Case]

These images can be built with the livecd-roottfs ubuntu/master branch by specifying the ubuntu project and the desktop-preinstalled subproject.

For example (using the ubuntu-bartender helper script in ubuntu-old-fashioned [1]):

ubuntu-old-fashioned/scripts/ubuntu-bartender/ubuntu-bartender -- --series eoan --project ubuntu --subproject desktop-preinstalled

When backported, it's expected that these images can be built for both disco and bionic with the same parameters specified:

ubuntu-old-fashioned/scripts/ubuntu-bartender/ubuntu-disco-bartender -- --project ubuntu --subproject desktop-preinstalled

ubuntu-old-fashioned/scripts/ubuntu-bartender/ubuntu-bionic-bartender -- --project ubuntu --subproject desktop-preinstalled

1: https://github.com/chrisglass/ubuntu-old-fashioned

[Regression Potential]

The binary hook used to create the HyperV image is isolated and shouldn't affect other image builds; however, that hook depends on a symbolic link to a hook in the ubuntu-cpc project. There's a possibility of future breakage if the ubuntu-cpc project hook is modified without taking into account its use in multiple places.

To enable the use of a symbolic link, some logic was changed in the live-build configuration script. Previously, all files were copied over as-is. Now, symbolic links in hook directories are dereferenced and turned into regular files. In practice, this should only have an affect on two files, and that affect should be safe:

livecd-rootfs $ find . -type l -print | grep hooks
./live-build/ubuntu/hooks/033-disk-image-uefi.binary
./live-build/ubuntu-cpc/hooks.d/base/series/all

This may cause undesired behavior for other users of livecd-rootfs, though, that inject symbolic links into their hooks directory.

Related branches

tags: added: id-5d2c8bb9ad70f8685502434c
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu Bionic):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu Disco):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
tags: added: id-5d8a793e03625a062527c720
Łukasz Zemczak (sil2100) wrote :

Reviewed, merged and sponsored. It's in the Unapproved queues now.

Hello David, or anyone else affected,

Accepted livecd-rootfs into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.578.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

Hello David, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.34 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

David Krauser (davidkrauser) wrote :

Hi brian-murray and sil2100,

I tested this with the ubuntu/disco branch today, and the image built successfully. I used ubuntu-bartender as described above to do the build.

When attempting with the ubuntu/bionic branch, however, it doesn't appear that my changes have merged in. Is that expected?

Brian Murray (brian-murray) wrote :

Hello David, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.35 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

David Krauser (davidkrauser) wrote :

Hi all, thank you for the merge. I was able to successfully build against the ubuntu/bionic branch (as described above).

Łukasz Zemczak (sil2100) wrote :

Excellent, thanks David! Marking as verified then.

Łukasz Zemczak (sil2100) wrote :

Note: normally we'd require testing the exact packages that are in -proposed to consider the verification valid, but livecd-rootfs is a very special cake. Since livecd-rootfs is just a bunch of scripts that are actually the same as per the git branch, in this case such a verification per git-branch is enough (I have actually made sure that the package contents are the same).

tags: added: verification-done verification-done-bionic verification-done-disco
removed: verification-needed verification-needed-bionic verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.578.10

---------------
livecd-rootfs (2.578.10) disco; urgency=medium

  * Add support for HyperV Gallery Images (LP: #1837088)

 -- David Krauser <email address hidden> Wed, 09 Oct 2019 15:13:28 -0400

Changed in livecd-rootfs (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.35

---------------
livecd-rootfs (2.525.35) bionic; urgency=medium

  * Did not expect the bionic branch being so outdated. Backport support
    for fetching core18 model assertions on bionic hosts. This enables build
    support for ubuntu-core 18 images. (LP: #1852332)

livecd-rootfs (2.525.34) bionic; urgency=medium

  * Add support for HyperV Gallery Images (LP: #1837088)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 12 Nov 2019 21:05:29 +0100

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers