please filter /usr/share/locales when creating minimized images

Bug #1829333 reported by Christian Ehrhardt  on 2019-05-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Medium
Steve Langasek
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Justification]
Improving the fitness for purpose of Ubuntu minimal images by continuing to remove unused files is appropriate for a livecd-rootfs SRU.

[Test case]
1. Verify that there are no autopkgtest regressions.
2. Generate a minimal tarball in launchpad (but do NOT publish to cdimage.u.c!)
3. Download the tarball and verify no files under /usr/share/locales are included.
4. Chroot to the tarball.
5. Run 'unminimize' and confirm that the command succeeds.

[Regression potential]
The unminimize command might break in some unforeseen corner case. But this code has already landed in devel and there have been no complaints so far.

[Original description]
In a discussion around image sizes it came up that our images still have locales in
  /usr/share/locales

Since my words seem to be misleading I'm quoting Steve on this:
"ok, now I see what you mean about locales. yes, since we do not support non-English locales in the minimized images, we should also filter out the apt translations from /usr/share/locales. Please file a bug on livecd-rootfs for this."

^^ this bug here :-)

Late on mwhudson said - "All done now"
But I wasn't sure if that also included the locales.

Better an extra bug that is quickly closed than one we forgot to fix.

FYI: /usr/share/locales have 7MB in ubuntu:latest as of 15th of May

Ah sorry for imprecision, I was indeed only referring to the apt bits.

On Thu, 16 May 2019, 18:25 Christian Ehrhardt , <email address hidden>
wrote:

> FYI: /usr/share/locales have 7MB in ubuntu:latest as of 15th of May
>
> --
> You received this bug notification because you are a member of Canonical
> Cloudware, which is subscribed to livecd-rootfs in Ubuntu.
> https://bugs.launchpad.net/bugs/1829333
>
> Title:
> please filter /usr/share/locales when creating minimized images
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/livecd-rootfs/+bug/1829333/+subscriptions
>

tags: added: id-5cdd06dc16ebf02310f65870
Steve Langasek (vorlon) on 2019-05-17
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Steve Langasek (vorlon)
Steve Langasek (vorlon) on 2019-05-28
Changed in livecd-rootfs (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.587

---------------
livecd-rootfs (2.587) eoan; urgency=medium

  * Strip translation files out of the minimal images, another thing that
    goes unused when there is no human console user (and we already don't
    have the locales themselves present on a minimal image). LP: #1829333.

 -- Steve Langasek <email address hidden> Tue, 28 May 2019 08:40:42 -0700

Changed in livecd-rootfs (Ubuntu):
status: Fix Committed → Fix Released

An upload of livecd-rootfs to disco-proposed has been rejected from the upload queue for the following reason: "Upload carries an UNRELEASED version (2.578.5), which is not included in the .changes file. Missing SRU information in the attached bug.".

Hello Christian, or anyone else affected,

Accepted livecd-rootfs into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.578.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in livecd-rootfs (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Adam Conrad (adconrad) wrote :

Hello Christian, or anyone else affected,

Accepted livecd-rootfs into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.542.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Adam Conrad (adconrad) wrote :

Hello Christian, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.26 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Steve Langasek (vorlon) on 2019-06-03
description: updated
Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon) wrote :

not marking verification-done yet for disco because there is an outstanding autopkgtest failure that is being retried.

Steve Langasek (vorlon) wrote :
tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Steve Langasek (vorlon) wrote :
tags: added: verification-done-bionic
removed: verification-needed-bionic
Steve Langasek (vorlon) wrote :

disco autopkgtests resolved.

tags: added: verification-done-disco
removed: verification-needed-disco
Balint Reczey (rbalint) wrote :

Setting verification-done, too, since it is complete with Disco.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.542.5

---------------
livecd-rootfs (2.542.5) cosmic; urgency=medium

  * Strip translation files out of the minimal images, another thing that
    goes unused when there is no human console user (and we already don't
    have the locales themselves present on a minimal image). LP: #1829333.

 -- Steve Langasek <email address hidden> Tue, 28 May 2019 08:51:17 -0700

Changed in livecd-rootfs (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.578.5

---------------
livecd-rootfs (2.578.5) disco; urgency=medium

  [ Balint Reczey ]
  * Build WSL rootfs tarball (LP: #1827930)

  [ Steve Langasek ]
  * Strip translation files out of the minimal images, another thing that
    goes unused when there is no human console user (and we already don't
    have the locales themselves present on a minimal image). LP: #1829333.

 -- Steve Langasek <email address hidden> Thu, 30 May 2019 12:13:55 -0700

Changed in livecd-rootfs (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.26

---------------
livecd-rootfs (2.525.26) bionic; urgency=medium

  * Strip translation files out of the minimal images, another thing that
    goes unused when there is no human console user (and we already don't
    have the locales themselves present on a minimal image). LP: #1829333.

 -- Steve Langasek <email address hidden> Tue, 28 May 2019 08:54:04 -0700

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers