[SRU] Please generate tarball for WSL

Bug #1827930 reported by Balint Reczey on 2019-05-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Balint Reczey
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

 * The tarball for Ubuntu WSL Windows Store apps is repacked from the ${release}-server-cloudimg-amd64-root.tar.xz tarball with a few minor changes as part or the appx build process. Since more customization is planned for the WSL tarball livecd-rootfs' code is a better place for maintaining them.

[Test Case]

 * Check livecd-rootfs autopkgtest output and observe the wsl tarball being generated among other non-minimal images. When building minimal images the WSL tarball should not be built.
 * Optionally use the built tarball to build the Ubuntu WSL app and verify that it can be installed on Windows 10.

[Regression Potential]

 * Since this is a separate tarball to be built there are no expected regressions affecting other images.

[Other Info]
 * At the moment only LTS releases are released to the Microsoft Store thus SRUs to Disco and Cosmic can be skipped as they won't be used. There is an ongoing discussion on whether we make Disco available or if so with which additional changes.

Related branches

Balint Reczey (rbalint) on 2019-05-06
Changed in livecd-rootfs (Ubuntu):
status: New → In Progress
assignee: nobody → Balint Reczey (rbalint)
tags: added: id-5ca4e00e768f3b71d2a5c6af
Balint Reczey (rbalint) on 2019-05-13
description: updated
Balint Reczey (rbalint) on 2019-05-17
description: updated
description: updated

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.24 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Timo Aaltonen (tjaalton) wrote :

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.46 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Balint Reczey (rbalint) wrote :

Verified livecd-rootfs/2.408.46 on Xenial:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/arm64/l/livecd-rootfs/20190517_164838_751fa@/log.gz
...
16K livecd.ubuntu-cpc.wsl.rootfs.manifest
184M livecd.ubuntu-cpc.wsl.rootfs.tar.gz
...
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/l/livecd-rootfs/20190517_155655_751fa@/log.gz
...
16K livecd.ubuntu-cpc.wsl.rootfs.manifest
199M livecd.ubuntu-cpc.wsl.rootfs.tar.gz
...

Verified livecd-rootfs/2.525.24 on Bionic:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/l/livecd-rootfs/20190517_154233_ad065@/log.gz
...
16K livecd.ubuntu-cpc.wsl.rootfs.manifest
221M livecd.ubuntu-cpc.wsl.rootfs.tar.gz
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/arm64/l/livecd-rootfs/20190517_163150_ad065@/log.gz
...
16K livecd.ubuntu-cpc.wsl.rootfs.manifest
212M livecd.ubuntu-cpc.wsl.rootfs.tar.gz
...

tags: added: verification-done verification-done-bionic verification-done-xenial
removed: verification-needed verification-needed-bionic verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.584

---------------
livecd-rootfs (2.584) eoan; urgency=medium

  * Build WSL rootfs tarball (LP: #1827930)

 -- Balint Reczey <email address hidden> Thu, 16 May 2019 23:01:13 +0200

Changed in livecd-rootfs (Ubuntu):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

Since this is verified, change small enough and only affecting image builds, let me release this early as per uploader request.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.24

---------------
livecd-rootfs (2.525.24) bionic; urgency=medium

  * Build WSL rootfs tarball (LP: #1827930)

 -- Balint Reczey <email address hidden> Fri, 17 May 2019 15:11:42 +0200

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.46

---------------
livecd-rootfs (2.408.46) xenial; urgency=medium

  * Build WSL rootfs tarball (LP: #1827930)

 -- Balint Reczey <email address hidden> Fri, 17 May 2019 15:14:38 +0200

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.578.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
removed: verification-done
Balint Reczey (rbalint) wrote :

Verified livecd-rootfs/2.578.5 on Disco:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-disco/disco/amd64/l/livecd-rootfs/20190604_011227_29089@/log.gz :
...
16K livecd.ubuntu-cpc.wsl.rootfs.manifest
363M livecd.ubuntu-cpc.wsl.rootfs.tar.gz
...

tags: added: verification-done-disco
removed: verification-needed-disco
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.578.5

---------------
livecd-rootfs (2.578.5) disco; urgency=medium

  [ Balint Reczey ]
  * Build WSL rootfs tarball (LP: #1827930)

  [ Steve Langasek ]
  * Strip translation files out of the minimal images, another thing that
    goes unused when there is no human console user (and we already don't
    have the locales themselves present on a minimal image). LP: #1829333.

 -- Steve Langasek <email address hidden> Thu, 30 May 2019 12:13:55 -0700

Changed in livecd-rootfs (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers