Snaps not included in image manifests

Bug #1805497 reported by Cody Shepherd on 2018-11-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]

 * Snaps are not included in manifests for cloud images for those releases where snaps are pre-seeded (Xenial & Bionic)

 * Snaps should appear in the manifests for (mf)diff purposes.

 * Note that this issue has been fixed already in Cosmic and newer.

[Test Case]

 * Build Xenial or Bionic image and note that snaps are not included in the manifest.

[Regression Potential]

 * Manifest could continue to be incorrect

 * Image build could fail

[Other Info]

 * None

Scott Moser (smoser) wrote :

Is this change expected to appear in Stable Releases? Does it conform to Stable Release Updates policy?

On Thu, Nov 29, 2018 at 05:53:26PM -0000, Scott Moser wrote:
> Is this change expected to appear in Stable Releases?

Since snaps are now being shipped in images for stable releases as well, and
as a result their manifests are currently incomplete, yes.

> Does it conform to Stable Release Updates policy?

In my view, yes.

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Cody, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.42 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Steve Langasek (vorlon) wrote :

We aren't building daily xenial ISOs currently (since we're past the last point release), but I checked the log for the latest bionic daily:

https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/bionic/ubuntu/+build/154102/+files/buildlog_ubuntu_bionic_amd64_ubuntu_BUILDING.txt.gz

and it looks like this is verification-failed, because the log shows livecd-rootfs 2.525.12 from -proposed being used, but http://cdimage.ubuntu.com/bionic/daily-live/20190110/bionic-desktop-amd64.manifest doesn't show the snaps (e.g. gnome-system-monitor).

Marking v-failed.

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Cody Shepherd (codyshepherd) wrote :

Please note that for now this bug only applies to cloud images.

description: updated
Łukasz Zemczak (sil2100) wrote :

Cody, could you please verify if this works for cloud images now? If yes, could you please set the tags to verification-done-bionic?

tags: added: verification-done-bionic
removed: verification-failed-bionic
Cody Shepherd (codyshepherd) wrote :

Verification done for Bionic and Xenial.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.12

---------------
livecd-rootfs (2.525.12) bionic; urgency=medium

  * Key netplan delegation to NetworkManager on presence of
    /usr/sbin/NetworkManager, not on /usr/lib/NetworkManager which may have
    hooks from other packages (i.e., wpasupplicant).

  [ Cody Shepherd ]
  * Include snaps in image manifests (LP: #1805497)
  * Change call to add grub efi packages using new create_manifests()
    function.

 -- Steve Langasek <email address hidden> Mon, 10 Dec 2018 12:46:46 -0800

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.42

---------------
livecd-rootfs (2.408.42) xenial; urgency=medium

  [ Cody Shepherd ]
  * Backport adding snaps to image manifests (LP: #1805497)

 -- Steve Langasek <email address hidden> Mon, 10 Dec 2018 10:21:47 -0800

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers