Pollinate missing from xenial minimal images

Bug #1779406 reported by Francis Ginther on 2018-06-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Critical
Francis Ginther
Xenial
Critical
Unassigned

Bug Description

[Impact]

Pollinate will not be present in the xenial minimal images when first booted and the random number seeding that it performs will be absent.

[Test Case]

Boot an unmodified xenial minimal image from date serial 20180628 or older (for example [1]). Run `apt-cache policy pollinate` and note that it is not installed.

[1] http://cloud-images.ubuntu.com/minimal/daily/xenial/20180628/

[Regression Potential]

The regression risk should be very minimal. The only change being made here is to not remove the vim-common package, which keeps pollinate in place. Pollinate is already present in the base cloud images and all bionic images (including minimal).

[Other Info]

This change was tested by doing a full build of all ubuntu-cpc images in launchpad.

Related branches

Changed in livecd-rootfs (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Francis Ginther (fginther)

Hello Francis, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.34 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Francis Ginther (fginther) wrote :

Found an issue while examining build logs that causes a failure to build minimal cloud images. Not sure how I missed it earlier.

I've marked this verification-failed-xenial.

tags: added: verification-failed-xenial
Francis Ginther (fginther) wrote :

The second merge proposal resolve the issue found during verification:

https://code.launchpad.net/~fginther/livecd-rootfs/xenial-proposed-fix-pollinate-install/+merge/348868

Łukasz Zemczak (sil2100) wrote :

Hello Francis, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.36 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed-xenial
Philip Roche (philroche) wrote :

I have verified xenial using a locally created test image.

Test image [1] was created using ubuntu-old-fashioned [2] and the proposed branch of livecd-rootfs.

[1] https://private-fileshare.canonical.com/~philroche/unminimize-verification-20180704/xenial/
[2] https://github.com/chrisglass/ubuntu-old-fashioned/

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.36

---------------
livecd-rootfs (2.408.36) xenial; urgency=medium

  * Update unminimize script text and install ubuntu-standard when
    unminimizing a minimal image (LP: #1778777)

livecd-rootfs (2.408.35) xenial; urgency=medium

  * Fix the install command for pollinate which is added back to minimal
    images (LP: #1779406)

livecd-rootfs (2.408.34) xenial; urgency=medium

  * Add back pollinate for minimal after it is removed due to a dependency
    on vim-common. LP: #1779406.

 -- Francis Ginther <email address hidden> Mon, 02 Jul 2018 16:42:18 -0500

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

no longer affects: livecd-rootfs (Ubuntu Xenial)
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Released
Changed in livecd-rootfs (Ubuntu):
status: In Progress → Fix Released
Changed in livecd-rootfs (Ubuntu Xenial):
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers