unminimize script is not restoring man-db

Bug #1778777 reported by Francis Ginther on 2018-06-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Running the unminimize script from a minimal image (20180625 serial) results in a system that is missing man-db and potentially additional packages form ubuntu-standard. The script does restore the man pages, but an additional step of installing man-db is required to use them.

This applies to the 20180625 serial for both xenial and bionic.

The expectation is that unminimize would install man in addition to restoring the man pages.

Are there other packages from ubuntu-standard that should also be installed during unminimize?

[Impact]

 * Users running the unminimized script on a minimal image may be confused by the end result. The unminimize text indicates "restores the content and packages that are found on a default Ubuntu server system", but this is not the case as only the existing packages are restored plus ubuntu-minimal.

[Test Case]

 * Run the unminimize script from a minimal image.

[Regression Potential]

 * The changes only impact the unminimize script written to minimal images. As such it will only impact minimal images and only users wishing to rehydrate the image.

[Other Info]

 * Cloud images have been built using the linked livecd-rootfs branches. The kvm images are available under https://people.canonical.com/~fginther/minimal/

Related branches

summary: - unminimize script is not restoring to ubuntu-server
+ unminimize script is not restoring man-db
Patricia Gaughen (gaughen) wrote :

Workaround for the specific issue is to 'apt install man-db'.

description: updated
description: updated
tags: added: id-5b3530321a6de28db49ec39b
description: updated

Hello Francis, or anyone else affected,

Accepted livecd-rootfs into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.525.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Francis, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.36 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Łukasz Zemczak (sil2100) wrote :

Since cosmic is not a target for this feature, I have accepted the bionic and xenial SRUs before cosmic. The merge proposal for the development series has been merged in trunk and staged for release with the nearest livecd-rootfs update - so it will eventually appear in cosmic anyway. Not blocking on that.

Philip Roche (philroche) wrote :

I have verified bionic using a locally created test image.

Test image [1] was created using ubuntu-old-fashioned [2] and the proposed branch of livecd-rootfs.

[1] https://private-fileshare.canonical.com/~philroche/unminimize-verification-20180704/bionic/
[2] https://github.com/chrisglass/ubuntu-old-fashioned/

tags: added: verification-done-bionic
removed: verification-needed-bionic
Philip Roche (philroche) wrote :

I have verified xenial using a locally created test image.

Test image [1] was created using ubuntu-old-fashioned [2] and the proposed branch of livecd-rootfs.

[1] https://private-fileshare.canonical.com/~philroche/unminimize-verification-20180704/xenial/
[2] https://github.com/chrisglass/ubuntu-old-fashioned/

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.525.2

---------------
livecd-rootfs (2.525.2) bionic; urgency=medium

  * Update unminimize script text and install ubuntu-standard when
    unminimizing a minimal image (LP: #1778777)

 -- Francis Ginther <email address hidden> Mon, 02 Jul 2018 13:27:15 -0500

Changed in livecd-rootfs (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.36

---------------
livecd-rootfs (2.408.36) xenial; urgency=medium

  * Update unminimize script text and install ubuntu-standard when
    unminimizing a minimal image (LP: #1778777)

livecd-rootfs (2.408.35) xenial; urgency=medium

  * Fix the install command for pollinate which is added back to minimal
    images (LP: #1779406)

livecd-rootfs (2.408.34) xenial; urgency=medium

  * Add back pollinate for minimal after it is removed due to a dependency
    on vim-common. LP: #1779406.

 -- Francis Ginther <email address hidden> Mon, 02 Jul 2018 16:42:18 -0500

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.533

---------------
livecd-rootfs (2.533) cosmic; urgency=medium

  [ Robert C Jennings ]
  * ubuntu-cpc: Remove git-man for minimized images
  * Disable checksum generation

  [ Colin Watson ]
  * live-build/auto/config: Drop "lp-*" hostname filter for Launchpad
    builders, since LP #1747015 is now fixed; "*.buildd" should be enough.

  [ Francis Ginther ]
  * Update unminimize script text and install ubuntu-standard when
    unminimizing a minimal image (LP: #1778777)

 -- Adam Conrad <email address hidden> Wed, 18 Jul 2018 11:06:54 -0600

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers