Long delay on boot without any feedback is disconcerting

Bug #1750873 reported by Mark Shuttleworth on 2018-02-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
subiquity
High
Unassigned
livecd-rootfs (Ubuntu)
Undecided
Unassigned

Bug Description

On boot, I saw the accessibility prompt (keyboard and davinci-man) and then had a very long wait with a black screen, flashing cursor and no prompt until the 18.04 robot-dot plymouth boot splash came up. Is this the boot time? Can plymouth come up sooner?

Related branches

Steve Langasek (vorlon) on 2018-03-07
Changed in subiquity:
importance: Undecided → High
Michael Hudson-Doyle (mwhudson) wrote :

Step 1: investigate and time things so we can quantify the problem and any improvements we make.

Changed in subiquity:
status: New → Triaged
tags: added: id-5a9fa372b59e78cb69e10cbe
Michael Hudson-Doyle (mwhudson) wrote :

I think about half of the delay is spent unpacking the initramfs, suggesting that switching to lz4 or gzip compression instead of the current lzma might help significantly (this sounds familiar from other contexts...)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.521

---------------
livecd-rootfs (2.521) bionic; urgency=medium

  * In subiquity image, mount additional squashfs in /media.

livecd-rootfs (2.520) bionic; urgency=medium

  * Make lzma initramfs compression opt-in rather than opt-out, and do not
    opt-in to it for live-server builds to speed up the boot. (LP: #1750873)

 -- Dimitri John Ledkov <email address hidden> Wed, 11 Apr 2018 14:20:27 +0200

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers