livecd-rootfs fails in lxd container because mounts under /dev are not unmounted

Bug #1716465 reported by Steve Langasek on 2017-09-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[SRU Justification]
After the move of livefs builds to lxd containers, cloud image builds will fail because loop devices are separate mount points set up by lxd and are not getting bind mounted correctly into the livecd-rootfs chroot, therefore they are not present at the right point for kpartx -d to run to free the devices.

This is fixed by mount --rbind of /dev instead of mount --bind, which then also requires changes for the unwinding.

[Test case]
Daily images on cloud-images.ubuntu.com are currently failing to build as a result of this bug. The daily images are built using a private overlay on top of the livecd-rootfs in the archive, so unfortunately we can't describe directly a public end-to-end test case for this.

We will verify this fix by verifying that we are able to produce daily cloud images again for each of the releases.

[Regression potential]
For xenial we should also verify this change by doing a test build of all images against xenial-proposed to guard against any possible regressions.
For zesty, there are no ongoing builds of any projects other than cloud images so there is no risk of external regressions.

Steve Langasek (vorlon) wrote :

fixed in livecd-rootfs 2.453, currently in artful-proposed.

Changed in livecd-rootfs (Ubuntu):
status: New → Fix Committed
Steve Langasek (vorlon) on 2017-09-11
description: updated

Hello Steve, or anyone else affected,

Accepted livecd-rootfs into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.441.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-zesty
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Steve, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.15 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Robert C Jennings (rcj) wrote :

I have verified artful and zesty, those livecd-rootfs proposed packages have been used to build the ubuntu-cpc projects on all supported architectures without issue.

tags: added: verification-done verification-done-zesty
removed: verification-needed verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.453

---------------
livecd-rootfs (2.453) artful; urgency=medium

  [ Chris Glass ]
  * Create vagrant user for vagrant image, per upstream requirements.

  [ Colin Watson ]
  * Mount and unmount /dev recursively, to cope with setups where there are
    interesting bind-mounts under /dev (e.g. loop devices bind-mounted by
    LXD). LP: #1716465.

 -- Steve Langasek <email address hidden> Mon, 11 Sep 2017 11:39:11 -0700

Changed in livecd-rootfs (Ubuntu):
status: Fix Committed → Fix Released
Robert C Jennings (rcj) wrote :

I have verified xenial 2.408.16 does build the ubuntu-cpc project on all supported architectures.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.441.5

---------------
livecd-rootfs (2.441.5) zesty; urgency=medium

  [ Colin Watson ]
  * Mount and unmount /dev recursively, to cope with setups where there are
    interesting bind-mounts under /dev (e.g. loop devices bind-mounted by
    LXD). LP: #1716465.

  [ Balint Reczey ]
  * Fix suppression of kpartx error. LP: #1684090.

 -- Steve Langasek <email address hidden> Mon, 11 Sep 2017 11:59:59 -0700

Changed in livecd-rootfs (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.16

---------------
livecd-rootfs (2.408.16) xenial; urgency=medium

  * live-build/ubuntu-cpc/functions: call apt-get update in the chroot
    after mounting a blank /var/lib/apt, so that further operations work
    as expected; otherwise, 'apt-get purge ^grub-.*' fails on s390x because
    no such packages are known to apt.
  * live-build/ubuntu-cpc/hooks/030-root-tarball.binary: correct a missing
    unmount of /var/{lib,cache}/apt on cleanup, detected via autopkgtests.

 -- Steve Langasek <email address hidden> Tue, 12 Sep 2017 13:25:58 -0700

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers