Please add autopkgtest tests for livecd-rootfs

Bug #1690440 reported by Balint Reczey on 2017-05-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[Impact]

* Having a working autopkgtest simplifies testing of future changes including
  package SRUs thus backporting both the new autopkgtest test and the fix
  making it succeed on every architecture seems to be beneficial.
  (SRU-ing the test was suggested here: https://code.launchpad.net/~rbalint/livecd-rootfs/livecd-rootfs-autopkgtest/+merge/322322/comments/845316 )

[Test Case]

* Run the autopkgtest test itself. It also covers the parts needed to be
  changed for making the test pass, including the part changed in this bug.

[Regression Potential]

* Livecd-rootfs scripts had to be changed to make the autopkgtest test pass.
  The changes could make livecd-rootfs generate broken/invalid images, but
  this is highly unlikely because changes with regressions would also break
  the test.

Related branches

Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Trusty):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Xenial):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released

hello @rbalint, ping? do you want an upload?

Balint Reczey (rbalint) wrote :

Hi @LocotusOfBorg,
thanks, it is not urgent and the patches need to be merged first in bzr.
(Adding Steve. :-))

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Łukasz Zemczak (sil2100) wrote :

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.208.14 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Trusty):
status: New → Fix Committed

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Steve Langasek (vorlon) wrote :
tags: added: verification-done-trusty
removed: verification-needed
tags: added: verification-done-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.13

---------------
livecd-rootfs (2.408.13) xenial; urgency=medium

  [ Balint Reczey ]
  * Source ubuntu-cpc functions from the right place
  * Use all config hooks from the proper place, not from /build/
  * Add basic but configurable autopkgtest (LP: #1690440)
  * sync before calling kpartx to let writing to loop devices finish
  * wrap kpartx and trap spurious errors, to work around kpartx
    unreliability.

 -- Steve Langasek <email address hidden> Tue, 06 Jun 2017 21:52:21 -0700

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package livecd-rootfs - 2.208.14

---------------
livecd-rootfs (2.208.14) trusty; urgency=medium

  [ Robert C. Jennings ]
  * Add ubuntu-cpc project (LP: #1693018)

    [ Daniel Watkins ]
    * Move building of all architecture-specific CPC artifacts into Launchpad
      - Fixup virtual FLAVOUR kernel name

    [ Oliver Grawert ]
    * added additional CPC build targets:
      - added manifest generation for squashfs and root.tar.gz
      - added VMDK generation
      - added OVA generation from VMDK's
      - added generic Vagrant image generation

    [ Ben Howard ]
    * Fix typo in ubuntu-cpc preventing non-intel builds.
    * add devpts-live to hook builds
    * add logic to settle the disks after UEFI builds
    * extended hooks/functions to support creation of derivative images
    * including mounting images.
    * added the ability to create qcow2 images in hooks/functions
    * simplified loop clean-up in hooks/functions
    * removed assumption that disk1.img would be built
    * switched qcow2 generation to use hooks/functions function

    [ Daniel Watkins ]
    * Produce OVA files for i386 cloud builds.

    [ Ben Howard ]
    * Remove unneeded packages from the root.tar.{gz,xz} cloud image targets

    [ Daniel Watkins ]
    * Install grub in ppc64el cloud images so they are bootable

    [ Daniel Watkins ]
    * Set timeout options so ppc64el cloud images don't display a grub boot
      menu (matching the behaviour of other cloud images).
    * Specify a regex to run-parts so that cloud image extra scripts are found
      and executed.

    [ Steve Langasek ]
    * Refactor/reorder ubuntu-cpc support for consistency with other flavors,
      so that subarch overrides can be applied correctly.

    [ Ben Howard ]
    * fixed loop setup due to change of kpartx output
    * only use grub-install logic for Intel architectures

    [ Steve Langasek ]
    * Refactor some non-idiomatic architecture handling in
      live-build/ubuntu-cpc/hooks/999-cpc-fixes.chroot that also misidentifies
      the architecture name for armhf.

    [ Steve Langasek ]
    * Add hooks to ubuntu-cpc to divert /bin/sync in the chroot and undivert it
      at the end. This is a general-purpose change that should be applied to
      all flavors and archs, but at the moment it's only needed on armhf+raspi2
      to work around the raspberrypi2-firmware postinst calling sync, which is
      actually warranted in the normal case.
    * If a subarch is specified for a cloud image build, don't build rootfs
      artifacts; these should come from the 'generic' build.
    * Fix architecture handling in hooks. We know we're always being invoked
      from a launchpad-buildd-like setup, which passes ARCH and SUBARCH in the
      environment, because auto/config and auto/build both rely on this. So
      don't scatter dpkg --print-architecture calls throughout, especially
      when many of these are not cross-build-aware.
    * Refactor ubuntu-cpc hooks to allow us to handle images where the root
      partition should not be partition 1.

    [ Ben Howard ]
    * ubuntu-cpc: fix hooks/032-disk-image.binary call to
      create_empty_p...

Read more...

Changed in livecd-rootfs (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers