Autopkgtest is failing on most architectures, ppc64el passes

Bug #1684090 reported by Balint Reczey on 2017-04-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
Medium
Unassigned
Declined for Trusty by Brian Murray
Xenial
Undecided
Unassigned
Yakkety
Medium
Unassigned
Zesty
Medium
Unassigned

Bug Description

http://autopkgtest.ubuntu.com/packages/livecd-rootfs

Log part from amd64:
...
+ udevadm settle
+ '[' -n /dev/mapper/loop0p1 -a -b /dev/mapper/loop0p1 ']'
+ '[' -e /etc/mtab ']'
+ apt-get -qqy install zerofree
+ e2fsck -y -E discard /dev/mapper/loop0p1
e2fsck 1.43.4 (31-Jan-2017)
cloudimg-rootfs: clean, 63584/274176 files, 284703/548091 blocks
+ zerofree /dev/mapper/loop0p1
+ rmdir mountpoint
+ clean_loops
+ '[' -n binary/boot/disk-uefi.ext4 ']'
+ kpartx -v -d binary/boot/disk-uefi.ext4
device-mapper: remove ioctl on loop0p1 failed: Device or resource busy
del devmap : loop0p15
del devmap : loop0p14
loop deleted : /dev/loop0
+ clean_loops
+ '[' -n binary/boot/disk-uefi.ext4 ']'
+ kpartx -v -d binary/boot/disk-uefi.ext4
device-mapper: remove ioctl on loop0p1 failed: Device or resource busy
loop deleted : /dev/loop0
E: config/hooks/033-disk-image-uefi.binary failed (exit non-zero). You should check for errors.
P: Begin unmounting filesystems...
...

[Impact]

* Having a working autopkgtest simplifies testing of future changes including
  package SRUs thus backporting both the new autopkgtest test and the fix
  making it succeed on every architecture seems to be beneficial.
  (SRU-ing the test was suggested here: https://code.launchpad.net/~rbalint/livecd-rootfs/livecd-rootfs-autopkgtest/+merge/322322/comments/845316 )

[Test Case]

* Run the autopkgtest test itself. It also covers the parts needed to be
  changed for making the test pass, including the part changed in this bug.

[Regression Potential]

* Livecd-rootfs scripts had to be changed to make the autopkgtest test pass.
  The changes could make livecd-rootfs generate broken/invalid images, but
  this is highly unlikely because changes with regressions would also break
  the test.

Related branches

Balint Reczey (rbalint) on 2017-04-19
Changed in livecd-rootfs (Ubuntu):
assignee: nobody → Balint Reczey (rbalint)
Balint Reczey (rbalint) on 2017-05-03
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
Balint Reczey (rbalint) on 2017-05-03
Changed in livecd-rootfs (Ubuntu):
assignee: Balint Reczey (rbalint) → nobody
Balint Reczey (rbalint) on 2017-05-11
description: updated
description: updated
Balint Reczey (rbalint) wrote :

The last kpartx-releated fix will be released to Artful in 2.445, the SRU-s need to wait for that to strictly follow the SRU process.

I don't understand why xenial and trusty are declined. is this a mistake?

no longer affects: livecd-rootfs (Ubuntu Xenial)
Balint Reczey (rbalint) wrote :

SRUs for older releases are tracked in LP: #1690440

no longer affects: livecd-rootfs (Ubuntu Xenial)
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in livecd-rootfs (Ubuntu Zesty):
importance: Undecided → Medium

hello @rbalint, ping? do you want an upload?

Steve Langasek (vorlon) wrote :

not failing on yakkety, because the autopkgtest doesn't yet exist there.

Changed in livecd-rootfs (Ubuntu Yakkety):
status: New → Invalid
Steve Langasek (vorlon) on 2017-06-07
Changed in livecd-rootfs (Ubuntu Zesty):
status: New → In Progress

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.441.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed

autopkgtest for livecd-rootfs/2.441.4: amd64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
so far so good!

tags: added: verification-done-zesty
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.441.4

---------------
livecd-rootfs (2.441.4) zesty; urgency=medium

  [ Balint Reczey ]
  * wrap kpartx and trap spurious errors, to work around kpartx
    unreliability as seen in autopkgtests. (LP: #1684090)

  [ Steve Langasek ]
  * Mark autopkgtests isolation-machine since debootstrap won't work in a
    container.

 -- Steve Langasek <email address hidden> Tue, 06 Jun 2017 23:09:10 -0700

Changed in livecd-rootfs (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Steve Langasek (vorlon) wrote :

Reopening this because although the autopkgtests have managed to pass, the test is still racy and we aren't correctly capturing the error message; we were grepping for 'loop deleted:' but the actual message (as shown in the bug log) is 'loop deleted : /dev/loop0'.

Fix is inbound.

Changed in livecd-rootfs (Ubuntu Zesty):
status: Fix Released → In Progress

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.441.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Zesty):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-zesty
removed: verification-done-zesty
Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Balint, or anyone else affected,

Accepted livecd-rootfs into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/livecd-rootfs/2.408.15 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Steve Langasek (vorlon) wrote :

The autopkgtests are passing on xenial and zesty.

tags: added: verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.441.5

---------------
livecd-rootfs (2.441.5) zesty; urgency=medium

  [ Colin Watson ]
  * Mount and unmount /dev recursively, to cope with setups where there are
    interesting bind-mounts under /dev (e.g. loop devices bind-mounted by
    LXD). LP: #1716465.

  [ Balint Reczey ]
  * Fix suppression of kpartx error. LP: #1684090.

 -- Steve Langasek <email address hidden> Mon, 11 Sep 2017 11:59:59 -0700

Changed in livecd-rootfs (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.16

---------------
livecd-rootfs (2.408.16) xenial; urgency=medium

  * live-build/ubuntu-cpc/functions: call apt-get update in the chroot
    after mounting a blank /var/lib/apt, so that further operations work
    as expected; otherwise, 'apt-get purge ^grub-.*' fails on s390x because
    no such packages are known to apt.
  * live-build/ubuntu-cpc/hooks/030-root-tarball.binary: correct a missing
    unmount of /var/{lib,cache}/apt on cleanup, detected via autopkgtests.

 -- Steve Langasek <email address hidden> Tue, 12 Sep 2017 13:25:58 -0700

Changed in livecd-rootfs (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers