Try harder to make sure that kernel output is world-readable

Bug #1334616 reported by Colin Watson on 2014-06-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson

Bug Description

https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/precise/ubuntu-zh-cn currently fails and is disabled. You can't see the failure in the logs (partly because it's only visible in the launchpad-buildd slave log, and partly because those builds were retried and then cancelled before they failed again), but it's as follows:

2014-06-23 12:39:25+0000 [-] Build log: P: Begin unmounting filesystems...
2014-06-23 12:39:25+0000 [-] Iterating with success flag 0 against stage BUILD_LIVEFS
2014-06-23 12:39:28+0000 [-] unexpected error in processEnded
        Traceback (most recent call last):
          File "/usr/lib/python2.7/dist-packages/twisted/internet/process.py", line 916, in maybeCallProcessEnded
            self.reapProcess()
          File "/usr/lib/python2.7/dist-packages/twisted/internet/process.py", line 312, in reapProcess
            self.processEnded(status)
          File "/usr/lib/python2.7/dist-packages/twisted/internet/_baseprocess.py", line 48, in processEnded
            self.maybeCallProcessEnded()
          File "/usr/lib/python2.7/dist-packages/twisted/internet/process.py", line 918, in maybeCallProcessEnded
            _BaseProcess.maybeCallProcessEnded(self)
        --- <exception caught here> ---
          File "/usr/lib/python2.7/dist-packages/twisted/internet/_baseprocess.py", line 60, in maybeCallProcessEnded
            proto.processEnded(Failure(reason))
          File "/usr/lib/launchpad-buildd/lpbuildd/slave.py", line 93, in processEnded
            self.notify(statusobject.value.exitCode)
          File "/usr/lib/launchpad-buildd/lpbuildd/debian.py", line 128, in iterate
            func(success)
          File "/usr/lib/launchpad-buildd/lpbuildd/livefs.py", line 80, in iterate_BUILD_LIVEFS
            self.gatherResults()
          File "/usr/lib/launchpad-buildd/lpbuildd/livefs.py", line 105, in gatherResults
            self._slave.addWaitingFile(path)
          File "/usr/lib/launchpad-buildd/lpbuildd/slave.py", line 409, in addWaitingFile
            self.waitingfiles[os.path.basename(path)] = self.storeFile(path)
          File "/usr/lib/launchpad-buildd/lpbuildd/slave.py", line 388, in storeFile
            f = open(path)
        exceptions.IOError: [Errno 13] Permission denied: '/home/buildd/build-LIVEFSBUILD-56/chroot-autobuild/build/livecd.ubuntu.kernel'

We apply an explicit chmod in a few other cases, but we're missing some.

For SRU verification, it should be sufficient to confirm that the livefs above can now be built in Launchpad.

Colin Watson (cjwatson) on 2014-06-26
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Changed in livecd-rootfs (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
status: New → In Progress
milestone: none → ubuntu-12.04.5
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.219

---------------
livecd-rootfs (2.219) utopic; urgency=medium

  * Drop fdupes analysis: not widely used any more, can be done separately
    if needed, and very noisy in build logs.
  * Make the output kernel/initrd world-readable in a couple more cases,
    particularly relevant to ubuntu-defaults-image (LP: #1334616).
 -- Colin Watson <email address hidden> Thu, 26 Jun 2014 12:31:12 +0100

Changed in livecd-rootfs (Ubuntu):
status: Fix Committed → Fix Released

Hello Colin, or anyone else affected,

Accepted livecd-rootfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/livecd-rootfs/2.65.12 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.65.12

---------------
livecd-rootfs (2.65.12) precise; urgency=medium

  * Make the output kernel/initrd world-readable in a couple more cases,
    particularly relevant to ubuntu-defaults-image (LP: #1334616).
 -- Colin Watson <email address hidden> Thu, 26 Jun 2014 12:33:54 +0100

Changed in livecd-rootfs (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers