Cannot handle more than one kernel for generic (3.13.0-24-generic 3.13.0-27-generic)!

Bug #1325281 reported by Tim Lunn on 2014-05-31
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
High
Colin Watson
Trusty
High
Colin Watson

Bug Description

When trying to locally build an Ubuntu GNOME trusty image with live-build, I get the following error:

Cannot handle more than one kernel for generic (3.13.0-24-generic 3.13.0-27-generic)!

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: livecd-rootfs 2.216
ProcVersionSignature: Ubuntu 3.15.0-4.9-generic 3.15.0-rc7
Uname: Linux 3.15.0-4-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.3-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Jun 1 09:23:52 2014
InstallationDate: Installed on 2012-09-23 (615 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)
SourcePackage: livecd-rootfs
UpgradeStatus: No upgrade log present (probably fresh install)

Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst) wrote :
Colin Watson (cjwatson) wrote :

This is happening because linux-signed-generic is in the live task, which I should have realised was invalid: that expands to ABI-versioned kernel packages, and tasks can't be updated post-release.

I've fixed this in utopic (for future stable releases) by making livecd-rootfs 2.218 install linux-signed-generic explicitly, and removing it from the seeds. However, we'll need a slightly different fix for trusty since we can't change the existing tasks: livecd-rootfs will need to filter out kernel packages from the live seed, as well as installing linux-signed-generic explicitly as in utopic.

Changed in livecd-rootfs (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
Changed in livecd-rootfs (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu Trusty):
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-14.04.1
Colin Watson (cjwatson) on 2014-06-24
Changed in livecd-rootfs (Ubuntu Trusty):
status: Triaged → In Progress

Hello Tim, or anyone else affected,

Accepted livecd-rootfs into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/livecd-rootfs/2.208.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in livecd-rootfs (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Colin Watson (cjwatson) wrote :

ubuntu/trusty/amd64 (which previously failed in the same way) now builds and seems to have a plausible manifest:

  https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/trusty/ubuntu/+build/160

tags: added: verification-done
removed: verification-needed
Tim Lunn (darkxst) wrote :

This unrelated to the SRU, however building a trusty image on a utopic host will still fail.

Colin Watson (cjwatson) wrote :

You don't give any details (why not?), but I guess that's the differing syslinux locations. That is indeed a separate bug. We don't use live-build's ISO generation mode in production so we don't run into that for official Ubuntu images.

Tim Lunn (darkxst) wrote :

Sorry I meant in the exact same way (I am not using the live-build ISO generation), I still get the same multiple kernel message, presumably because the filtering changes are only in livecd-rootfs on trusty.

Colin Watson (cjwatson) wrote :

True. In our infrastructure we only ever use livecd-rootfs and live-build from the same series that we're building for (we run livecd-rootfs in a chroot). I think I'd generally advise doing the same - for comparison, the hacks needed to get precise point releases working were never added to livecd-rootfs for later series either.

Tim Lunn (darkxst) wrote :

ok, I will just do it that way then!

The verification of the Stable Release Update for livecd-rootfs has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.208.1

---------------
livecd-rootfs (2.208.1) trusty; urgency=medium

  * Install linux-signed-generic directly in live passes rather than relying
    on it being in the corresponding tasks. linux-signed-generic shouldn't
    be in a task because that expands to ABI-versioned packages, and tasks
    can't be updated post-release.
  * Filter out kernel packages that mistakenly ended up in live tasks, so
    that we can install updated versions separately (LP: #1325281).
 -- Colin Watson <email address hidden> Tue, 24 Jun 2014 14:51:03 +0100

Changed in livecd-rootfs (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers