Quantal Ubuntu Server minimal install oversized

Bug #1028453 reported by Jean-Baptiste Lallement on 2012-07-24
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
High
Colin Watson
base-installer (Ubuntu)
High
Colin Watson
live-installer (Ubuntu)
High
Colin Watson
livecd-rootfs (Ubuntu)
High
Colin Watson

Bug Description

Quantal Ubuntu server minimal 20120724.3

Minimal installation pulls ubuntu-standard, is oversized and installs wrong kernel.

Jean-Baptiste Lallement (jibel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1028453

tags: added: iso-testing
tags: added: rls-q-incoming
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
James Page (james-page) on 2012-07-26
Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Canonical Server Team (canonical-server)
Ben Howard (utlemming) on 2012-08-21
Changed in ubuntu-meta (Ubuntu):
assignee: Canonical Server Team (canonical-server) → Ben Howard (utlemming)
assignee: Ben Howard (utlemming) → nobody
assignee: nobody → Ubuntu Server Team (ubuntu-server)
Colin Watson (cjwatson) on 2012-09-07
affects: ubuntu-meta (Ubuntu) → livecd-rootfs (Ubuntu)
Changed in livecd-rootfs (Ubuntu):
assignee: Ubuntu Server Team (ubuntu-server) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

This is mostly slightly incorrect live-build configuration in livecd-rootfs, but I think we'll have to add kernel installation support to live-installer in order to allow the same base squashfs to be used with multiple target kernels.

Changed in live-installer (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Oh, and apparently we still want headers, so adding an ubuntu-cdimage task for that.

Changed in ubuntu-cdimage:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) on 2012-09-08
Changed in live-installer (Ubuntu):
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

The list of tasks keeps on growing; handling kernel installation in live-installer will involve moving /usr/lib/base-installer/kernel.sh from bootstrap-base to base-installer.

Changed in base-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package base-installer - 1.122ubuntu10

---------------
base-installer (1.122ubuntu10) quantal; urgency=low

  * Move /usr/lib/base-installer/kernel.sh from bootstrap-base to
    base-installer (LP: #1028453).
 -- Colin Watson <email address hidden> Sun, 09 Sep 2012 13:13:49 +0100

Changed in base-installer (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-installer - 36ubuntu5

---------------
live-installer (36ubuntu5) quantal; urgency=low

  * Install a kernel unless the squashfs contains one (LP: #1028453).
 -- Colin Watson <email address hidden> Sun, 09 Sep 2012 16:38:17 +0100

Changed in live-installer (Ubuntu):
status: In Progress → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1810
fixes bug: https://launchpad.net/bugs/1028453
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Sun 2012-09-09 20:43:58 +0100
message:
  Install kernel headers in the ubuntu-server minimalvm case; apparently life is too difficult without them.

Changed in ubuntu-cdimage:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.83

---------------
livecd-rootfs (2.83) quantal; urgency=low

  * live-build/auto/config: Remove standard and server tasks from
    ubuntu-server squashfs, and build it with no kernel packages so that
    they can be added more correctly later by the installer (LP: #1028453).
 -- Colin Watson <email address hidden> Sun, 09 Sep 2012 20:41:19 +0100

Changed in livecd-rootfs (Ubuntu):
status: Confirmed → Fix Released
Victor Zhou (victor.zhou) wrote :

we can still met this issue in the test on quantal-server-amd64 iso.

The last test showed that the minimal amd64 install is 725972k (~709MB).

https://jenkins.qa.ubuntu.com/view/Quantal/view/ISO%20Testing%20Dashboard/job/quantal-server-amd64_minimal-virtual/123/testReport/test/MinimalVirtualTest/testInstallSize/

The current test case allows up to 684MB, we are proposing a move to a
new max of 725MB, which would make this test a pass. The extra
padding can probably be attributed to the kernel headers which are now
included. Whilst not a firm requirement, the experience can often be
poor without them.

Colin Watson (cjwatson) wrote :

Here's a brief analysis of the extra packages installed on top of the squashfs contents, organised in groups of which ones are installed together by d-i followed by the reported additional installed-size for each group:

linux-headers-3.5.0-14
linux-headers-3.5.0-14-generic
linux-headers-generic
linux-headers-virtual
linux-image-3.5.0-14-generic
linux-image-virtual
linux-virtual
(101MB)

libpci3
pciutils
(270KB)

libusb-1.0-0
usbutils
(259KB)

biosdevname
(22KB)

apt-xapian-index
aptitude
aptitude-common
dmidecode
laptop-detect
libboost-iostreams1.49.0
libclass-accessor-perl
libclass-isa-perl
libcwidget3
libept1.4.12
libgdbm3
libio-string-perl
libparse-debianchangelog-perl
libsigc++-2.0-0c2a
libsub-name-perl
libswitch-perl
libtimedate-perl
libxapian22
perl
perl-modules
python-apt
python-apt-common
python-chardet
python-debian
python-six
python-xapian
tasksel
tasksel-data
xz-utils
(50MB - possibly closer to 65MB following change in livecd-rootfs 2.87, since now this will pull in iso-codes too)

installation-report
(77KB)

language-pack-en
language-pack-en-base
(4MB)

gettext-base
grub-common
libasprintf0c2
libfreetype6
libfuse2
os-prober
(7MB)

grub-gfxpayload-lists
grub-pc
grub-pc-bin
grub2-common
(2.6MB)

With the exception of kernel headers which you've already said you want to keep, most of this is small enough that it isn't worth talking about. However, tasksel and its dependencies take up a noticeable amount of space considering that we configure tasksel not to do anything during installation in the minimalvm case. Do you want to keep this? I'm reluctant to take the decision to remove this myself, because you may well have documentation that says "install minimalvm and then run tasksel to turn the system into whatever you want", given that a minimal virtual machine isn't very useful on its own. Anyone from the server team want to weigh in on this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers