live-installer/net-image cannot fetch-url to unexisting /tmp/live-installer directory

Bug #1042906 reported by Marc Tardif
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
live-installer (Ubuntu)
Fix Released
High
Dave Walker

Bug Description

When installing Ubuntu-Server 12.10 "Quantal Quetzal" - Alpha amd64 (20120828) over a network with this preseed value:

d-i live-installer/net-image string http://10.153.104.60/rsync.cdimage.ubuntu.com/cdimage/ubuntu-server/daily/current/quantal-server-amd64/install/filesystem.squashfs

I eventually get this in the syslog of the system installing:

user.debug Aug 28 18:24:46 debconf: --> GET live-installer/net-image
user.debug Aug 28 18:24:46 debconf: <-- 0 http://10.153.104.60/rsync.cdimage.ubuntu.com/cdimage/ubuntu-server/daily/current/quantal-server-amd64/install/filesystem.squashfs
user.notice Aug 28 18:24:46 base-installer: info: Downloading http://10.153.104.60/rsync.cdimage.ubuntu.com/cdimage/ubuntu-server/daily/current/quantal-server-amd64/install/filesystem.squashfs to /tmp/live-installer/filesystem.squashfs
user.debug Aug 28 18:24:46 debconf: --> GET mirror/http/proxy
user.debug Aug 28 18:24:46 debconf: <-- 0
user.info Aug 28 18:24:46 main-menu[464]: (process:16926): wget: can't open '/tmp/live-installer/filesystem.squashfs': No such file or directory
user.warning Aug 28 18:24:46 main-menu[464]: WARNING **: Configuring 'live-installer' failed with error code 1
user.debug Aug 28 18:24:46 debconf: --> GET debconf/priority
user.debug Aug 28 18:24:46 debconf: <-- 0 critical
user.warning Aug 28 18:24:46 main-menu[464]: WARNING **: Menu item 'live-installer' failed.

In the console, it looks like the directory /tmp/live-installer doesn't exist. So, when fetch-url attempts to wget into /tmp/live-installer/filesystem.squashfs, the command just fails. Creating the directory in the postinst script somewhere after delaring the directory and calling fetch-url should do the trick, or fetch-url should be fixed to create the target directory before calling wget.

Changed in live-installer (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Dave Walker (davewalker)
Changed in live-installer (Ubuntu):
assignee: nobody → Dave Walker (davewalker)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-installer - 36ubuntu4

---------------
live-installer (36ubuntu4) quantal; urgency=low

  * debian/live-installer.postinst: If using net-image, create the temporary
    location to store the retrieved image, otherwise it fails. (LP: #1042906)
 -- Dave Walker (Daviey) <email address hidden> Thu, 30 Aug 2012 12:21:45 +0100

Changed in live-installer (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers