Ubuntu

lb_chroot_dpkg doesn't check dpkg version before setting 'unsafe-io' option

Reported by Neil Wilson on 2011-10-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
live-build (Debian)
Fix Released
Unknown
live-build (Ubuntu)
Undecided
Unassigned

Bug Description

The dpkg in the chroot (on a lucid build for example) might not be new enough to handle the 'unsafe-io' option set in the configuration file.

lb_chroot_dpkg should check the chroot's dpkg capability first, e.g.

Chroot chroot dpkg --force-help | grep -q unsafe-io

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: live-build 3.0~a24-1ubuntu17 [modified: usr/share/live/build/scripts/build/lb_bootstrap_cdebootstrap]
ProcVersionSignature: User Name 3.0.0-12.20-virtual 3.0.4
Uname: Linux 3.0.0-12-virtual x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Thu Oct 27 17:02:24 2011
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: live-build
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (13 days ago)

Neil Wilson (neil-aldur) wrote :
Neil Wilson (neil-aldur) on 2011-10-28
Changed in live-build (Ubuntu):
assignee: nobody → Neil Wilson (neil-aldur)
Neil Wilson (neil-aldur) wrote :
Neil Wilson (neil-aldur) on 2011-10-28
Changed in live-build (Ubuntu):
assignee: Neil Wilson (neil-aldur) → nobody
Changed in live-build (Debian):
status: Unknown → New
Changed in live-build (Debian):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

I have to say that I somewhat agree with Daniel Baumann in his reply to the Debian bug; we only switched to live-build as of oneiric, and it would not at all surprise me to find that quite a few little things need to be changed to make it work well on lucid. I'm reluctant to embark on that kind of thing when it might well be much easier to simply use an oneiric chroot. Could you elaborate on your requirements here, and why you need to use a lucid chroot?

Colin Watson (cjwatson) wrote :

Or rather (as I notice "chroot" here means the target system), it might well be better-supported to use livecd-rootfs. I didn't really want to expand the scope of the project that switched Ubuntu to live-build to cover releases older than oneiric.

I'm using live build to build virtual machines and I noticed this and
I thought I'd report it as it was an easy fix.

I was rather hoping to do what I wanted as an extension to the
standard live-build, but that subsequently seems impossible so I've
just forked the code for my purposes.

On 8 November 2011 13:51, Colin Watson <email address hidden> wrote:
> Or rather (as I notice "chroot" here means the target system), it might
> well be better-supported to use livecd-rootfs.  I didn't really want to
> expand the scope of the project that switched Ubuntu to live-build to
> cover releases older than oneiric.
>

--
Neil Wilson

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in live-build (Ubuntu):
status: New → Confirmed
gcc (chris+ubuntu-qwirx) wrote :

We are build a system for use in schools. We started before 12.04 was released, and we needed a stable system so we used Lucid. We don't have time to switch to 12.04 now (and anyway I hate the new default desktop thingy) so we're still on Lucid. I'm trying to replace the manually-built image with an automatically-built one using live-build and hit this bug.

I'm going to manually patch whatever it takes to use live-build for Lucid, but would really appreciate it if the fixes could be rolled into live-build if it's not too difficult, as it makes it much easier for others to reproduce my work, which is the whole point of using live-build in the first place. I'd prefer that we not prejudge just how hard the path might be when we haven't seen it yet?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.