live-build doesn't work with multi-part initrds

Bug #1778811 reported by Adam Conrad on 2018-06-26
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
live-build (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

Due to attempts to treat initrds as single compressed files (both for recompression, and in the lesser-used codepath for hunting through the initrd to find a file), multi-part initrds cause live-build to fail.

Proposed fix is to let initramfs-tools do the heavy lifting, by setting COMPRESS for generating initrds, and by using unmkinitramfs to unpack them and look around for stuff.

[Test Case]

A livefs build of a -proposed bionic image should generate a working initrd. To test this a new bionic build on cdimage should be started. The build should succeed and generate a working image.

[Regression Potential]

The initrds are empty right now so it can't get any worse than this.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in live-build (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a57-1ubuntu35

---------------
live-build (3.0~a57-1ubuntu35) cosmic; urgency=medium

  * ubuntu-initramfs-handling.patch: Use initramfs-tools to work with initrds,
    instead of trying to naively repack and unpack them blindly (LP: #1778811)

 -- Adam Conrad <email address hidden> Tue, 26 Jun 2018 16:36:32 -0600

Changed in live-build (Ubuntu):
status: Confirmed → Fix Released

Hello Adam, or anyone else affected,

Accepted live-build into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/live-build/3.0~a57-1ubuntu34.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in live-build (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

For xenial - I see the xenial SRU of live-build doesn't add the initramfs-tools dependency, is that not needed there? Or did that just slip through the cracks?

description: updated
Łukasz Zemczak (sil2100) wrote :

Hello Adam, or anyone else affected,

Accepted live-build into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/live-build/3.0~a57-1ubuntu25.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in live-build (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a57-1ubuntu34.1

---------------
live-build (3.0~a57-1ubuntu34.1) bionic; urgency=medium

  * ubuntu-initramfs-handling.patch: Use initramfs-tools to work with initrds,
    instead of trying to naively repack and unpack them blindly (LP: #1778811)
  * debian/control: Need to depend on initramfs-tools which isn't in chroots.

 -- Adam Conrad <email address hidden> Tue, 26 Jun 2018 16:36:32 -0600

Changed in live-build (Ubuntu Bionic):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Since the xenial builds seem to work correctly I'm actually marking this as verified.

tags: added: verification-done-xenial
removed: verification-needed verification-needed-xenial

The verification of the Stable Release Update for live-build has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package live-build - 3.0~a57-1ubuntu25.6

---------------
live-build (3.0~a57-1ubuntu25.6) xenial; urgency=medium

  * ubuntu-initramfs-handling.patch: Use initramfs-tools to work with initrds,
    instead of trying to naively repack and unpack them blindly (LP: #1778811)

 -- Adam Conrad <email address hidden> Tue, 26 Jun 2018 16:36:32 -0600

Changed in live-build (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers