live-build fails to build

Bug #1739790 reported by thelinuxbox on 2017-12-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
live-build (Ubuntu)
Undecided
Unassigned

Bug Description

Hello, I'm trying to build an Ubuntu ISO with the minimal amount of packages using live-build, towards the end of the building process it says "Unable to locate package syslinux-themes-ubuntu-oneiric" and then it appears to stop the build process, below is the command from my bash file, thank you in advance to any replies.
--

#!/bin/sh

sudo lb clean

sudo lb config \
--mode ubuntu \
--architecture amd64 \
--distribution xenial \
--archive-areas "main universe multiverse" \
--parent-distribution xenial \
--parent-archive-areas "main universe multiverse" \
--apt-options "--yes" \
--binary-images iso-hybrid \

sudo lb build

--

1) OS:Ubuntu 16.04.3 LTS
2) Live-Build Version: 3.0~a57-1ubuntu25.5
3) Live-Build to build an installable minimal Ubuntu ISO
4) "Unable to locate package syslinux-themes-ubuntu-oneiric"

tags: added: xenial
thelinuxbox (thelinuxbox) wrote :

Hi, quick update, I tried live-build on debian and it worked without any issues, so it seems to me that the ubuntu build is definitely broken.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in live-build (Ubuntu):
status: New → Confirmed
tags: added: rls-bb-incoming rls-ee-incoming rls-xx-incoming
Sebastien Bacher (seb128) wrote :

Thank you for your bug report.

Indeed it's obvious from the code was is wrong and should be trivial to fix

functions/defaults.sh has that code

' ubuntu)
   LB_SYSLINUX_THEME="${LB_SYSLINUX_THEME:-ubuntu-oneiric}"
   ;;'

Or the -oneiric binary got removed in xenial so it's probably a matter for doing s/oneiric/xenial there

Tagging rls for foundations review they know better the image build tools and what modes are supposed in Ubuntu

thelinuxbox (thelinuxbox) wrote :

Thank you very much for replying to my bug report, I really appreciate it.

I was just thinking about the live-build tool this morning and was pleasantly surprised to see an email in my inbox with your message.

As soon as an update is available I'd gladly test it out.

Many thanks!

Steve Langasek (vorlon) wrote :

Foundations does not support live-build directly as a tool for building images, but only as an implementation detail of builds driven by livecd-rootfs and ubuntu-cdimage.

tags: added: rls-bb-notfixing rls-ee-notfixing rls-xx-notfixing
removed: rls-bb-incoming rls-ee-incoming rls-xx-incoming
thelinuxbox (thelinuxbox) wrote :

Thank you for your reply Steve,

I'd like to ask what solution you'd recommend for building a custom Ubuntu derivative from the command line.

Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers