Arduino fails to start: undefined symbol: sp_get_port_usb_vid_pid

Bug #1916278 reported by Hans Joachim Desserud on 2021-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
arduino (Ubuntu)
Undecided
Unassigned
listserialportsc (Ubuntu)
Undecided
Unassigned

Bug Description

How to reproduce:
1. Run `arduino`
2. A window pops up stating "you need to be added to the dialout group"
3. Click add. At this point, a system dialog pops up. Confirm with your password.
4. When authenticated, watch the Arduino splash screen and wait a while.

Expected:
Arduino launches

Actual:
It fails to start with an error message indicating undefined symbol:
$ arduino
No required groups are missing for this user.
Picked up JAVA_TOOL_OPTIONS:
java.lang.UnsatisfiedLinkError: /usr/lib/x86_64-linux-gnu/liblistSerialsj.so.1.4.0: /usr/lib/x86_64-linux-gnu/liblistSerialsj.so.1.4.0: undefined symbol: sp_get_port_usb_vid_pid
 at java.base/java.lang.ClassLoader$NativeLibrary.load0(Native Method)
 at java.base/java.lang.ClassLoader$NativeLibrary.load(ClassLoader.java:2442)
 at java.base/java.lang.ClassLoader$NativeLibrary.loadLibrary(ClassLoader.java:2498)
 at java.base/java.lang.ClassLoader.loadLibrary0(ClassLoader.java:2694)
 at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2659)
 at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:830)
 at java.base/java.lang.System.loadLibrary(System.java:1873)
 at processing.app.Platform.<clinit>(Platform.java:144)
 at java.base/java.lang.Class.forName0(Native Method)
 at java.base/java.lang.Class.forName(Class.java:315)
 at processing.app.BaseNoGui.initPlatform(BaseNoGui.java:514)
 at processing.app.Base.<init>(Base.java:201)
 at processing.app.Base.main(Base.java:141)

I am not sure exactly what is causing this issue. I was unable to reacreate it on Debian Sid.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: arduino 2:1.8.13+dfsg1-1
ProcVersionSignature: Ubuntu 5.8.0-36.40+21.04.1-generic 5.8.18
Uname: Linux 5.8.0-36-generic x86_64
ApportVersion: 2.20.11-0ubuntu59
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Fri Feb 19 19:07:33 2021
InstallationDate: Installed on 2020-11-05 (106 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201105)
SourcePackage: arduino
UpgradeStatus: No upgrade log present (probably fresh install)

Hans Joachim Desserud (hjd) wrote :
Hans Joachim Desserud (hjd) wrote :

Fwiw, I tried to rebuild the package locally in case it would pick up new symbols, but I still get the same error message.

Same problem here on the alpha Hirsute Hippo :-). Suspect package
liblistserialsj1 needs attention.

Download version 1.8.13 direct from Arduino. That works fine!

--
David Coe

Hans Joachim Desserud (hjd) wrote :

Thanks for checking, I've marked listserialportsc as also affected. :)

Changed in arduino (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers