Ubuntu

lirc init script doesn't disable other methods on natty

Reported by Ernst Sjöstrand on 2011-01-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: lirc

In natty the sysfs interface has change a bit so there's no longer a devices/virtual/rc.
The following patch seems to solve it!

diff --git a/etc/init.d/lirc b/etc/init.d/lirc
index b3c9266..620d2e1 100755
--- a/etc/init.d/lirc
+++ b/etc/init.d/lirc
@@ -93,8 +93,8 @@ in_kernel_support() {
        else
                action="-"
        fi
- if [ -d /sys/devices/virtual/rc ]; then
- for file in `find /sys/devices/virtual/rc/ -name protocols`; do
+ if [ -d /sys/class/rc ]; then
+ for file in `find /sys/class/rc/*/ -name protocols`; do
                        for protocol in rc5 nec rc6 jvc sony; do
                                echo "${action}${protocol}" > $file
                        done

Ernst Sjöstrand (ernstp) wrote :
Ernst Sjöstrand (ernstp) wrote :

Btw, the rc* protocols have changed names to rc-5 and rc-6 but the new patch works around that problem.

tags: added: patch
Ernst Sjöstrand (ernstp) wrote :

Hi, shouldn't this be submitted soon?

Hock (beehock) wrote :

https://wiki.ubuntu.com/SponsorshipProcess

This might help to speed up the submission.

Scott Moser (smoser) wrote :

Hi Ernst,
  Thank you for taking the time to open a bug and submit a patch. I don't have access to upload the fix, but I've taken your patch and pulled it into the Ubuntu packaging format at lp:~smoser/ubuntu/natty/lirc/lp-698208 . In the future, making changes to the debian packaging yourself makes less work for the Ubuntu developer trying to upload your fixes (ie, start from 'bzr branch lp:ubuntu/lirc).

  I've also pushed a build of that source package to my ppa at https://launchpad.net/~smoser/+archive/ppa/+packages .

  I think this is ready to pull in, and it is in the sponsorship queue, so someone should be taking a look at it sometime soon.

Michael Vogt (mvo) wrote :

Thanks, uploaded

Changed in lirc (Ubuntu):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.7-0ubuntu4

---------------
lirc (0.8.7-0ubuntu4) natty; urgency=low

  [Ernst Sjöstrand]
  * update init script for /sys change in natty kernels (LP: #698208)
 -- Scott Moser <email address hidden> Fri, 18 Mar 2011 16:26:14 -0400

Changed in lirc (Ubuntu):
status: In Progress → Fix Released
Ernst Sjöstrand (ernstp) wrote :

Oh wait, you merged an old patch!
You should have taken the patch Mario did on bazaar that's linked to this bug, that's the patch I mention in comment #2.
http://bazaar.launchpad.net/~mythbuntu-dev/lirc/ubuntu/revision/151

Changed in lirc (Ubuntu):
status: Fix Released → Incomplete
Michael Vogt (mvo) wrote :

Sorry for that, I will do another fix for it.

Bryce Harrington (bryce) wrote :

[Unmarking old patch as a solution as per previous comments. Unsubbing sponsors since correct patch is already merged onto the packaging bzr branch.]

Changed in lirc (Ubuntu):
status: Incomplete → Confirmed

Accepted lirc into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in lirc (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Mario Limonciello (superm1) wrote :

I just upgraded a box with an affected remote to natty. After installing the updated package from proposed, the problem is now fixed for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.7-0ubuntu4.1

---------------
lirc (0.8.7-0ubuntu4.1) natty-proposed; urgency=low

  [ Ernst Sjöstrand ]
  * For disabling other protocols, adjust to the new location in 2.6.37.
    (LP: #698208)
 -- Mario Limonciello <email address hidden> Mon, 25 Apr 2011 12:52:38 -0500

Changed in lirc (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in lirc (Ubuntu Oneiric):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers