Ubuntu

lirc does not create /dev/lirc0 when using Imon Pad remote

Reported by Mikko Rönkkö on 2010-09-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lirc

Everything seems to work OK with lirc, except that it does not create /dev/lirc0 device file.

Here is terminal output

mronkko@Hondchan:~$ sudo rmmod lirc_dev lirc_imon ir_lirc_codec
mronkko@Hondchan:~$ lsmod | grep lirc
mronkko@Hondchan:~$
mronkko@Hondchan:~$ sudo modprobe lirc_imon
mronkko@Hondchan:~$ dmesg | tail
[ 319.932412] usbcore: registered new interface driver lirc_imon
[ 320.117208] type=1400 audit(1284138864.859:12): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/mysqld" pid=1304 comm="apparmor_parser"
[ 320.415398] NET: Registered protocol family 5
[ 4487.587000] usbcore: deregistering interface driver lirc_imon
[ 4487.587071] lirc_imon: module removed. Goodbye!
[ 4499.666763] lirc_dev: module unloaded
[ 4522.741867] lirc_dev: IR Remote Control driver registered, major 250
[ 4522.745016] lirc_imon: module is from the staging directory, the quality is unknown, you have been warned.
[ 4522.748770] lirc_imon: Driver for SoundGraph iMON MultiMedia IR/Display, v0.8
[ 4522.748861] usbcore: registered new interface driver lirc_imon
mronkko@Hondchan:~$ ls /dev | grep lirc
lircd
Description: Ubuntu maverick (development branch)
Release: 10.10
mronkko@Hondchan:~$ apt-cache policy lirc
lirc:
  Installed: 0.8.7~pre3-0ubuntu1
  Candidate: 0.8.7~pre3-0ubuntu1
  Version table:
 *** 0.8.7~pre3-0ubuntu1 0
        500 http://fi.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status
mronkko@Hondchan:~$

Mikko Rönkkö (mikko-ronkko) wrote :

This same issue is also present on my system with Philips SRM 7500 remote.

a_user (a-user-sci) wrote :

same here: no /dev/lirc0 device for imon

rhpot1991 (rhpot1991) wrote :

If lirc_imon doesn't create a /dev/lirc0 then your device is one of the newer imon devices and should use the imon kernel driver. This will automagically send keystrokes to the system so lirc isn't really needed. If you still want lirc then you can set it up as a devinput device. There is also currently an issue with imon mce devices not working correctly with the new kernel driver.

Changed in lirc (Ubuntu):
status: New → Incomplete
Chris Murphy (chrismurf2900) wrote :

So how would one go about making sure that we are using the imon kernel driver?

What issue is there with the imon mce devices not working correctly with the new kernel driver?
I don't know if my 15c2:0038 Soundgraph iMon Remote controller is one of those mce devices or not. Any help would be appreciated.

SaschaVogt (funkyfish) wrote :

Same here too.

I tried a dpkg-reconfigure lirc and selected Linux input layer (with /dev/input/input5, which according to cat /sys/class/input/input5/name is iMON Remote (15c2:0038))

Nothing changed, though I'm not sure if anything else should be done

Chris Murphy (chrismurf2900) wrote :

Sascha,

I've actually figured out the issue I had and was able to fix it.

I've created a wiki page on MythTV.org to show how I fixed it.

You can take a look at it here:

http://www.mythtv.org/wiki/Soundgraph_iMON_Antec_Veris_Mythbuntu_10.10

Good Luck!

Launchpad Janitor (janitor) wrote :

[Expired for lirc (Ubuntu) because there has been no activity for 60 days.]

Changed in lirc (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers