Ubuntu

Comment 0 for bug 567512

Reuben Thomas (rrt) wrote :

Binary package hint: lirc

See the mistitled bug #440466 for the background and supposed fix to this bug.

Previously, lircd would inject key events into /dev/input/uinput (according to the lircd manpage, though there is no such file on my system) when run with the --uinput option and the uinput input module. This worked with the Mac mini remote, except that auto-repeat did not work, and one had to wait about a second between key presses.

According to bug #440466 there was a fix for this bug recently. Only now it is completely broken: pressing keys on the Mac mini remote seems to do nothing. However, when lircd is stopped, all the key presses entered are indeed injected into the keyboard buffer. So in fact they are being queued up somewhere.

This is not great: in Hardy the Mac mini remote worked perfectly out of the box. In Jaunty and Karmic it worked poorly, with considerable manual configuration. In Lucid it doesn't work at all.

I will now go and ping the other bug reports which I made before Karmic was released (mostly simple configuration problems that can be worked around). Sigh.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: lirc 0.8.6-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Tue Apr 20 21:31:35 2010
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
SourcePackage: lirc