Hauppauge TV Card is detected as Leadtek IR in lucid

Bug #550369 reported by TecnoBrat on 2010-03-28
76
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Tim Gardner
lirc (Ubuntu)
Medium
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: lirc

My Hauppage remote is detected as a "Leadtek IR" by lirc_i2c in Lucid

Mar 28 09:31:35 hyena kernel: [ 41.177256] lirc_dev: IR Remote Control driver registered, major 61
Mar 28 09:31:35 hyena kernel: [ 41.727948] lirc_i2c: chip 0x0 found @ 0x18 (Leadtek IR)
Mar 28 09:31:35 hyena kernel: [ 41.727952] lirc_dev: lirc_register_driver: sample_rate: 10

I found this post, which seems to lie out what the issue is:

http://www.gossamer-threads.com/lists/mythtv/users/427306

Howdy, and thank you for helping to improve Ubuntu by opening this
ticket. I am a bit confused though - this is actually a bug against
the kernel and not the lirc appliations themselves, right?

Nope, its the lirc package.

There is a patch in the fedora kernel which patches drivers/lirc_i2c/lirc_i2c.c

Here is the extracted patch, which I just compiled and it seems to resolve the issue for me.

TecnoBrat (tecnobrat) wrote :

Whoops, that patch was backwards :)

MarcRandolph (mrand) wrote :

Thank you for the patch!

Changed in lirc (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
tags: added: patch
MarcRandolph (mrand) wrote :

ok, lirc upstream appears to have this patch in a different form here:
http://lirc.cvs.sourceforge.net/viewvc/lirc/lirc/drivers/lirc_i2c/lirc_i2c.c?r1=1.71&r2=1.72

Having said that, 1.72 is the latest version, and there is only one other diff between that and 0.8.6 that Ubuntu has:
http://lirc.cvs.sourceforge.net/viewvc/lirc/lirc/drivers/lirc_i2c/lirc_i2c.c?r1=1.70&r2=1.71
which looks somewhat related to a recently resolved bug:
https://bugs.launchpad.net/ubuntu/+source/lirc/+bug/529514

If a diff containing both is desired, it is:
http://lirc.cvs.sourceforge.net/viewvc/lirc/lirc/drivers/lirc_i2c/lirc_i2c.c?r1=1.72&r2=1.70

TecnoBrat (tecnobrat) wrote :

Wanted to mention that this bug affects anyone with a Hauppage TV Card. This breaks support for this card completely in lucid, the remote doesn't work at all.

Seeing as its probably one of the more common cards on the market, I would suggest marking this bug a little higher priority so that its fixed by the time lucid is released :)

Benjamin Drung (bdrung) on 2010-04-28
summary: - Hauppage TV Card is detected as Leadtek IR in lucid
+ Hauppauge TV Card is detected as Leadtek IR in lucid
Julian Edwards (julian-edwards) wrote :

If, like me, you got caught out by this when upgrading to lucid recently, I've made a package in my PPA that fixes the problem using the upstream patch. I've installed this package on my production MythTV box and it works fine. At the time of writing this comment, the builds are done but not yet published though.

https://edge.launchpad.net/~julian-edwards/+archive/lirc/

Hopefully someone will push a fixed package up to lucid soon :)

Benjamin Drung (bdrung) wrote :

0.8.6-0ubuntu4+ppa2 fixes this bug and bug #555863. Please add a DEP-3 header to the patch and create a debdiff for maverick and lucid.

John (johnnybirdman) wrote :

Added the PPA and installed the lirc files but the remote for my PVR-350 still does not work and I have lirc_dev consuming 100% of my CPU unless I uninstall lirc from MCC and reboot.
J.

Benjamin Drung (bdrung) wrote :

You have to install lirc-modules-source (or patch the kernel).

tags: added: review-request
John (johnnybirdman) wrote :

Benjamin and Julian
Thank you for the magic, that worked.
Confirmed... works.
J.

mh (mrhegstrom) wrote :

Thanks guys - that worked great. I am going to post this on a new thread on mythbuntu forums. I just got lucky finding this. I didn't thing to look for or notice the CPU pegging. I just noticed my remote didn't work and couldn't find that anyone else had this problem. Anyway this is what I did:
- the lirc_dev would not unload and wouldn't let the new package install correctly so I did this:
-mythbuntu control center and uncheck the remote selection checkbox. (left lirc itself checked)
-sudo mv /dev/init.d/lirc /dev/init.d/lirc-off
-rebooted machine (so that lirc and lirc_dev doesn't load)
-Used synaptic to install all 5 of the new packages with the new lirc +ppa2 at the end (look in synaptic under /main /universe)
-sudo mv /dev/init.d/lirc-off /dev/init.d/lirc
-go into mythbuntu control center, enable the remote and select the hauppauge TV card one.
-Reboot and check

Guessing they are spending a lot of resources on fixing it cuz there aren't too many of us "SD" TV watchers out there!.

Since it seems to work ok for a few of us now, I'll grab a core dev (I'm at UDS next week) and see if I can get it uploaded to Lucid.

Benjamin Drung (bdrung) wrote :

You could ask me instead. ;) I will take the upstream patch, upload lirc and prepare a patch for the linux kernel.

Benjamin Drung (bdrung) wrote :

Here is the SRU patch for lirc.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.6-0ubuntu5

---------------
lirc (0.8.6-0ubuntu5) maverick; urgency=low

  * Add hauppauge-tv-card.patch to fix detection of Hauppauge TV Card as
    Leadtek IR (LP: #550369)
 -- Benjamin Drung <email address hidden> Sat, 08 May 2010 23:59:53 +0200

Changed in lirc (Ubuntu):
status: Triaged → Fix Released
Benjamin Drung (bdrung) on 2010-05-08
Changed in lirc (Ubuntu Lucid):
status: New → Fix Committed
Benjamin Drung (bdrung) on 2010-05-08
tags: added: patch-accepted-upstream
removed: review-request
Herco van Brug (hercovanbrug) wrote :

ok, the patch works for me but has now my imon isn't working anymore. i have both hauppauge and soundgraph in my mediacenter. previously the imon loaded, but i2c didn't. now it's the other way around.

this will probably be fixed with the official kernel release but just in case; i get this message:

[26168.248130] lirc_imon: disagrees about version of symbol lirc_register_driver
[26168.248138] lirc_imon: Unknown symbol lirc_register_driver

Benjamin Drung (bdrung) wrote :

@Herco: Which patch did you test (lirc.patch or the upstream patch)? Did you installed lirc-modules-source?

Benjamin Drung (bdrung) wrote :

Here is the patch for the linux kernel.

tags: added: kj-triage

Accepted lirc into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Lucid):
status: New → Invalid
tags: added: verification-needed
Herco van Brug (hercovanbrug) wrote :

@Benjamin
i installed all 5 ppa2 packages from julian including the modules-source. i put a backup of the lirc_imon.ko back into the driver tree and it loaded so i have a working setup now. i'll test the proposed update tonight to see if both load correctly.

besson3c (joe-netmusician) wrote :

Thank you for this fix! Installing the lirc and lirc-modules-source in proposed works just fine...

I'm wondering, is there a version of this that is compatible with the 2.6.33 mainline kernels? I'm testing a possible fix for another problem in 2.6.33, I'd like to run this version full time, and getting LIRC to work in this version would be very nice! :)

Martin Pitt (pitti) on 2010-05-10
tags: added: verification-done
removed: verification-needed
Herco van Brug (hercovanbrug) wrote :

i installed the proposed packages and both i2c and imon seem to load fine.

Don Giovanni (thedongiovanni) wrote :

Installing lirc and lirc-modules-source in lucid-proposed fixed this for me as well. Thank you.

GrosMario (ttkspam) wrote :

Tried to installed the proposed packages but this didn't fix the problem. I have a soundgraph imon, used to work fine before I upgrade to lucid.

Installed lirc-modules-sources is 0.8.6-0ubuntu4.1.

Strangely enough the date on lirc_imon.ko did not change after installing the proposed packages.

GrosMario (ttkspam) wrote :

I tried to manually run dpk-reconfigure and got this error:

lirc_imon.ko:
Running module version sanity check.

Error! Module version 0.6 for lirc_imon.ko
is not newer than what is already found in kernel 2.6.32-21-generic (0.6).
You may override by specifying --force.

--force did not help.

I then removed the lirc_imon.ko file before running dpkg-reconfigure again.
Now the lirc_imon.ko was updated, I can modprobe it but irw won't show any activity ...

GrosMario (ttkspam) wrote :

Sorry, after a reboot lirc is back on wheels. I can't find how to edit/delete previous post.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.6-0ubuntu4.1

---------------
lirc (0.8.6-0ubuntu4.1) lucid-proposed; urgency=low

  * Add hauppauge-tv-card.patch to fix detection of Hauppauge TV Card as
    Leadtek IR (LP: #550369)
 -- Benjamin Drung <email address hidden> Sun, 09 May 2010 00:00:50 +0200

Changed in lirc (Ubuntu Lucid):
status: Fix Committed → Fix Released

I upgraded to Lucid today, including the lirc 0.8.6-0ubuntu4.1 update, and am still seeing this problem (mis-detection of a Hauppauge WinTV PVR-350 remote control as a Leadtek, the remote not working and lirc_dev taking 100% CPU).

I am running the -server kernel if that makes a difference. Reverting back to the 2.6.31-22-server kernel fixes the problem for now.

Anyone else seeing this?

/var/log/syslog

Jun 18 15:45:08 vmhost kernel: [ 10.633727] lirc_dev: IR Remote Control driver registered, major 61
...
Jun 18 15:45:08 vmhost kernel: [ 10.651169] bttv: driver version 0.9.18 loaded
Jun 18 15:45:08 vmhost kernel: [ 10.651171] bttv: using 8 buffers with 2080k (520 pages) each for capture
Jun 18 15:45:08 vmhost kernel: [ 10.663321] cx88/0: cx2388x v4l2 driver version 0.0.7 loaded
Jun 18 15:45:08 vmhost kernel: [ 10.663482] lirc_i2c: chip 0x0 found @ 0x18 (Leadtek IR)
Jun 18 15:45:08 vmhost kernel: [ 10.663484] lirc_dev: lirc_register_driver: sample_rate: 10

tim@vmhost:/lib/modules$ dpkg -l | grep lirc
ii liblircclient0 0.8.6-0ubuntu4.1 infra-red remote control support - client library
ii lirc 0.8.6-0ubuntu4.1 infra-red remote control support

tim@vmhost:/lib/modules$ ls -la `find . -name lirc_dev.ko`
-rw-r--r-- 1 root root 26168 2010-05-27 01:25 ./2.6.31-22-server/kernel/ubuntu/lirc/lirc_dev/lirc_dev.ko
-rw-r--r-- 1 root root 27616 2010-06-03 19:26 ./2.6.32-22-server/kernel/ubuntu/lirc/lirc_dev/lirc_dev.ko

TecnoBrat (tecnobrat) wrote :

Did you also upgrade lirc-modules-source?

Guy Thomas (guy-r-thomas) wrote :

I am still seeing this bug.

[ 113.327985] lirc_dev: IR Remote Control driver registered, major 61
[ 113.450218] lirc_i2c: chip 0x0 found @ 0x18 (Leadtek IR)
[ 113.450226] lirc_dev: lirc_register_driver: sample_rate: 10

guy@guy-mythtv:~$ dpkg -l | grep lirc
ii liblircclient0 0.8.6-0ubuntu4.1 infra-red remote control support - client li
ii lirc 0.8.6-0ubuntu4.1 infra-red remote control support
ii lirc-modules-source 0.8.6-0ubuntu4.1 infra-red remote control support - kernel mo
ii mythbuntu-lirc-generator 0.24-0ubuntu1 Mythbuntu Lirc Configuration Generator

-rw-r--r-- 1 root root 18508 2010-04-16 06:03 ./2.6.32-21-generic/kernel/ubuntu/lirc/lirc_dev/lirc_dev.ko
-rw-r--r-- 1 root root 18508 2010-06-11 05:56 ./2.6.32-23-generic/kernel/ubuntu/lirc/lirc_dev/lirc_dev.ko
-rw-r--r-- 1 root root 18516 2010-07-09 00:35 ./2.6.32-23-generic/updates/dkms/lirc_dev.ko

TecnoBrat (tecnobrat) wrote :

Guy,

Its the lirc_i2c.ko file that is the issue, was that regenerated with dkms? Are you running the 2.6.32-23-generic kernel?

This is my output, and it works ...

---

ii liblircclient0 0.8.6-0ubuntu4.1 infra-red remote control support - client li
ii lirc 0.8.6-0ubuntu4.1 infra-red remote control support
ii lirc-modules-source 0.8.6-0ubuntu4.1 infra-red remote control support - kernel mo
ii lirc-x 0.8.6-0ubuntu4.1 infra-red remote control support - X utiliti

---

Jul 6 14:44:10 hyena kernel: [ 54.338335] lirc_dev: IR Remote Control driver registered, major 61
Jul 6 14:44:10 hyena kernel: [ 54.590933] lirc_i2c: chip 0x0 found @ 0x18 (Hauppauge IR)
Jul 6 14:44:10 hyena kernel: [ 54.590937] lirc_dev: lirc_register_driver: sample_rate: 10

---

/lib/modules/2.6.32-22-generic/updates/dkms/lirc_i2c.ko
/lib/modules/2.6.32-22-generic/kernel/ubuntu/lirc/lirc_i2c/lirc_i2c.ko
/lib/modules/2.6.32-23-generic/updates/dkms/lirc_i2c.ko
/lib/modules/2.6.32-23-generic/kernel/ubuntu/lirc/lirc_i2c/lirc_i2c.ko

---

uname -r
2.6.32-23-generic

Hi TecnoBrat,

Installing lirc-modules-source solved the problem, thanks! dkms automatically was called to compile and use all the lirc kernel modules included in the source package, including lirc_i2c.

I was surprised this would work, as the package description for it says, "Also, note that this package is not necessary for usage on Ubuntu since the modules are shipped in linux-ubuntu-modules. It is soley here in the case that a local patch needs to be applied."

However, it appears the lirc_i2c.ko module included with the current kernel (2.6.32-23) is based on not the same source as is included in lirc-modules-source.

root@vmhost:/lib/modules# ls -la `find . -name lirc_i2c.ko`
-rw-r--r-- 1 root root 21208 2010-06-11 08:02 ./2.6.32-23-server/kernel/ubuntu/lirc/lirc_i2c/lirc_i2c.ko
-rw-r--r-- 1 root root 21176 2010-07-10 12:46 ./2.6.32-23-server/updates/dkms/lirc_i2c.ko

I am now getting a warning from dkms that the built and installed versions are different of this module.

root@vmhost:/lib/modules# dkms status
lirc, 0.8.6, 2.6.32-23-server, x86_64: installed (WARNING! Diff between built and installed module!)
nvidia-current, 195.36.24, 2.6.32-23-server, x86_64: installed

However, the newer module is still loaded and correctly detects the Hauppauge remote.

Tim

Guy Thomas (guy-r-thomas) wrote :

It worked for me too. I don't get the error the Tim reports though.

--
Guy

Benjamin Drung (bdrung) on 2010-08-16
Changed in linux (Ubuntu):
status: Invalid → New
Changed in linux (Ubuntu Lucid):
status: Invalid → New
Tim Gardner (timg-tpi) wrote :

Use the lirc DKMS package instead.

Changed in linux (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Won't Fix
Changed in linux (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions