lirc does not configure IR transmitter properly

Bug #463050 reported by ioio85 on 2009-10-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lirc

I am using Kubuntu Karmic Koala 9.10
I have a Hauppauge 350 and IR blaster, my lirc is setup with:
- Hauppauge HVR-1300
- Serial Port (UART) : Motorola cable box

When the the script /etc/init.d/lirc start it automatically links:
lrwxrwxrwx 1 root root 19 2009-10-24 21:36 /dev/lircd -> /var/run/lirc/lircd
lrwxrwxrwx 1 root root 20 2009-10-24 21:39 /dev/lircd1 -> /var/run/lirc/lircd

 instead of
lrwxrwxrwx 1 root root 19 2009-10-24 21:36 /dev/lircd -> /var/run/lirc/lircd
lrwxrwxrwx 1 root root 20 2009-10-24 21:39 /dev/lircd1 -> /var/run/lirc/lircd1

I had to change it in /etc/init.d/lirc (see attached)

ProblemType: Bug
Architecture: i386
Date: Wed Oct 28 18:58:07 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.2)
NonfreeKernelModules: nvidia
Package: lirc 0.8.6-0ubuntu2
ProcEnviron:
 LANGUAGE=
 LANG=en_CA.UTF-8
 SHELL=/bin/zsh
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: lirc
Uname: Linux 2.6.31-14-generic i686

ioio85 (ioio85) wrote :
ioio85 (ioio85) wrote :

please ignore the attachment it is causing other issues

Alec Leamas (leamas-alec) wrote :

These links makes no sense, at least not on a reasonable updated lirc. The /dev/lirc? devices are lircd input stuff whereas the /var/run//lircd devices are lircd output sockets. Linking input to output is, well, not ideal.

Partly due to the the bad linking, partly due to the sheer age I'mn closing this one.

Changed in lirc (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers