Ubuntu

Comment 21 for bug 454371

Kevin Worth (kworth) wrote :

Updated from 9.04 to 9.10 and then to 10.04 today. Found that in both newer releases my remote stopped working. Once I made it to 10.04, I looked around and found this thread. Things look like they go back pretty far, so perhaps things are in a better shape today, as I was able to get mine working with no need for special builds.

My current kernel:
# uname -r
2.6.32-21-generic
(System was brought up-to-date today)

My old config (that worked on 9.04 and before):
# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="PVR"
REMOTE_MODULES="lirc_dev lirc_i2c"
REMOTE_DRIVER=""
REMOTE_DEVICE="/dev/lirc0"
REMOTE_LIRCD_CONF="hauppauge/lircd.conf.hauppauge"
REMOTE_LIRCD_ARGS=""

My new config (that works now on 10.04)
# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Hauppauge TV card"
REMOTE_MODULES="ir_kbd_i2c lirc_dev lirc_i2c"
REMOTE_DRIVER="dev/input"
REMOTE_DEVICE="/dev/input/event4"
REMOTE_LIRCD_CONF="hauppauge/lircd.conf.hauppauge"
REMOTE_LIRCD_ARGS=""

dmesg output that let me know ir_kbd_i2c was looking good:
[ 1257.753138] input: i2c IR (CX23418 Z8F0811 Hauppau as /devices/virtual/input/input6
[ 1257.753306] ir-kbd-i2c: i2c IR (CX23418 Z8F0811 Hauppau detected at i2c-0/0-0071/ir0 [cx18 i2c driver #0-0]

Found which /dev/intput/event* device it was by looking at /proc/bus/input/devices
I: Bus=0018 Vendor=0000 Product=0000 Version=0000
N: Name="i2c IR (CX23418 Z8F0811 Hauppau"
P: Phys=i2c-0/0-0071/ir0
S: Sysfs=/devices/virtual/input/input6
U: Uniq=
H: Handlers=kbd event4
B: EV=100003
B: KEY=100fc312 214a802 0 0 0 0 18000 41a8 4801 9e1680 0 0 10000ffc

Fired up irw and tested a few events
000000008001018f 00 green HVR-1100
000000008001018f 01 green HVR-1100
000000008001018f 02 green HVR-1100
00000000800100ae 00 Back/edit HVR-1100

I think the codes for some things may have changed, as I believe previously the codes were recognized as a PVR-350 (also note the typo "Back/edit" not "Back/exit"). So it may require a little editing/regeneration of key config and bindings, but overall things look good.