Please update LIRC to 0.8.6

Bug #432678 reported by Jeremy Yoder
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Karmic
Medium
Tim Gardner
lirc (Debian)
Fix Released
Unknown
lirc (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: lirc

I have a bzr branch with an updated lirc for 0.8.6 here:
https://code.launchpad.net/~jyoder/+junk/lirc-CVS

And a PPA here:
https://launchpad.net/~jyoder/+archive/ppa

I would like this considered for a FeatureFreeze exception to Karmic. This release fixed NUMEROUS issues with the iMON drivers along with other issues. I've been promoting my PPA for over a month now with very good feedback.

This package also cleans up the debian directory structure a lot, making support of new releases in the future much easier. It builds cleanly/installs/and upgrades.

NOTE: Kernel updates to the LIRC modules will also be required to include this in Karmic, but I think it's well worth it for the vast improvement in HTPC user experience.

Changelog from 0.8.6:
0.8.6: 09/13/09
  * added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
    (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
    (Maxim Levitsky)
  * merged 1st-gen mceusb device support into lirc_mceusb2,
    renamed lirc_mceusb2 to lirc_mceusb
  * added support for putting iMON receviers into MCE/RC6 mode
  * added input subsystem mouse device support to iMON driver
  * improved iMON driver to handle dual-interface iMON devices
    via a single lirc device, reducing configuration complexity
  * added support for more iMON devices, including proper support
    for touchscreen iMON devices (Rene Harder)
  * improved iMON driver including touchscreen support
  * Linux input support added to lircmd
  * added support for IT8720 CIR port
  * moved default lircd, lircmd and lircrcd config file locations to
    /etc/lirc/lircd.conf, /etc/lirc/lircmd.conf and /etc/lirc/lircrc
  * moved lircd socket from /dev/lircd to /var/run/lirc/lircd
  * moved default pid file location from /var/run/lircd.pid to
    /var/run/lirc/lircd.pid
  * added support for XMP protocol

Revision history for this message
StefanPotyra (sistpoty) wrote :

what do you mean with "Kernel updates to the LIRC modules will also be required"? Do we need to change the default kernel?

Revision history for this message
StefanPotyra (sistpoty) wrote :

[01:04:05] <superm1> sistpoty, re bug 432678 there is a kernel component that needs to be updated too
[01:04:16] <superm1> it's been on my TODO for the last week or so to fully investigate
[01:04:27] <superm1> but it's a daunting task. i always shrug whenever i need to touch LIRC
[01:05:13] <superm1> if you can make a call in terms of the FFe, i'll sort out the technical details if you lean towards yes though
[01:05:35] <sistpoty> superm1: thanks for the info
[01:05:56] <sistpoty> superm1: basically having you sort out details is what makes me lean very much towards it
[01:06:32] <sistpoty> superm1: the FFe only sounded as if we'd need to make changes to the stock kernel of which noone is aware yet ;)
[01:06:51] <superm1> which is true
[01:07:02] <superm1> there is a LIRC patchset that sits on top of the kernel
[01:07:51] <sistpoty> superm1: will that patchset work with an older lirc?
[01:07:58] <superm1> no it won't
[01:08:09] <superm1> so it's either new LIRC + new patches to kernel
[01:08:15] <superm1> or stay with the current stuff
[01:08:49] <sistpoty> superm1: hm, are you ok if I'll elevate this to ubuntu-release then?
[01:09:25] <superm1> sistpoty, yeah however you'd like to do it. i'll clone a kernel and try to look into the technical details over the weekend

Revision history for this message
StefanPotyra (sistpoty) wrote :

due to either this and touching the kernel, or nothing of both -> ubuntu-release, your call.

Revision history for this message
Mario Limonciello (superm1) wrote :

Here's the two patches that need to get applied to the kernel. I've already merge all of the stuff for 0.8.6 into the bzr branch. Jeremy's changes are very good, and reduce our delta to both upstream and Debian.

Revision history for this message
Mario Limonciello (superm1) wrote :

I've also tested 0.8.6 against my USB mceusb remote.

There needs to be some logic added to force people to re-pick their remote on upgrade, but this shouldn't be very difficult to add to the postinst.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 432678] Re: Please update LIRC to 0.8.6

Plus one from me if the kernel updates get in.

Revision history for this message
Tim Gardner (timg-tpi) wrote :

@Mario - do the LIRC package updates still require a feature freeze exception?

Revision history for this message
Mario Limonciello (superm1) wrote :

@Tim:

I believe that's what this bug is regarding, encompassing the updates for
both the kernel and package pieces.

On Sat, Oct 10, 2009 at 18:01, Tim Gardner <email address hidden>wrote:

> @Mario - do the LIRC package updates still require a feature freeze
> exception?
>
> --
> Please update LIRC to 0.8.6
> https://bugs.launchpad.net/bugs/432678
> You received this bug notification because you are a member of Mythbuntu
> Developers, which is subscribed to lirc in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Revision history for this message
Tim Gardner (timg-tpi) wrote :

Perhaps a better question is, _will_ the LIRC be granted a feature freeze exception (about which I've seen no discussion) ? I'm fine with the kernel patches as long as LIRC is going to be updated. Otherwise, the kernel patches don't make sense.

Revision history for this message
Martin Pitt (pitti) wrote :

This is a fairly intrusive update. Mario, Jeremy, on how much hardware the new 0.8.6 packages were tested? We'd lose all the testing results from the alphas and 9.10 beta with this.

Does this do proper conffile migration? Does it have provisions to mkdir /var/run/lirc/ on boot or startup (a very common bug with programs which use subdirs in /var/run/).

Revision history for this message
Scott Kitterman (kitterman) wrote :

Assuming Mario is in favor of the upgrade, I don't see a problem with
upgrading lirc.

Revision history for this message
Jeremy Yoder (jyoder) wrote :

Yes, it does conffile migration (conffile changes were very minimal) and
it does a mkdir /var/run/lirc in /etc/init.d/lirc if it doesn't exist.

I'm not sure how many different machines this has been tested on, but my
package has been very well received in the feedback I've gotten,
including from the upstream lirc maintainers. I wish there were a way
to tell how many people have added the PPA repository.

Given the number of threads and howtos for the IMON hardware alone, I
think this is a very useful update.

Jeremy

Martin Pitt wrote the following on 10/12/2009 9:28 AM:
> This is a fairly intrusive update. Mario, Jeremy, on how much hardware
> the new 0.8.6 packages were tested? We'd lose all the testing results
> from the alphas and 9.10 beta with this.
>
> Does this do proper conffile migration? Does it have provisions to mkdir
> /var/run/lirc/ on boot or startup (a very common bug with programs which
> use subdirs in /var/run/).
>
>

Artur Rona (ari-tczew)
tags: added: upgrade
Revision history for this message
Mario Limonciello (superm1) wrote :

As Jeremy said, imon support is currently quite a mess to set up (and broken for a lot of people).

From what I gather in seeing tons of forum and mailing list posts, the most common hardware is mceusb2 & imon followed by i2c.

I've personally verified on mceusb2 hardware (well now call mceusb).

-----------
In trying to assess risk for other hardware, here's what I find on that diff (organized by size):

lirc_mceusb/lirc_mceusb2: Merged together. Verified this myself
lirc_imon: Lots of changes here to improve imon support
lirc_i2c: Proper 2.6.31 support. We were working off old patches
lirc_igorplugusb: Code cleanup and shuffling
lirc_sir: Adds support for external dongles
lirc_it87: Adds support for additional chip IDs
lirc_wpc8769l: No functional changes. Whitespace only

Revision history for this message
Scott Kitterman (kitterman) wrote :

Mario,

Do you recommend this change then?

Revision history for this message
Mario Limonciello (superm1) wrote :

Scott:

As this change that would help alleviate the pains of one of the majority
user groups we have (imon), I'd lean on yes.

Revision history for this message
Scott Kitterman (kitterman) wrote :

I think since this really affects mythbuntu, your call with your delegated
release authority.

Revision history for this message
Mario Limonciello (superm1) wrote :

If it's boiling down to Mythbuntu's call, then yes, we want LIRC 0.8.6.

On Mon, Oct 12, 2009 at 13:49, Scott Kitterman <email address hidden> wrote:

> I think since this really affects mythbuntu, your call with your delegated
> release authority.
>
> --
> Please update LIRC to 0.8.6
> https://bugs.launchpad.net/bugs/432678
> You received this bug notification because you are a member of Mythbuntu
> Developers, which is subscribed to lirc in ubuntu.
>

--
Mario Limonciello
<email address hidden>
Sent from Austin, Texas, United States

Revision history for this message
Scott Kitterman (kitterman) wrote :

FFe approved.

Changed in lirc (Ubuntu):
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

OK. Marked it approved. Please follow up on the kernel patches.

Revision history for this message
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Karmic):
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → Medium
milestone: none → ubuntu-9.10
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.31-13.45

---------------
linux (2.6.31-13.45) karmic; urgency=low

  [ Luke Yelavich ]

  * [Config] Add sd_mod to scsi-modules udeb for powerpc

  [ Mario Limonciello ]

  * SAUCE: Update to LIRC 0.8.6
    - LP: #432678

  [ Tim Gardner ]

  * [Config] CONFIG_X86_PAT=y
    https://lists.ubuntu.com/archives/kernel-team/2009-October/007477.html
    https://lists.ubuntu.com/archives/kernel-team/2009-October/007534.html

  * [Config] Add armel arch to linux-libc-dev arches.
    - LP: #449637

  [ Upstream Kernel Changes ]

  * e1000e: swap max hw supported frame size between 82574 and 82583
  * drm/i915: Initialize HDMI outputs as HDMI connectors, not DVI.
    - LP: #392017
  * ALSA: hda - Add quirks for some HP laptops
    - LP: #449742
  * ALSA: hda - Add support for HP dv6
    - LP: #449742

 -- Tim Gardner <email address hidden> Mon, 12 Oct 2009 11:27:10 -0600

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package lirc - 0.8.6-0ubuntu1

---------------
lirc (0.8.6-0ubuntu1) karmic; urgency=low

  [ Jeremy Yoder ]
  * Update to LIRC 0.8.6 release. (LP: #432678)
    - added support for ENE KB3926 revision B/C/D (ENE0100) CIR port
      (found on some notebooks, e.g: Acer Aspire 5720G, HP Pavilion dv5)
      (Maxim Levitsky)
    - New parameter for lircd: --repeat-max
    - merged 1st-gen mceusb device support into lirc_mceusb2,
      renamed lirc_mceusb2 to lirc_mceusb
    - added support for putting iMON receviers into MCE/RC6 mode
    - added input subsystem mouse device support to iMON driver
    - improved iMON driver to handle dual-interface iMON devices
      via a single lirc device, reducing configuration complexity
    - added support for more iMON devices, including proper support
      for touchscreen iMON devices (Rene Harder)
    - improved iMON driver including touchscreen support
    - Linux input support added to lircmd
    - added support for IT8720 CIR port
    - added support for XMP protocol
  * Cleanup more_remotes.hwdb
  * TODO: Make changes to the "lircd.conf.atiusb" and
    "lircd.conf.hauppauge" files PATCHES instead of duplicates
  * TODO: Submit "lircd.conf.atiusb" and
    "lircd.conf.hauppauge" file patches upstream again
  * Changed lirc init script to create socket in /var/run/lirc/lircd
    as is the new default, but also create a symlink /dev/lircd
    to point to it. This makes all clients happy, old and new.
  * Fix bug in dkms.conf.in, forgot to increment array number
    when adding ene0100 driver.
  * Added the extra "Debian-only" remotes and transmitters back
    in, but in a different way. I created a subdirectory
    "debian/extras" and copy that to /usr/share/lirc/extras.
    This avoids patching the source.
    NOTE: CONFIG FILES IN BOTH LOCATIONS WILL USE THE "extras"
    VERSION. DUPLICATE LINES IN lirc.hwdb AND extras/remotes.hwdb
    WILL USE THE extras/remotes.hwdb VERSION. TRY TO AVOID THIS.
  * Added support to build new ene0100 driver
  * Update debian/lircd.init.d to reflect new default
    PID location in /var/run/lirc
  * Update debian/lircd.init.d to force socket to /dev/lircd
    rather than the new default of /var/run/lirc/lircd
  * Add support for new lirc-extras package to
    debian/lirc.postinst
  * Remove /etc/lircd.conf link to /etc/lirc since
    0.8.6 defaults to /etc/lirc/lircd.conf now
  * Drop 04_man_pages patch, included in upstream
  * Drop 16_lirc-gpio in favor of a sed line in debian/rules
  * Drop 28_irrecord_resume_support - Doesn't work
    according to upstream
  * Drop 36_remove_extra_tekram in favor of a minor
    tweak to debian/lirc.postinst to ignore duplicates
  * Drop extra remote control/transmitter patches, move to lirc-extras:
    - 21_atiusb
    - 22_hauppauge_novat_500
    - 23_remove_md8800
    - 24_freecom_dvbt
    - 26_transmitter_lircd.conf
    - 30_medion_md1_remote
    - 31_hauppauge_hvr_1100
    - 32_radioshack_15_2116_remote
    - 33_asus_mycinema_remote
    - 34_nebula_digitaltv_remote
    - 35_general_deviniput
    - 37_msi_tv_anywhere
    - 38_encore_enltv
  * Cleaned up a few lintian warnings

  [ Mario Limonciello ]
...

Read more...

Changed in lirc (Ubuntu Karmic):
status: Confirmed → Fix Released
Changed in lirc (Debian):
status: Unknown → New
Changed in lirc (Debian):
status: New → Fix Committed
Changed in lirc (Debian):
status: Fix Committed → New
Changed in lirc (Debian):
status: New → Fix Released
Revision history for this message
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-lucid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.