[Hardy] LIRC does not generate input events

Bug #262851 reported by Aaron Whitehouse on 2008-08-30
4
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lirc

Using Mythbuntu 8.04, fully updated.

I have a bttv Winfast TV 2000XP (card 34) that is working fine for all TV capture.

The ir receiver does not seem to be generating input events. If I run:
~# lircd -n -d /dev/input/event6 -H devinput
lircd-0.8.3pre1[6477]: lircd(userspace) ready

No further events are received as I push buttons on the remote. The remote worked fine in Windows XP with the enclosed drivers.

The input device seems to have registered correctly.

~# cat /proc/bus/input/devices
I: Bus=0001 Vendor=107d Product=6606 Version=0001
N: Name="bttv IR (card=34)"
P: Phys=pci-0000:02:0a.0/ir0
S: Sysfs=/devices/pci0000:00/0000:00:1e.0/0000:02:0a.0/input/input6
U: Uniq=
H: Handlers=kbd event6
B: EV=100003
B: KEY=10afc336 2150a48 0 0 0 404 80010000 190 4801 1e0000 4400 100000 10000ffc

~# lspci | grep Brooktree
02:0a.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
02:0a.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

If I can be of any further help - any advice would be appreciated. We've RTFM and Google was not My Friend.

> The ir receiver does not seem to be generating input events. If I run:
> ~# lircd -n -d /dev/input/event6 -H devinput

Christoph Bartelmus wrote (on the LIRC mailing list):
Do you get any output from /dev/input/event6 at all?
If not, then the problem is not in LIRC, but the kernel driver which is
part of the Linux kernel.

Have you made sure that you are using the correct config file?

Christoph

My response:
No, we tested that and there was no output.

> Have you made sure that you are using the correct config file?

I thought that, given there were no events coming through, the config
file wouldn't matter - is that the case? I selected my remote in the
Mythbuntu Control Centre GUI, but I'm pretty new to all of this...

So, according to them, my problem is in the kernel.

MarcRandolph (mrand) wrote :

I've been through this lately. This *might* help confirm if it is kernel or not:

$ sudo hexdump -C /dev/input/event6

When I do that, I typically see lots of lines of output for each keypress + keyrelease. For example:

$ sudo hexdump -C /dev/input/by-id/usb-Gyration_Gyration_RF_Technology_Receiver-event-kbd
00000000 ca 9d c4 48 f2 80 03 00 04 00 04 00 8d 00 0c 00 |...H............|
00000010 ca 9d c4 48 1d 81 03 00 01 00 6a 01 01 00 00 00 |...H......j.....|
00000020 ca 9d c4 48 27 81 03 00 00 00 00 00 00 00 00 00 |...H'...........|
00000030 ca 9d c4 48 4e b3 05 00 04 00 04 00 8d 00 0c 00 |...HN...........|
00000040 ca 9d c4 48 76 b3 05 00 01 00 6a 01 00 00 00 00 |...Hv.....j.....|
                                                              ^^ ^^^
                                                     keycode 00 is release, 01 is press
00000050 ca 9d c4 48 82 b3 05 00 00 00 00 00 00 00 00 00 |...H............|

A few of my keys don't produce this output though, even though deeper debugging seems to show that the kernel is detecting them properly - still working on those.

Anyway, if you don't get much output, you might try 8.10 alpha or beta before putting much more time into it. More remotes are supported in the new kernel, and the code has changed considerably from 8.04 (so you won't get much support on that). If it still doesn't work in 8.10, you can help the kernel guys by recompiling the Ubuntu 8.10 kernel with debug enabled and collect data on the key presses.

Thanks Marc,

I really appreciate the help.

That command doesn't give me anything from any button pushes (with any remotes).

I'll try 8.10 soon, but not before it is a little less "alpha" as the
g/f will not be impressed if I stop Mythbuntu from working!

Wow, I'm truly impressed!

I just tested an Alpha 6 live CD and, without installing anything,
volume, numbers (anything non TV-specific) on the remote works
out-of-the-box! Presumably configuring the rest should be possible
now.

Thanks for all of your help.

Mario Limonciello (superm1) wrote :

Since the op mentions the latest live disks doing the trick, i'm closing up this bug.

Changed in lirc:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers