Add resume support to irrecord

Bug #197493 reported by Mario Limonciello on 2008-03-02
6
Affects Status Importance Assigned to Milestone
lirc (Ubuntu)
Medium
Mario Limonciello
Changed in lirc:
assignee: nobody → superm1
status: New → Confirmed
Mathias Hasselmann (hasselmm) wrote :

This patch is really important to support key code recording in gnome-lirc-properties (see LP 192368). The patch sent upstream on 2008-02-13, but it seems Christoph Bartelmus doesn't have the time to apply it yet.

Mathias Hasselmann (hasselmm) wrote :

Patched package is in Openismus PPA: https://launchpad.net/%7Eopenismus-team/+archive

Changed in lirc:
status: Confirmed → In Progress
Changed in lirc:
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.8.3~pre1-0ubuntu7

---------------
lirc (0.8.3~pre1-0ubuntu7) hardy; urgency=low

  [ Mario Limonciello ]
  * Fix a logical error in the init script related
    to udev preventing it from working. (LP: #176616)
  * Fix race conditions with udev (LP: #204672)
  * Backup hardware.conf before changing. (LP: #198903)
  * Add support for the Medion MD1-NBC remote. (LP: #192392)
    - Thanks Florian Fahr
  * Add support for the Hauppauge HVR-1100 remote (LP: #203493)
    - Thanks Lucas
  * Flag repeat events on apple mac mini (LP: #179608)
    - Thanks Don Mahurin
  * Add support for Radioshack 15-2116 remote (LP: #193568)
    - Thanks Scott D
  * Add support for ASUS MyCinema P7131 remote (LP: #190018)
    - Thanks Gianfranco Liporace

  [ Mathias Hasselmann ]
  * Add 28_irrecord_resume_support for resume support to
    irrecord. (LP: #197493)

  [ Andrew Barbaccia ]
  * Fix typo in lirc init script preventing transmitter
    arguments from properly being built. (LP: #204664)
  * Update Scientific Atlanta config in 26_transmitter_lircd.conf.dpatch
    to better naming convention. (LP: #204342)

 -- Mario Limonciello <email address hidden> Sun, 23 Mar 2008 23:25:36 -0500

Changed in lirc:
status: In Progress → Fix Released
Murray Cumming (murrayc) wrote :

Thanks. Please do make sure that these other patches are also submitted upstream. There are rather a lot of them.

Mario Limonciello (superm1) wrote :

Murray,
w/ LIRC we've been leaving it the responsibility of the submitter to send them upstream. Matthias, can you make sure this happens?

Murray Cumming (murrayc) wrote :

> we've been leaving it the responsibility of the submitter to send them upstream.

I don't think that's a good policy. It isn't happening. It's in your interests to reduce the number of patches that you have to apply.

> Matthias, can you make sure this happens?
This patch was submitted upstream first and was only submitted here because of the delay in having it reviewed upstream.

Mathias Hasselmann (hasselmm) wrote :

A can carefully ping Christoph again.

Murray Cumming wrote:
>> we've been leaving it the responsibility of the submitter to send them
> upstream.
>
> I don't think that's a good policy. It isn't happening. It's in your
> interests to reduce the number of patches that you have to apply.
>
>> Matthias, can you make sure this happens?
> This patch was submitted upstream first and was only submitted here because of the delay in having it reviewed upstream.
>
Murray,

We have the same amount of flex as you do for influencing a patch to be added.
With how many packages we maintain, this is a time saver if the submitter of
such a patch can submit it upstream. It won't be until next time the package is
touched sometime during the Intrepid schedule that we'd go through and see which
ones upstream hasn't absorbed and try to add them upstream.

--
Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

I'm preparing another LIRC upload and this patch is having to get updated again. Can you please reping upstream about it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers