iguanaIR support not functional

Bug #153457 reported by lurgy on 2007-10-17
68
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
lirc (Ubuntu)
Wishlist
Unassigned
Nominated for Dapper by Chad
Nominated for Hardy by Chad
Nominated for Intrepid by Chad
Nominated for Jaunty by Chad
Nominated for Karmic by Chad

Bug Description

Binary package hint: lirc

Upon installation (or dpkg-reconfigure) of the lirc package, the configuration gives me the option to support my iguanaworks USB IR receiver. Unfortunately, running lircd --driver=help suggests the lirc package doesn't have iguanaIR support compiled in to it. Can we add support for this?

It turns out we need the iguana IR package in intrepid before we can get this resolved.

Related branches

Mario Limonciello (superm1) wrote :

lirc (0.8.3~pre1-0ubuntu1) hardy; urgency=low

  * New upstream version.
    - Includes Iguanaworks IR Support (LP: #153457)
  * Update 03_extrafiles patch for gpio changes.
  * Update 05_fix_cmdir patch for command IR lirc.hwdb update.
  * Update 12_lirc_pvr150 patch for transmitting support under
    kernel 2.6.22.
  * Update 13-warning-cleanup patch for items that were already
    cleaned up upstream.
  * Drop 14_mceusb2 patch since now included upstream.
  * Drop 14_lirc-i2c patch since now included upstream.
  * Drop 15_macmini patch since now included upstream.
  * Update 16_lirc-gpio patch for added changes upstream.
  * Update 17_devinput patch for added changes upstream.
  * Drop 18_irman-fix patch since now included upstream.
  * Drop 19_serial_support patch since now included upstream.
  * Update 20_serial_igor patch for new serial support upstream.
  * Update 22_hauppauge_novat_500 patch for new support upstream.
  * Add 23_pad2keys patch for pad2keys imon support (LP: #153184).
  * Add 24_freecom_dvbt patch for NovaT 500 Remote (LP: #152539).
  * Clean up lintian warning for -$(MAKE).
  * Clean up lintian warning for ${source:Version}.

 -- Mario Limonciello <email address hidden> Tue, 30 Oct 2007 09:44:55 -0400

Changed in lirc:
status: New → Fix Released
David Hofer (david-hofer) wrote :

Can you confirm that the status of "fix released" is correct? I just got the latest Hardy update today and I'm still not seeing iguanaIR available in the set of supported drivers when I run 'lircd -H ?' as per: http://iguanaworks.net/projects/IguanaIR/wiki/GettingStarted

Thanks for your help.

lurgy (dkuester) wrote :

I'm still running Gutsy on all my boxen, but (perhaps tomorrow?) I'll try giving the latest Hardy a go. Is there a chance the updated lirc package could work on gutsy, or shall I take the plunge and test it with the Hardy alpha?

Markus Vuori (lite) wrote :

I'm running Hardy.

[16:16:38][markus@saturnus:~]$ dpkg -l | grep lirc
ii liblircclient0 0.8.3~pre1-0ubuntu7 LIRC client library
ii lirc 0.8.3~pre1-0ubuntu7 Linux Infra-red Remote Control support

[16:17:56][markus@saturnus:~]$ lircd -H ?
Driver `?' not supported.
Supported drivers:
 accent
 alsa_usb
 asusdh
 atilibusb
 audio_alsa
 bte
 bw6130
 creative
 creative_infracd
 default
 devinput
 dsp
 dvico
 ea65
 i2cuser
 irman
 livedrive_midi
 livedrive_seq
 logitech
 macmini
 mp3anywhere
 mouseremote
 mouseremote_ps2
 null
 pcmak
 pinsys
 pixelview
 sb0540
 silitek
 tira
 udp
 uirt2
 uirt2_raw
 usb_uirt_raw
 usbx

So.. no iguanaworks driver there. Bug hasn't been fixed.

Ilkka Tuohela (hile) wrote :

Hi I just ordered myself some iguanaIR-receivers, and checked this problem report.

This is simply a build problem: while the lirc source has iguanaIR support available and this driver is included when lirc is built with the --with-driver=userspace flag, the build of iguanaIR requires a header to build, and because this header is not available when lirc is built, the support is not included in standard ubuntu package.

So, the standard configure is just skipping iguanaIR because the header is not available.

If you install the iguanair package (which is required to operate the IR-interface anyway) from iguanaworks website, it installs file /usr/include/iguanaIR.h and when this header file is available, the iguanaIR support is included in lirc build with no modifications to lirc package sources, so this will fix this problem for users with the header:

apt-get source lirc && apt-get build-dep lirc
(cd lirc-0.8.3~pre1; dpkg-buildpackage-us -uc)
dpkg -i lirc_0.8.3*.deb

The iguanaIR headers and driver are released under GPL license. I think proper long term solution is to:
- split the iguanair package to a client and a -dev package, adding README, HOWTO etc docs required
- add these packages to ubuntu release
- after the packages are available, add a build dependency of iguanair-dev to lirc build

I'm not a ubuntu developer or MOTU, so I can't really bring this issue any further, but hope this helps package maintainers. For the iguanair source code etc., see http://iguanaworks.net/downloads.php. They already provide some .deb packages.

Ilkka Tuohela (hile) wrote :

Oh, and as a temporary solution, before iguanair-dev is available in ubuntu:

I think the lirc package could actually include the iguanaIR.h file in the package build process with no problems, not installing it or anything, just make it available so that standard package builds cleanly.

All iguanaIR source code, including the required header iguanaIR.h, are under GPL license, just like lirc, and the source is available from:

http://iguanaworks.net/downloads.php

It would be great if LIRC maintainers could get this build change to the hardy packages. Meanwhile, I'll be rebuilding my own lirc package.

aporter (aporter) wrote :

Should we mark this bug as open? It's clear by the comments that this bug has reappeared.

laga (laga) wrote :

Ok, I'm setting this back to "confirmed". Thanks for the reports.

Changed in lirc:
status: Fix Released → Confirmed
Mario Limonciello (superm1) wrote :

Well once we get iguanair in intrepid we'll fix this in lirc.

Changed in lirc:
status: Confirmed → Triaged
description: updated
Changed in lirc:
importance: Undecided → Wishlist
faceman (jfacemyer) wrote :

I followed the directions for rebuilding LIRC in Hardy with Iguana support - IguanaIR is installed, the header is in the right place, but the compile breaks:

dh_shlibdeps -s
dpkg-shlibdeps: failure: no dependency information found for /usr/lib/libiguanaIR.so.0 (used by debian/lirc/usr/bin/irrecord).
dh_shlibdeps: command returned error code 512
make: *** [binary-arch] Error 1
dpkg-buildpackage: failure: debian/rules binary gave error exit status 2

I know Intrepid is just over the horizon, but I'd like to make this work - it may be a while before I can upgrade.

faceman (jfacemyer) wrote :

I'm sure you're all aware, but this is still a problem in Intrepid - both lack of IguanaIR support and ability to compile as per the above directions. I still get the previous error when following directions above to compile LIRC.

jboehm (jbpub) wrote :

I too noticed that this has not been fixed in Intrepid.

faceman (jfacemyer) wrote :

So...............

is there any possibility of either getting a fix applied or someone helping to diagnose the problem?

jboehm (jbpub) wrote :

I wrote an email IguanaIR support asking for a how-to that was a little clearer. This was their reply.

-----------------
1) Install our iguanaIR package from our deb repository (see
http://www.iguanaworks.net/downloads.php?distro=deb )

2) run "sudo apt-get build-dep lirc"

3) run (in some temp directory) "sudo apt-get -b source lirc"

4) if 3) goes without problems, you will have lirc deb packages you can
install (sudo dpkg -i *.deb) and they should have iguanaIR support.
-----------------

This works great except as soon as I install it, the update manager says it has a new rev of lirc to install. It doesn't. I just doesn't like my new home built versions. I wish I could tell the update system not to try and update lirc unless a truly new version comes out. Then I'll have to run the above steps again, that is until this bug is truly fixed.

faceman (jfacemyer) wrote :

I just tried it and got the same error I posted above.

I had also written an email to the iguana guys and I think they're looking into it. Meanwhile, if anyone can interpret what the problem is...

faceman (jfacemyer) wrote :

I've removed and reinstalled iguanair and lirc, and the device appears to work even without recompiling.

faceman (jfacemyer) wrote :

I was incorrect - it turned out to be my own version of lirc (which I had compiled once and installed completely manually) which was working.

I can't even reproduce the success, much less in a .deb which can be used to install lirc correctly.

Seriously, can this get some attention? I'll be happy to do whatever I need to so that IguanaIR can be included in the lirc package.

aporter (aporter) wrote :

I have also confirmed that the package in intrepid (8.10) does not have iguana support. I've been getting the lirc from lirc's website and compiling manually. I haven't tried lirc on my jaunty (9.04) machine yet.

OffAxis (weilmark) wrote :

The lirc package in jaunty (9.04) does not have iguana support.

Chad (masterclc) wrote :

This is the kind of problem Ubuntu has always been "designed" to fix... Instead this appears to be seeing the kind of affection typical Debian would apply to packages necessary to get something to work correctly. By taking a "not our problem" approach this is making it extremely difficult for the average Ubuntu user to actually use this piece of hardware. Come on folks, it is truly trivial to get this working correctly in an actual release the users can use (from a power user/dev position anyway). Can we get support soon?

Thanks!

-Chad

aporter (aporter) wrote :

The lirc package in karmic does not have iguana support. I can help test a karmic or lucid update if someone tells me what to do.

Chad (masterclc) wrote :

Just poking my head in here to see if there is something I can do to help get this working... Do we need a package maintainer? If so, I'm willing to volunteer for that job if someone would like to point me towards a resource to be that guy.

Thanks!

-Chad

This issue still hasn't been resolved as of 10.04 Beta 2.

To fully support this device, the following needs to be installed:

libusb-1.0.0 (important, 0.1.4 isn't recent enough and causes channel change difficulties)

and

http://www.iguanaworks.net/downloads/debian/binary-i386/iguanair_1.0pre2_i386.deb

and

http://www.iguanaworks.net/downloads/lirc_0.8.6-0ubuntu2_i386.deb

which is the pre-compiled LIRC by the IguanaWorks guys because Ubuntu is still distributing LIRC without the iguanaIR driver compiled in.

Mario Limonciello (superm1) wrote :

I've add a task for the Debian ITP for iguanaIR. Once that's resolved, this bug can be fixed.

Stew Ellis (ellis-kettering) wrote :

I am running 10.04.1 on an Asus EB1012. I was able to work around this with the iguanair deb file that is currently on iguanaworks .net, iguanaIR-1.0.1-1.i386.deb, but the lirc package they had there, lirc_0.8.7~pre3-0ubuntu1_i386.deb, gave a broken install. I rm'ed it and used the link above in comment #23, and it works, but it is not exposed in their downloads section anymore. I followed their advice to issue the command "echo lirc hold| sudo dpkg --set-selections", although I am not sure it will work. Synaptic shows a bang in the icon button for lirc. I will have to wait and see what update manager tries to do with it.

From what I gather here there is some problem upstream with including iguanaIR in Debian. Is this some sort of purity deal? Is there some legitimate reason support is not included? What is Debian ITP?

I have been using and programming for UNIX for 25 years and even with all the wonderful features it still takes pretty much of an expert to get many things running. I have spent almost two full days to get this running.

Changed in debian:
status: Unknown → Fix Released
Mark Weil (mark-martialfit) wrote :

The fix didn't make it into 11.10; does anyone know if it's in 12.04?

Zac (zac280) wrote :

lircd -H '?' does not list iguanaIR in 12.04 either. I compiled it into the source, as has been the method, only this time I stupidly let ubuntu update and it broke it. Now the problem is LIRC won't apt-get install after a apt-get remove. Removing iguanaIR doesn't help. See https://bugs.launchpad.net/ubuntu/+source/lirc/+bug/1004239

Alec Leamas (leamas-alec) wrote :

The new version 0.9.4b in zesty - experimental has completely new driver handling based on dynamic loading. While it doesn't include the iguanaIR driver, it's a simple task to compile it out-of-tree and add it to lirc without changing anything of the installed package. See https://github.com/iguanaworks/iguanair-lirc. If the iguanair driver should be made part of ubuntu, it should be a separate package like lirc-drv-iguanair, available on some other distros

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lirc - 0.9.4c-1

---------------
lirc (0.9.4c-1) experimental; urgency=medium

  * New upstream release.
  * New tool irtext2udp.
  * Resolves build errors on kernels > 4.8.0A.
  * Most of patches upstreamed.

 -- Alec Leamas <email address hidden> Sat, 22 Oct 2016 14:52:05 +0200

Changed in lirc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.