Sound in liquidwar does not work

Bug #545884 reported by KIAaze
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
liquidwar (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: liquidwar

Here's the output when running it from a terminal:
==========
Starting Allegro (http://www.talula.demon.co.uk/allegro) - success!

Allegro ID : Allegro 4.2.2, Unix

Loading config options from "~/.liquidwarrc" - success!
Installing timer (driver="Unix pthreads timers") - success!
Installing keyboard (driver="X11 keyboard") - success!
Installing mouse (driver="X-Windows mouse") - success!
ALSA lib rawmidi_hw.c:233:(snd_rawmidi_hw_open) open /dev/snd/midiC0D0 failed: No such file or directory
Installing sound - failed...
Installing joystick (driver="No joystick") - success!
Setting up network - success!
Allocating 16 Mb - success!

Loading data from "/usr/share/games/liquidwar/liquidwar.dat" - success!
Loading fonts - success!
Loading maps - success!
Loading background bitmap - success!
Loading sound fx - success!
Loading textures - success!
Loading map textures - success!
Loading water sounds - success!
Loading midi music - success!

Loading custom textures from "/usr/share/games/liquidwar/texture" +++++ - success!
Loading custom maps from "/usr/share/games/liquidwar/map" ++++ - success!
Loading custom musics from "/usr/share/games/liquidwar/music" + - success!

Changing video mode to 640x480, windowed (driver="X11 window") - success!

Leaving Allegro (http://www.talula.demon.co.uk/allegro)

Liquid War by U-Foot

v5.6.4 compiled on Nov 7 2008 at 13:32:40
Copyright (C) 1998-2007 Christian Mauduit

This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Liquid War homepage : http://www.ufoot.org/liquidwar/v5
Contact author : <email address hidden>

Thanks for playing Liquid War, I hope you enjoyed it!
==========

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 24 11:18:27 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: liquidwar 5.6.4-1
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: liquidwar
Uname: Linux 2.6.31-20-generic x86_64

Revision history for this message
KIAaze (zohn-joidberg) wrote :
Revision history for this message
KIAaze (zohn-joidberg) wrote :
Revision history for this message
Christian Mauduit (ufoot) wrote :

Looks like there's some problem with midi. I suspect installing timidity and running it as a server (it's daemonizable) could solve the problem.

Maybe trying "liquidwar -nomusic" could help, not trying to open midi devices might cause other digi driver to work anyway. Untested.

Revision history for this message
KIAaze (zohn-joidberg) wrote : Re: [Bug 545884] Re: Sound in liquidwar does not work

Wow, quite an old bug. Will try it again as soon as possible.

2011/8/31 Christian Mauduit <email address hidden>:
> Looks like there's some problem with midi. I suspect installing timidity
> and running it as a server (it's daemonizable) could solve the problem.
>
> Maybe trying "liquidwar -nomusic" could help, not trying to open midi
> devices might cause other digi driver to work anyway. Untested.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/545884
>
> Title:
>  Sound in liquidwar does not work
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/liquidwar/+bug/545884/+subscriptions
>

--
Unlock your computing: http://www.getgnulinux.org/
If the above link is down: http://www.linux.com/learn/new-user-guides

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers