adcs Connect failed: SSL Error

Bug #722959 reported by Rafael Driutti on 2011-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linuxdcpp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linuxdcpp

Can't connect to a hub running ADCH++ v2.7.0 (r481) using TLS. I get the following error:

*** Connecting to adcs://zaku.local:2780...
*** Connected
*** Connect failed: SSL Error: error:00000005:lib(0):func(0):reason(5) (0, 5)

I tried both ubuntu 10.4 and 10.10 and have the same problem. The version of the package linuxdcpp is 1.0.3-1ubuntu2.

I think it's worth mentioning that using the version from lp:linuxdcppworks as expected i.e. I can succesfully connect to and adc hub using TLS security, and the same certificates.

Razzloss (razzloss) wrote :

Can't decide what to change the status of this bug to so I'll leave it as new.

Anyway 0.698 core used in Linuxdcpp 1.0.3 doesn't support ADC 1.0, which is used by all the recent ADC hubs. The only way to fix this is to update the core. So wait for the Linuxdcpp-1.1.0 release (and packaging) or use the development trunk (lp:linuxdcpp).

--RZ

Steven Sheehy (steven-sheehy) wrote :

I think Fix committed is the correct status for this bug since it's in bzr but has not been released yet.

Changed in linuxdcpp (Ubuntu):
status: New → Fix Committed
tags: added: core ssl
JC Hulce (soaringsky) wrote :

This bug has been marked as Fix Committed for over a year. If the fix has made it into Ubuntu, please mark this bug as Fix Released. If the fix has been released upstream, but not Ubuntu, create a new bug asking for the new version and tag it with upgrade-software-version. If this bug has not been fixed anywhere, change the status back to Confirmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers