Crash when switching tabs

Bug #339700 reported by William Wynn
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
LinuxDC++
High
Steven Sheehy
linuxdcpp (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linuxdcpp

linuxdcpp occasionally freezes and grays out when switching tabs.
When it freezes, the window turns white and gray before the entire windows grays out. The program process must be ended.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/linuxdcpp
NonfreeKernelModules: nvidia
Package: linuxdcpp 1.0.2-1
ProcCmdline: linuxdcpp
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: linuxdcpp
StacktraceTop:
 IA__g_type_value_table_peek (type=158026304)
 IA__g_value_peek_pointer (value=0x99e31c8)
 g_type_class_meta_marshal (closure=0x95ba650,
 IA__g_closure_invoke (closure=0x95ba650, return_value=0x0,
 signal_emit_unlocked_R (node=0x96a5cf0, detail=0,
Title: linuxdcpp crashed with SIGSEGV in IA__g_type_value_table_peek()
Uname: Linux 2.6.28-8-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

Related branches

Revision history for this message
William Wynn (williamwynn) wrote :
Revision history for this message
Daniel Aronoff (da0487) wrote :

I am trying to recreate this bug. Can you provide an (more specific) example of an activity that causes it to cash?

Revision history for this message
William Wynn (williamwynn) wrote :

I'm having trouble making it happen now that I want to. It's almost as if it's doomed to happen from the start sometimes, and other times it doesn't happen at all. It sometimes happens when scrolling up and down through a long connected users list when I'm searching for someone. I'll post exactly what I was doing next time it happens.

Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:IA__g_type_value_table_peek (type=158026304)
IA__g_value_peek_pointer (value=0x99e31c8)
g_type_class_meta_marshal (closure=0x95ba650,
IA__g_closure_invoke (closure=0x95ba650, return_value=0x0,
signal_emit_unlocked_R (node=0x96a5cf0, detail=0,

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Changed in linuxdcpp:
importance: Undecided → Medium
Revision history for this message
Steven Sheehy (steven-sheehy) wrote : Re: linuxdcpp crashed with SIGSEGV in IA__g_type_value_table_peek()

Thanks for the report. It seems to be stuck in an infinite loop of signals and events due the tab raising functionality. How are you switching the tabs (mouse clicking, ctrl-tab, the tabs menu) and what type of tabs are you switching when it occurs (hub, pm, search, etc)? If you can narrow down exactly when it occurs it would be very helpful.

Revision history for this message
William Wynn (williamwynn) wrote :

It happend when I was switching between PM tabs. The hub I connect to has several specific PM rooms (I'm guessing through IRC) and I often switch quickly between tabs to catch up with a conversation. I always switch tabs by clicking the bars across the top.

There is a possibility it was from a search tab to a user tab, but I'll check out and see if it will happen again or if I can cause it to crash and let you know more exact details.

The other things I mentioned that crashed it I think are unrelated. They have stopped happening and crashed differently than this one did. I'll remove those from the description since you seem to have narrowed it down.

description: updated
Revision history for this message
Steven Sheehy (steven-sheehy) wrote :

I committed a fix for this to trunk. It should hopefully stop the infinite invocation of signals that eventually leads to a crash.

Changed in linuxdcpp:
assignee: nobody → Steven Sheehy (steven-sheehy)
importance: Undecided → High
milestone: none → 1.1.0
status: New → Fix Committed
summary: - linuxdcpp crashed with SIGSEGV in IA__g_type_value_table_peek()
+ Crash when switching tabs
Changed in linuxdcpp (Ubuntu):
status: New → Confirmed
tags: added: crash ui
Changed in linuxdcpp (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Olorin (vivliofika) wrote :

could you make a ppa, please? - It's because of my client hanging up. Please!

Revision history for this message
Razzloss (razzloss) wrote :

This is already included in the PPAs. The fix was committed to the trunk few months ago.

--RZ

Revision history for this message
Olorin (vivliofika) wrote :

but it still hangs up!

Revision history for this message
Razzloss (razzloss) wrote :

Well that's a different bug or this one hasn't been properly fixed then.

Next time it hangs, attach gdb and get a full backtrace
1) start gdb,
2) attach PID-of-linuxdcpp
3) thread apply all bt full

You probably should file a new bug with the backtrace attached since I don't think this is related (this one crashed, yours just hangs).

--RZ

Revision history for this message
Kristoffer Grundström (umeaboy) wrote :

This still affects me.

Here's my output: http://umeaboy.pastebin.com/abzWDcFm

Revision history for this message
Steven Sheehy (steven-sheehy) wrote :

I don't see any indication of a crash in your output. The thread is simply waiting on some lock. Perhaps the crash is in another thread that you didn't get output for, in which case you need to run 'thread apply all bt full' next time.

Changed in linuxdcpp (Ubuntu):
status: Fix Committed → Fix Released
Changed in linuxdcpp:
status: Fix Committed → Fix Released
Revision history for this message
Martijn Heemels (yggdrasil) wrote :

Does anyone have the ability to block Kristoffer Grundström?
His account seems to be used to spam comments in bugreports. I haven't found a way to file an 'abuse' report or something similar on his account.

Revision history for this message
Sergey Basalaev (sbasalaev) wrote :

Martin, spam reports may be filed in support tracker. I've reported it here https://answers.launchpad.net/launchpad/+question/173483

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers