linux 5.4.0-26.30 source package in Ubuntu

Changelog

linux (5.4.0-26.30) focal; urgency=medium

  * focal/linux: 5.4.0-26.30 -proposed tracker (LP: #1873882)

  * Packaging resync (LP: #1786013)
    - update dkms package versions

  * swap storms kills interactive use (LP: #1861359)
    - SAUCE: drm/i915: prevent direct writeback from the shrinker

  * 5.4.0-24.28 does not seem to apply rtprio, whereas -21 does. (LP: #1873315)
    - [Config] lowlatency: turn off RT_GROUP_SCHED

  * [RTL810xE] No ethernet connection (LP: #1871182)
    - net: phy: realtek: fix handling of RTL8105e-integrated PHY

 -- Andrea Righi <email address hidden>  Mon, 20 Apr 2020 18:33:49 +0200

Upload details

Uploaded by:
Andrea Righi
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64 armhf arm64 ppc64el s390x i386
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Focal release main devel

Downloads

File Size SHA-256 Checksum
linux_5.4.0.orig.tar.gz 162.4 MiB 805f3ed93854317814c59caf2dbfd2097745685f95c8c18b509c9347dcc7d51f
linux_5.4.0-26.30.diff.gz 4.0 MiB f7700ed6c0a5b8fee2d1d605b8830f35b116adc7d78f6ecea2647bbde8f17b3a
linux_5.4.0-26.30.dsc 7.0 KiB ee57181c9c9f5ab79ee106888701fd6bc14bb67f6dafdc6f2e01a60612221099

View changes file

Binary packages built by this source

block-modules-5.4.0-26-generic-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-5.4.0-26-generic-lpae-di: No summary available for block-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for block-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

crypto-modules-5.4.0-26-generic-di: No summary available for crypto-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for crypto-modules-5.4.0-26-generic-di in ubuntu groovy.

crypto-modules-5.4.0-26-generic-lpae-di: No summary available for crypto-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for crypto-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

dasd-extra-modules-5.4.0-26-generic-di: DASD storage support -- extras
dasd-modules-5.4.0-26-generic-di: No summary available for dasd-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for dasd-modules-5.4.0-26-generic-di in ubuntu groovy.

fat-modules-5.4.0-26-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-5.4.0-26-generic-lpae-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fb-modules-5.4.0-26-generic-di: Framebuffer modules
firewire-core-modules-5.4.0-26-generic-di: Firewire (IEEE-1394) Support
floppy-modules-5.4.0-26-generic-di: Floppy driver support
fs-core-modules-5.4.0-26-generic-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-5.4.0-26-generic-lpae-di: No summary available for fs-core-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for fs-core-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

fs-secondary-modules-5.4.0-26-generic-di: No summary available for fs-secondary-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for fs-secondary-modules-5.4.0-26-generic-di in ubuntu groovy.

fs-secondary-modules-5.4.0-26-generic-lpae-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

input-modules-5.4.0-26-generic-di: Support for various input methods
input-modules-5.4.0-26-generic-lpae-di: Support for various input methods
ipmi-modules-5.4.0-26-generic-di: ipmi modules
ipmi-modules-5.4.0-26-generic-lpae-di: ipmi modules
kernel-image-5.4.0-26-generic-di: No summary available for kernel-image-5.4.0-26-generic-di in ubuntu groovy.

No description available for kernel-image-5.4.0-26-generic-di in ubuntu groovy.

kernel-image-5.4.0-26-generic-lpae-di: No summary available for kernel-image-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for kernel-image-5.4.0-26-generic-lpae-di in ubuntu groovy.

linux-buildinfo-5.4.0-26-generic: Linux kernel buildinfo for version 5.4.0 on RISC-V SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 RISC-V SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-5.4.0-26-generic-lpae: No summary available for linux-buildinfo-5.4.0-26-generic-lpae in ubuntu groovy.

No description available for linux-buildinfo-5.4.0-26-generic-lpae in ubuntu groovy.

linux-buildinfo-5.4.0-26-lowlatency: Linux kernel buildinfo for version 5.4.0 on 64 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 5.4.0 on
 64 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-cloud-tools-5.4.0-26: Linux kernel version specific cloud tools for version 5.4.0-26

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 5.4.0-26 on
 64 bit x86.
 You probably want to install linux-cloud-tools-5.4.0-26-<flavour>.

linux-cloud-tools-5.4.0-26-generic: Linux kernel version specific cloud tools for version 5.4.0-26

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.4.0-26 on
 64 bit x86.

linux-cloud-tools-5.4.0-26-lowlatency: No summary available for linux-cloud-tools-5.4.0-26-lowlatency in ubuntu groovy.

No description available for linux-cloud-tools-5.4.0-26-lowlatency in ubuntu groovy.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 5.4.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version 5.4.0.

linux-doc: No summary available for linux-doc in ubuntu groovy.

No description available for linux-doc in ubuntu groovy.

linux-headers-5.4.0-26: Header files related to Linux kernel version 5.4.0

 This package provides kernel header files for version 5.4.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-26/debian.README.gz for details

linux-headers-5.4.0-26-generic: Linux kernel headers for version 5.4.0 on RISC-V SMP

 This package provides kernel header files for version 5.4.0 on
 RISC-V SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-26/debian.README.gz for details.

linux-headers-5.4.0-26-generic-lpae: Linux kernel headers for version 5.4.0 on ARM (hard float) SMP

 This package provides kernel header files for version 5.4.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-26/debian.README.gz for details.

linux-headers-5.4.0-26-lowlatency: Linux kernel headers for version 5.4.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.4.0-26/debian.README.gz for details.

linux-image-5.4.0-26-generic: Linux kernel image for version 5.4.0 on RISC-V SMP

 This package contains the Linux kernel image for version 5.4.0 on
 RISC-V SMP.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-5.4.0-26-generic-dbgsym: Linux kernel debug image for version 5.4.0 on RISC-V SMP

 This package provides the kernel debug image for version 5.4.0 on
 RISC-V SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-5.4.0-26-generic-lpae: Linux kernel image for version 5.4.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-5.4.0-26-generic-lpae-dbgsym: Linux kernel debug image for version 5.4.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 5.4.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.4.0-26-generic: No summary available for linux-image-unsigned-5.4.0-26-generic in ubuntu groovy.

No description available for linux-image-unsigned-5.4.0-26-generic in ubuntu groovy.

linux-image-unsigned-5.4.0-26-generic-dbgsym: Linux kernel debug image for version 5.4.0 on ARMv8 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.4.0-26-lowlatency: Linux kernel image for version 5.4.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 5.4.0 on
 64 bit x86 SMP.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.4.0-26-lowlatency-dbgsym: Linux kernel debug image for version 5.4.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.4.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-libc-dev: Linux Kernel Headers for development

 This package provides headers from the Linux kernel. These headers
 are used by the installed headers for GNU glibc and other system
 libraries. They are NOT meant to be used to build third-party modules for
 your kernel. Use linux-headers-* packages for that.

linux-modules-5.4.0-26-generic: Linux kernel extra modules for version 5.4.0 on RISC-V SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-5.4.0-26-generic-lpae: No summary available for linux-modules-5.4.0-26-generic-lpae in ubuntu groovy.

No description available for linux-modules-5.4.0-26-generic-lpae in ubuntu groovy.

linux-modules-5.4.0-26-lowlatency: Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-5.4.0-26-generic: Linux kernel extra modules for version 5.4.0 on RISC-V SMP

 This package contains the Linux kernel extra modules for version 5.4.0 on
 RISC-V SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-source-5.4.0: Linux kernel source for version 5.4.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 5.4.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-5.4.0-26: Linux kernel version specific tools for version 5.4.0-26

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-26 on
 ARM (hard float).
 You probably want to install linux-tools-5.4.0-26-<flavour>.

linux-tools-5.4.0-26-generic: No summary available for linux-tools-5.4.0-26-generic in ubuntu groovy.

No description available for linux-tools-5.4.0-26-generic in ubuntu groovy.

linux-tools-5.4.0-26-generic-lpae: Linux kernel version specific tools for version 5.4.0-26

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0-26 on
 ARM (hard float).

linux-tools-5.4.0-26-lowlatency: No summary available for linux-tools-5.4.0-26-lowlatency in ubuntu groovy.

No description available for linux-tools-5.4.0-26-lowlatency in ubuntu groovy.

linux-tools-common: Linux kernel version specific tools for version 5.4.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.4.0.

linux-tools-host: Linux kernel VM host tools

 This package provides kernel tools useful for VM hosts.

linux-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-generic-lpae: No summary available for linux-udebs-generic-lpae in ubuntu groovy.

No description available for linux-udebs-generic-lpae in ubuntu groovy.

md-modules-5.4.0-26-generic-di: Multi-device support (raid, device-mapper, lvm)
md-modules-5.4.0-26-generic-lpae-di: Multi-device support (raid, device-mapper, lvm)
message-modules-5.4.0-26-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-5.4.0-26-generic-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-5.4.0-26-generic-lpae-di: No summary available for mouse-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for mouse-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

multipath-modules-5.4.0-26-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-5.4.0-26-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-5.4.0-26-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-5.4.0-26-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-5.4.0-26-generic-di: Network interface support
nic-modules-5.4.0-26-generic-lpae-di: Network interface support
nic-pcmcia-modules-5.4.0-26-generic-di: No summary available for nic-pcmcia-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for nic-pcmcia-modules-5.4.0-26-generic-di in ubuntu groovy.

nic-shared-modules-5.4.0-26-generic-di: No summary available for nic-shared-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for nic-shared-modules-5.4.0-26-generic-di in ubuntu groovy.

nic-shared-modules-5.4.0-26-generic-lpae-di: No summary available for nic-shared-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for nic-shared-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

nic-usb-modules-5.4.0-26-generic-di: USB network interface support
nic-usb-modules-5.4.0-26-generic-lpae-di: No summary available for nic-usb-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for nic-usb-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

parport-modules-5.4.0-26-generic-di: Parallel port support
parport-modules-5.4.0-26-generic-lpae-di: Parallel port support
pata-modules-5.4.0-26-generic-di: No summary available for pata-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for pata-modules-5.4.0-26-generic-di in ubuntu groovy.

pcmcia-modules-5.4.0-26-generic-di: No summary available for pcmcia-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for pcmcia-modules-5.4.0-26-generic-di in ubuntu groovy.

pcmcia-storage-modules-5.4.0-26-generic-di: No summary available for pcmcia-storage-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for pcmcia-storage-modules-5.4.0-26-generic-di in ubuntu groovy.

plip-modules-5.4.0-26-generic-di: PLIP (parallel port) networking support
plip-modules-5.4.0-26-generic-lpae-di: PLIP (parallel port) networking support
ppp-modules-5.4.0-26-generic-di: PPP (serial port) networking support
ppp-modules-5.4.0-26-generic-lpae-di: PPP (serial port) networking support
sata-modules-5.4.0-26-generic-di: SATA storage support
sata-modules-5.4.0-26-generic-lpae-di: SATA storage support
scsi-modules-5.4.0-26-generic-di: SCSI storage support
scsi-modules-5.4.0-26-generic-lpae-di: No summary available for scsi-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

No description available for scsi-modules-5.4.0-26-generic-lpae-di in ubuntu groovy.

serial-modules-5.4.0-26-generic-di: Serial port support
storage-core-modules-5.4.0-26-generic-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-5.4.0-26-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-5.4.0-26-generic-di: Core USB support
usb-modules-5.4.0-26-generic-lpae-di: Core USB support
virtio-modules-5.4.0-26-generic-di: No summary available for virtio-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for virtio-modules-5.4.0-26-generic-di in ubuntu groovy.

vlan-modules-5.4.0-26-generic-di: No summary available for vlan-modules-5.4.0-26-generic-di in ubuntu groovy.

No description available for vlan-modules-5.4.0-26-generic-di in ubuntu groovy.

vlan-modules-5.4.0-26-generic-lpae-di: vlan modules

 This package contains vlan (8021.Q) modules.