linux 5.11.0-16.17 source package in Ubuntu

Changelog

linux (5.11.0-16.17) hirsute; urgency=medium

  * hirsute beta desktop AMD64 ISO kernel panic on boot when booting using UEFI
    (LP: #1922403)
    - SAUCE: efifb: Check efifb_pci_dev before using it

 -- Seth Forshee <email address hidden>  Wed, 14 Apr 2021 14:31:58 -0500

Upload details

Uploaded by:
Seth Forshee on 2021-04-14
Uploaded to:
Hirsute
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64 armhf arm64 ppc64el s390x i386 riscv64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Hirsute release on 2021-04-19 main devel

Downloads

File Size SHA-256 Checksum
linux_5.11.0.orig.tar.gz 177.7 MiB 8e7f07e91e9aa0611b749fd1a908dc9d28c7d612f831e9d273427d4442b55f25
linux_5.11.0-16.17.diff.gz 4.5 MiB a5ecbaee0c777275731b7f67d2a636d126725404a73376f558f1265841f88062
linux_5.11.0-16.17.dsc 8.3 KiB aafb89cffec389f1bbc702a57ab79063f6be61fe8866b558bba402a23c03fbc0

View changes file

Binary packages built by this source

linux-buildinfo-5.11.0-16-generic: No summary available for linux-buildinfo-5.11.0-16-generic in ubuntu impish.

No description available for linux-buildinfo-5.11.0-16-generic in ubuntu impish.

linux-buildinfo-5.11.0-16-generic-64k: No summary available for linux-buildinfo-5.11.0-16-generic-64k in ubuntu impish.

No description available for linux-buildinfo-5.11.0-16-generic-64k in ubuntu impish.

linux-buildinfo-5.11.0-16-generic-lpae: Linux kernel buildinfo for version 5.11.0 on ARM (hard float) SMP

 This package contains the Linux kernel buildinfo for version 5.11.0 on
 ARM (hard float) SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-5.11.0-16-lowlatency: Linux kernel buildinfo for version 5.11.0 on 64 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 5.11.0 on
 64 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-cloud-tools-5.11.0-16: Linux kernel version specific cloud tools for version 5.11.0-16

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 5.11.0-16 on
 64 bit x86.
 You probably want to install linux-cloud-tools-5.11.0-16-<flavour>.

linux-cloud-tools-5.11.0-16-generic: Linux kernel version specific cloud tools for version 5.11.0-16

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 5.11.0-16 on
 64 bit x86.

linux-cloud-tools-5.11.0-16-lowlatency: No summary available for linux-cloud-tools-5.11.0-16-lowlatency in ubuntu impish.

No description available for linux-cloud-tools-5.11.0-16-lowlatency in ubuntu impish.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 5.11.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version 5.11.0.

linux-doc: Linux kernel specific documentation for version 5.11.0

 This package provides the various documents in the 5.11.0 kernel
 Documentation/ subdirectory. These document kernel subsystems, APIs, device
 drivers, and so on. See
 /usr/share/doc/linux-doc/00-INDEX for a list of what is
 contained in each file.

linux-headers-5.11.0-16: No summary available for linux-headers-5.11.0-16 in ubuntu impish.

No description available for linux-headers-5.11.0-16 in ubuntu impish.

linux-headers-5.11.0-16-generic: Linux kernel headers for version 5.11.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.11.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.11.0-16/debian.README.gz for details.

linux-headers-5.11.0-16-generic-64k: Linux kernel headers for version 5.11.0 on ARMv8 SMP

 This package provides kernel header files for version 5.11.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.11.0-16/debian.README.gz for details.

linux-headers-5.11.0-16-generic-lpae: Linux kernel headers for version 5.11.0 on ARM (hard float) SMP

 This package provides kernel header files for version 5.11.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.11.0-16/debian.README.gz for details.

linux-headers-5.11.0-16-lowlatency: Linux kernel headers for version 5.11.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.11.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.11.0-16/debian.README.gz for details.

linux-image-5.11.0-16-generic: No summary available for linux-image-5.11.0-16-generic in ubuntu impish.

No description available for linux-image-5.11.0-16-generic in ubuntu impish.

linux-image-5.11.0-16-generic-dbgsym: No summary available for linux-image-5.11.0-16-generic-dbgsym in ubuntu impish.

No description available for linux-image-5.11.0-16-generic-dbgsym in ubuntu impish.

linux-image-5.11.0-16-generic-lpae: Linux kernel image for version 5.11.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 5.11.0 on
 ARM (hard float) SMP.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-5.11.0-16-generic-lpae-dbgsym: No summary available for linux-image-5.11.0-16-generic-lpae-dbgsym in ubuntu impish.

No description available for linux-image-5.11.0-16-generic-lpae-dbgsym in ubuntu impish.

linux-image-unsigned-5.11.0-16-generic: No summary available for linux-image-unsigned-5.11.0-16-generic in ubuntu impish.

No description available for linux-image-unsigned-5.11.0-16-generic in ubuntu impish.

linux-image-unsigned-5.11.0-16-generic-64k: No summary available for linux-image-unsigned-5.11.0-16-generic-64k in ubuntu impish.

No description available for linux-image-unsigned-5.11.0-16-generic-64k in ubuntu impish.

linux-image-unsigned-5.11.0-16-generic-64k-dbgsym: No summary available for linux-image-unsigned-5.11.0-16-generic-64k-dbgsym in ubuntu impish.

No description available for linux-image-unsigned-5.11.0-16-generic-64k-dbgsym in ubuntu impish.

linux-image-unsigned-5.11.0-16-generic-dbgsym: Linux kernel debug image for version 5.11.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.11.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-5.11.0-16-lowlatency: No summary available for linux-image-unsigned-5.11.0-16-lowlatency in ubuntu impish.

No description available for linux-image-unsigned-5.11.0-16-lowlatency in ubuntu impish.

linux-image-unsigned-5.11.0-16-lowlatency-dbgsym: No summary available for linux-image-unsigned-5.11.0-16-lowlatency-dbgsym in ubuntu impish.

No description available for linux-image-unsigned-5.11.0-16-lowlatency-dbgsym in ubuntu impish.

linux-libc-dev: Linux Kernel Headers for development

 This package provides headers from the Linux kernel. These headers
 are used by the installed headers for GNU glibc and other system
 libraries. They are NOT meant to be used to build third-party modules for
 your kernel. Use linux-headers-* packages for that.

linux-modules-5.11.0-16-generic: Linux kernel extra modules for version 5.11.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-5.11.0-16-generic-64k: Linux kernel extra modules for version 5.11.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic 64K pages processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-64k meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-5.11.0-16-generic-lpae: No summary available for linux-modules-5.11.0-16-generic-lpae in ubuntu impish.

No description available for linux-modules-5.11.0-16-generic-lpae in ubuntu impish.

linux-modules-5.11.0-16-lowlatency: No summary available for linux-modules-5.11.0-16-lowlatency in ubuntu impish.

No description available for linux-modules-5.11.0-16-lowlatency in ubuntu impish.

linux-modules-extra-5.11.0-16-generic: No summary available for linux-modules-extra-5.11.0-16-generic in ubuntu impish.

No description available for linux-modules-extra-5.11.0-16-generic in ubuntu impish.

linux-source-5.11.0: Linux kernel source for version 5.11.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 5.11.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-5.11.0-16: Linux kernel version specific tools for version 5.11.0-16

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.11.0-16 on
 64 bit x86.
 You probably want to install linux-tools-5.11.0-16-<flavour>.

linux-tools-5.11.0-16-generic: No summary available for linux-tools-5.11.0-16-generic in ubuntu impish.

No description available for linux-tools-5.11.0-16-generic in ubuntu impish.

linux-tools-5.11.0-16-generic-64k: No summary available for linux-tools-5.11.0-16-generic-64k in ubuntu impish.

No description available for linux-tools-5.11.0-16-generic-64k in ubuntu impish.

linux-tools-5.11.0-16-generic-lpae: Linux kernel version specific tools for version 5.11.0-16

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.11.0-16 on
 ARM (hard float).

linux-tools-5.11.0-16-lowlatency: No summary available for linux-tools-5.11.0-16-lowlatency in ubuntu impish.

No description available for linux-tools-5.11.0-16-lowlatency in ubuntu impish.

linux-tools-common: Linux kernel version specific tools for version 5.11.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.11.0.

linux-tools-host: Linux kernel VM host tools

 This package provides kernel tools useful for VM hosts.