linux 4.18.0-18.19 source package in Ubuntu

Changelog

linux (4.18.0-18.19) cosmic; urgency=medium

  * linux: 4.18.0-18.19 -proposed tracker (LP: #1822796)

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts
    - [Packaging] resync retpoline extraction

  * 3b080b2564287be91605bfd1d5ee985696e61d3c in ubuntu_btrfs_kernel_fixes
    triggers system hang on i386 (LP: #1812845)
    - btrfs: raid56: properly unmap parity page in finish_parity_scrub()

  * [SRU][B/C/OEM]IOMMU: add kernel dma protection (LP: #1820153)
    - ACPI / property: Allow multiple property compatible _DSD entries
    - PCI / ACPI: Identify untrusted PCI devices
    - iommu/vt-d: Force IOMMU on for platform opt in hint
    - iommu/vt-d: Do not enable ATS for untrusted devices
    - thunderbolt: Export IOMMU based DMA protection support to userspace
    - iommu/vt-d: Disable ATS support on untrusted devices

  * Huawei Hi1822 NIC has poor performance (LP: #1820187)
    - net-next: hinic: fix a problem in free_tx_poll()
    - hinic: remove ndo_poll_controller
    - net-next/hinic: add checksum offload and TSO support
    - hinic: Fix l4_type parameter in hinic_task_set_tunnel_l4
    - net-next/hinic:replace multiply and division operators
    - net-next/hinic:add rx checksum offload for HiNIC
    - net-next/hinic:fix a bug in set mac address
    - net-next/hinic: fix a bug in rx data flow
    - net: hinic: fix null pointer dereference on pointer hwdev
    - hinic: optmize rx refill buffer mechanism
    - net-next/hinic:add shutdown callback
    - net-next/hinic: replace disable_irq_nosync/enable_irq

  * [CONFIG] please enable highdpi font FONT_TER16x32 (LP: #1819881)
    - Fonts: New Terminus large console font
    - [Config]: enable highdpi Terminus 16x32 font support

  * [19.04 FEAT] qeth: Enhanced link speed - kernel part (LP: #1814892)
    - s390/qeth: report 25Gbit link speed

  * Avoid potential memory corruption on HiSilicon SoCs (LP: #1819546)
    - iommu/arm-smmu-v3: Avoid memory corruption from Hisilicon MSI payloads

  * CVE-2017-5715
    - x86/speculation: Apply IBPB more strictly to avoid cross-process data leak
    - x86/speculation: Propagate information about RSB filling mitigation to sysfs
    - x86/speculation: Add RETPOLINE_AMD support to the inline asm CALL_NOSPEC
      variant
    - x86/retpoline: Make CONFIG_RETPOLINE depend on compiler support
    - x86/retpoline: Remove minimal retpoline support
    - x86/speculation: Update the TIF_SSBD comment
    - x86/speculation: Clean up spectre_v2_parse_cmdline()
    - x86/speculation: Remove unnecessary ret variable in cpu_show_common()
    - x86/speculation: Move STIPB/IBPB string conditionals out of
      cpu_show_common()
    - x86/speculation: Disable STIBP when enhanced IBRS is in use
    - x86/speculation: Rename SSBD update functions
    - x86/speculation: Reorganize speculation control MSRs update
    - sched/smt: Make sched_smt_present track topology
    - x86/Kconfig: Select SCHED_SMT if SMP enabled
    - sched/smt: Expose sched_smt_present static key
    - x86/speculation: Rework SMT state change
    - x86/l1tf: Show actual SMT state
    - x86/speculation: Reorder the spec_v2 code
    - x86/speculation: Mark string arrays const correctly
    - x86/speculataion: Mark command line parser data __initdata
    - x86/speculation: Unify conditional spectre v2 print functions
    - x86/speculation: Add command line control for indirect branch speculation
    - x86/speculation: Prepare for per task indirect branch speculation control
    - x86/process: Consolidate and simplify switch_to_xtra() code
    - x86/speculation: Avoid __switch_to_xtra() calls
    - x86/speculation: Prepare for conditional IBPB in switch_mm()
    - ptrace: Remove unused ptrace_may_access_sched() and MODE_IBRS
    - x86/speculation: Split out TIF update
    - x86/speculation: Prevent stale SPEC_CTRL msr content
    - x86/speculation: Prepare arch_smt_update() for PRCTL mode
    - x86/speculation: Add prctl() control for indirect branch speculation
    - x86/speculation: Enable prctl mode for spectre_v2_user
    - x86/speculation: Add seccomp Spectre v2 user space protection mode
    - x86/speculation: Provide IBPB always command line options
    - kvm: svm: Ensure an IBPB on all affected CPUs when freeing a vmcb
    - x86/speculation: Change misspelled STIPB to STIBP
    - x86/speculation: Add support for STIBP always-on preferred mode
    - x86, modpost: Replace last remnants of RETPOLINE with CONFIG_RETPOLINE

  * [Ubuntu] vfio-ap: add subsystem to matrix device to avoid libudev failures
    (LP: #1818854)
    - s390: vfio_ap: link the vfio_ap devices to the vfio_ap bus subsystem

  * Kernel regularly logs: Bluetooth: hci0: last event is not cmd complete
    (0x0f) (LP: #1748565)
    - Bluetooth: Fix unnecessary error message for HCI request completion

  * HiSilicon HNS ethernet broken in 4.15.0-45 (LP: #1818294)
    - net: hns: Fix WARNING when hns modules installed

  * Lenovo ideapad 330-15ICH Wifi rfkill hard blocked (LP: #1811815)
    - platform/x86: ideapad: Add ideapad 330-15ICH to no_hw_rfkill

  * Qualcomm Atheros QCA9377 wireless does not work (LP: #1818204)
    - platform/x86: ideapad-laptop: Add Ideapad 530S-14ARR to no_hw_rfkill list

  * fscache: jobs might hang when fscache disk is full (LP: #1821395)
    - fscache: fix race between enablement and dropping of object

  * hns3: fix oops in hns3_clean_rx_ring() (LP: #1821064)
    - net: hns3: add dma_rmb() for rx description

  * tcm_loop.ko: move from modules-extra into main modules package
    (LP: #1817786)
    - [Packaging] move tcm_loop.lo to main linux-modules package

  * tcmu user space crash results in kernel module hang. (LP: #1819504)
    - scsi: tcmu: delete unused __wait
    - scsi: tcmu: track nl commands
    - scsi: tcmu: simplify nl interface
    - scsi: tcmu: add module wide block/reset_netlink support

  * Intel XL710 - i40e driver does not work with kernel 4.15 (Ubuntu 18.04)
    (LP: #1779756)
    - i40e: prevent overlapping tx_timeout recover

  * some codecs stop working after S3 (LP: #1820930)
    - ALSA: hda - Enforces runtime_resume after S3 and S4 for each codec

  * 4.15 s390x kernel BUG at /build/linux-
    Gycr4Z/linux-4.15.0/drivers/block/virtio_blk.c:565! (LP: #1788432)
    - virtio/s390: avoid race on vcdev->config
    - virtio/s390: fix race in ccw_io_helper()

  * [SRU][B/B-OEM/C/D] Fix AMD IOMMU NULL dereference (LP: #1820990)
    - iommu/amd: Fix NULL dereference bug in match_hid_uid

  * New Intel Wireless-AC 9260 [8086:2526] card not correctly probed in Ubuntu
    system (LP: #1821271)
    - iwlwifi: add new card for 9260 series

  * Add support for MAC address pass through on RTL8153-BD (LP: #1821276)
    - r8152: Add support for MAC address pass through on RTL8153-BD
    - r8152: Fix an error on RTL8153-BD MAC Address Passthrough support

 -- Kleber Sacilotto de Souza <email address hidden>  Tue, 02 Apr 2019 18:06:12 +0200

Upload details

Uploaded by:
Kleber Sacilotto de Souza on 2019-04-02
Uploaded to:
Cosmic
Original maintainer:
Ubuntu Kernel Team
Architectures:
all i386 amd64 armhf arm64 x32 ppc64el s390x
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
linux_4.18.0.orig.tar.gz 149.8 MiB fd5c4f5ab07d6dccf7ef79317e36c2754438fb3d79d750df1d9868bab0de9573
linux_4.18.0-18.19.diff.gz 7.2 MiB 53b8947690429eb4a98b1e65b94627fedbb1f4f283d8f66e0b9dad32798c9b4b
linux_4.18.0-18.19.dsc 7.8 KiB fc709cc5f4346215e7abe1d99a90ac0c240581e978afcac7c386a9ef1aefe94c

View changes file

Binary packages built by this source

block-modules-4.18.0-18-generic-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-4.18.0-18-generic-lpae-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-4.18.0-18-snapdragon-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

crypto-modules-4.18.0-18-generic-di: crypto modules

 This package contains crypto modules.

crypto-modules-4.18.0-18-generic-lpae-di: crypto modules

 This package contains crypto modules.

crypto-modules-4.18.0-18-snapdragon-di: crypto modules

 This package contains crypto modules.

dasd-extra-modules-4.18.0-18-generic-di: DASD storage support -- extras
dasd-modules-4.18.0-18-generic-di: DASD storage support
fat-modules-4.18.0-18-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-4.18.0-18-generic-lpae-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-4.18.0-18-snapdragon-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fb-modules-4.18.0-18-generic-di: Framebuffer modules
firewire-core-modules-4.18.0-18-generic-di: Firewire (IEEE-1394) Support
floppy-modules-4.18.0-18-generic-di: Floppy driver support
fs-core-modules-4.18.0-18-generic-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-4.18.0-18-generic-lpae-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-4.18.0-18-snapdragon-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-secondary-modules-4.18.0-18-generic-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-4.18.0-18-generic-lpae-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-4.18.0-18-snapdragon-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

input-modules-4.18.0-18-generic-di: Support for various input methods
input-modules-4.18.0-18-generic-lpae-di: Support for various input methods
input-modules-4.18.0-18-snapdragon-di: Support for various input methods
ipmi-modules-4.18.0-18-generic-di: ipmi modules
ipmi-modules-4.18.0-18-generic-lpae-di: ipmi modules
ipmi-modules-4.18.0-18-snapdragon-di: ipmi modules
kernel-image-4.18.0-18-generic-di: kernel image and system map
kernel-image-4.18.0-18-generic-lpae-di: kernel image and system map
kernel-image-4.18.0-18-snapdragon-di: kernel image and system map
linux-buildinfo-4.18.0-18-generic: Linux kernel buildinfo for version 4.18.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 4.18.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-4.18.0-18-generic-lpae: Linux kernel buildinfo for version 4.18.0 on ARM (hard float) SMP

 This package contains the Linux kernel buildinfo for version 4.18.0 on
 ARM (hard float) SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-4.18.0-18-lowlatency: Linux kernel buildinfo for version 4.18.0 on 32 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 4.18.0 on
 32 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-buildinfo-4.18.0-18-snapdragon: Linux kernel buildinfo for version 4.18.0 on ARMv8 SMP

 This package contains the Linux kernel buildinfo for version 4.18.0 on
 ARMv8 SMP.
 .
 You likely do not want to install this package.

linux-cloud-tools-4.18.0-18: Linux kernel version specific cloud tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 4.18.0-18 on
 32 bit x86.
 You probably want to install linux-cloud-tools-4.18.0-18-<flavour>.

linux-cloud-tools-4.18.0-18-generic: Linux kernel version specific cloud tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.18.0-18 on
 32 bit x86.

linux-cloud-tools-4.18.0-18-lowlatency: Linux kernel version specific cloud tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.18.0-18 on
 32 bit x86.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 4.18.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version PGKVER.

linux-doc: Linux kernel specific documentation for version 4.18.0

 This package provides the various documents in the 4.18.0 kernel
 Documentation/ subdirectory. These document kernel subsystems, APIs, device
 drivers, and so on. See
 /usr/share/doc/linux-doc/00-INDEX for a list of what is
 contained in each file.

linux-headers-4.18.0-18: Header files related to Linux kernel version 4.18.0

 This package provides kernel header files for version 4.18.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-18/debian.README.gz for details

linux-headers-4.18.0-18-generic: Linux kernel headers for version 4.18.0 on ARMv8 SMP

 This package provides kernel header files for version 4.18.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-18/debian.README.gz for details.

linux-headers-4.18.0-18-generic-lpae: Linux kernel headers for version 4.18.0 on ARM (hard float) SMP

 This package provides kernel header files for version 4.18.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-18/debian.README.gz for details.

linux-headers-4.18.0-18-lowlatency: Linux kernel headers for version 4.18.0 on 32 bit x86 SMP

 This package provides kernel header files for version 4.18.0 on
 32 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-18/debian.README.gz for details.

linux-headers-4.18.0-18-snapdragon: Linux kernel headers for version 4.18.0 on ARMv8 SMP

 This package provides kernel header files for version 4.18.0 on
 ARMv8 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.18.0-18/debian.README.gz for details.

linux-image-4.18.0-18-generic: Signed kernel image generic

 A kernel image for generic. This version of it is signed with
 Canonical's UEFI/Opal signing key.

linux-image-4.18.0-18-generic-dbgsym: Signed kernel image generic

 A link to the debugging symbols for the generic signed kernel.

linux-image-4.18.0-18-generic-lpae: Linux kernel image for version 4.18.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 4.18.0 on
 ARM (hard float) SMP.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.18.0-18-generic-lpae-dbgsym: Linux kernel debug image for version 4.18.0 on ARM (hard float) SMP

 This package provides the kernel debug image for version 4.18.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-4.18.0-18-lowlatency: Signed kernel image lowlatency

 A kernel image for lowlatency. This version of it is signed with
 Canonical's UEFI signing key.

linux-image-4.18.0-18-lowlatency-dbgsym: Signed kernel image lowlatency

 A link to the debugging symbols for the lowlatency signed kernel.

linux-image-4.18.0-18-snapdragon: Linux kernel image for version 4.18.0 on ARMv8 SMP

 This package contains the Linux kernel image for version 4.18.0 on
 ARMv8 SMP.
 .
 Supports Generic Snapdragon processors.
 .
 Geared toward desktop,server and embedded systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-snapdragon meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.18.0-18-snapdragon-dbgsym: Linux kernel debug image for version 4.18.0 on ARMv8 SMP

 This package provides the kernel debug image for version 4.18.0 on
 ARMv8 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-4.18.0-18-generic: Linux kernel image for version 4.18.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 4.18.0 on
 64 bit x86 SMP.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-4.18.0-18-generic-dbgsym: Linux kernel debug image for version 4.18.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 4.18.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-unsigned-4.18.0-18-lowlatency: Linux kernel image for version 4.18.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 4.18.0 on
 64 bit x86 SMP.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-4.18.0-18-lowlatency-dbgsym: Linux kernel debug image for version 4.18.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 4.18.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-libc-dev: Linux Kernel Headers for development

 This package provides headers from the Linux kernel. These headers
 are used by the installed headers for GNU glibc and other system
 libraries. They are NOT meant to be used to build third-party modules for
 your kernel. Use linux-headers-* packages for that.

linux-modules-4.18.0-18-generic: Linux kernel extra modules for version 4.18.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-4.18.0-18-generic-lpae: Linux kernel extra modules for version 4.18.0 on ARM (hard float) SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-4.18.0-18-lowlatency: Linux kernel extra modules for version 4.18.0 on 32 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-4.18.0-18-snapdragon: Linux kernel extra modules for version 4.18.0 on ARMv8 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic Snapdragon processors.
 .
 Geared toward desktop,server and embedded systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-snapdragon meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-modules-extra-4.18.0-18-generic: Linux kernel extra modules for version 4.18.0 on ARMv8 SMP

 This package contains the Linux kernel extra modules for version 4.18.0 on
 ARMv8 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-source-4.18.0: Linux kernel source for version 4.18.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 4.18.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-4.18.0-18: Linux kernel version specific tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-18 on
 ARMv8.
 You probably want to install linux-tools-4.18.0-18-<flavour>.

linux-tools-4.18.0-18-generic: Linux kernel version specific tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-18 on
 ARMv8.

linux-tools-4.18.0-18-generic-lpae: Linux kernel version specific tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-18 on
 ARM (hard float).

linux-tools-4.18.0-18-lowlatency: Linux kernel version specific tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-18 on
 32 bit x86.

linux-tools-4.18.0-18-snapdragon: Linux kernel version specific tools for version 4.18.0-18

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.18.0-18 on
 ARMv8.

linux-tools-common: Linux kernel version specific tools for version 4.18.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version PGKVER.

linux-tools-host: Linux kernel VM host tools

 This package provides kernel tools useful for VM hosts.

linux-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-generic-lpae: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-snapdragon: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

md-modules-4.18.0-18-generic-di: Multi-device support (raid, device-mapper, lvm)
md-modules-4.18.0-18-generic-lpae-di: Multi-device support (raid, device-mapper, lvm)
md-modules-4.18.0-18-snapdragon-di: Multi-device support (raid, device-mapper, lvm)
message-modules-4.18.0-18-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

message-modules-4.18.0-18-snapdragon-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-4.18.0-18-generic-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-4.18.0-18-generic-lpae-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-4.18.0-18-snapdragon-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

multipath-modules-4.18.0-18-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-4.18.0-18-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-4.18.0-18-snapdragon-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-4.18.0-18-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-4.18.0-18-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-4.18.0-18-snapdragon-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-4.18.0-18-generic-di: Network interface support
nic-modules-4.18.0-18-generic-lpae-di: Network interface support
nic-modules-4.18.0-18-snapdragon-di: Network interface support
nic-pcmcia-modules-4.18.0-18-generic-di: PCMCIA network interface support
nic-shared-modules-4.18.0-18-generic-di: nic shared modules

  This package contains modules which support nic modules

nic-shared-modules-4.18.0-18-generic-lpae-di: nic shared modules

  This package contains modules which support nic modules

nic-shared-modules-4.18.0-18-snapdragon-di: nic shared modules

  This package contains modules which support nic modules

nic-usb-modules-4.18.0-18-generic-di: USB network interface support
nic-usb-modules-4.18.0-18-generic-lpae-di: USB network interface support
nic-usb-modules-4.18.0-18-snapdragon-di: USB network interface support
parport-modules-4.18.0-18-generic-di: Parallel port support
parport-modules-4.18.0-18-generic-lpae-di: Parallel port support
parport-modules-4.18.0-18-snapdragon-di: Parallel port support
pata-modules-4.18.0-18-generic-di: PATA support modules
pcmcia-modules-4.18.0-18-generic-di: PCMCIA Modules
pcmcia-storage-modules-4.18.0-18-generic-di: PCMCIA storage support
plip-modules-4.18.0-18-generic-di: PLIP (parallel port) networking support
plip-modules-4.18.0-18-generic-lpae-di: PLIP (parallel port) networking support
plip-modules-4.18.0-18-snapdragon-di: PLIP (parallel port) networking support
ppp-modules-4.18.0-18-generic-di: PPP (serial port) networking support
ppp-modules-4.18.0-18-generic-lpae-di: PPP (serial port) networking support
ppp-modules-4.18.0-18-snapdragon-di: PPP (serial port) networking support
sata-modules-4.18.0-18-generic-di: SATA storage support
sata-modules-4.18.0-18-generic-lpae-di: SATA storage support
sata-modules-4.18.0-18-snapdragon-di: SATA storage support
scsi-modules-4.18.0-18-generic-di: SCSI storage support
scsi-modules-4.18.0-18-generic-lpae-di: SCSI storage support
scsi-modules-4.18.0-18-snapdragon-di: SCSI storage support
serial-modules-4.18.0-18-generic-di: Serial port support
storage-core-modules-4.18.0-18-generic-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-4.18.0-18-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-4.18.0-18-snapdragon-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-4.18.0-18-generic-di: Core USB support
usb-modules-4.18.0-18-generic-lpae-di: Core USB support
usb-modules-4.18.0-18-snapdragon-di: Core USB support
virtio-modules-4.18.0-18-generic-di: VirtIO Modules

 Includes modules for VirtIO (virtual machine, generally kvm guests)

virtio-modules-4.18.0-18-snapdragon-di: VirtIO Modules

 Includes modules for VirtIO (virtual machine, generally kvm guests)

vlan-modules-4.18.0-18-generic-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-4.18.0-18-generic-lpae-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-4.18.0-18-snapdragon-di: vlan modules

 This package contains vlan (8021.Q) modules.