linux 4.10.0-38.42 source package in Ubuntu

Changelog

linux (4.10.0-38.42) zesty; urgency=low

  * linux: 4.10.0-38.42 -proposed tracker (LP: #1722330)

  * Controller lockup detected on ProLiant DL380 Gen9 with P440 Controller
    (LP: #1720359)
    - scsi: hpsa: limit transfer length to 1MB

  * [Dell Docking IE][0bda:8153] Realtek USB Ethernet leads to system hang
    (LP: #1720977)
    - r8152: fix the list rx_done may be used without initialization

  * Touchpad not detected in Lenovo X1 Yoga / Yoga 720-15IKB (LP: #1700657)
    - mfd: intel-lpss: Add missing PCI ID for Intel Sunrise Point LPSS devices

  * Add installer support for Broadcom BCM573xx network drivers. (LP: #1720466)
    - d-i: Add bnxt_en to nic-modules.

  * CVE-2017-1000252
    - KVM: VMX: Do not BUG() on out-of-bounds guest IRQ

  * CVE-2017-10663
    - f2fs: sanity check checkpoint segno and blkoff

  * xfstest sanity checks on seek operations fails (LP: #1696049)
    - xfs: fix off-by-one on max nr_pages in xfs_find_get_desired_pgoff()

  * [P9, Power NV][ WSP][Ubuntu 16.04.03] : perf hw breakpoint command results
    in call traces and system goes for reboot. (LP: #1706033)
    - powerpc/64s: Handle data breakpoints in Radix mode

  * 5U84 - ses driver isn't binding right - cannot blink lights on 1 of the 2
    5u84 (LP: #1693369)
    - scsi: ses: do not add a device to an enclosure if enclosure_add_links()
      fails.

  * Vlun resize request could fail with cxlflash driver (LP: #1713575)
    - scsi: cxlflash: Fix vlun resize failure in the shrink path

  * More migrations with constant load (LP: #1713576)
    - sched/fair: Prefer sibiling only if local group is under-utilized

  * New PMU fixes for marked events. (LP: #1716491)
    - powerpc/perf: POWER9 PMU stops after idle workaround

  * CVE-2017-14340
    - xfs: XFS_IS_REALTIME_INODE() should be false if no rt device present

  * [Zesty][Yakkety] rtl8192e bug fixes (LP: #1698470)
    - staging: rtl8192e: rtl92e_fill_tx_desc fix write to mapped out memory.
    - staging: rtl8192e: fix 2 byte alignment of register BSSIDR.
    - staging: rtl8192e: rtl92e_get_eeprom_size Fix read size of EPROM_CMD.
    - staging: rtl8192e: GetTs Fix invalid TID 7 warning.

  * Stranded with ENODEV after mdadm --readonly (LP: #1706243)
    - md: MD_CLOSING needs to be cleared after called md_set_readonly or
      do_md_stop

  * multipath -ll is not showing the disks which are actually multipath
    (LP: #1718397)
    - fs: aio: fix the increment of aio-nr and counting against aio-max-nr

  * ETPS/2 Elantech Touchpad inconsistently detected (Gigabyte P57W laptop)
    (LP: #1594214)
    - Input: i8042 - add Gigabyte P57 to the keyboard reset table

  * CVE-2017-10911
    - xen-blkback: don't leak stack data via response ring

  * CVE-2017-11176
    - mqueue: fix a use-after-free in sys_mq_notify()

  * implement 'complain mode' in seccomp for developer mode with snaps
    (LP: #1567597)
    - Revert "UBUNTU: SAUCE: seccomp: log actions even when audit is disabled"
    - seccomp: Provide matching filter for introspection
    - seccomp: Sysctl to display available actions
    - seccomp: Operation for checking if an action is available
    - seccomp: Sysctl to configure actions that are allowed to be logged
    - seccomp: Selftest for detection of filter flag support
    - seccomp: Action to log before allowing

  * implement errno action logging in seccomp for strict mode with snaps
    (LP: #1721676)
    - Revert "UBUNTU: SAUCE: seccomp: log actions even when audit is disabled"
    - seccomp: Provide matching filter for introspection
    - seccomp: Sysctl to display available actions
    - seccomp: Operation for checking if an action is available
    - seccomp: Sysctl to configure actions that are allowed to be logged
    - seccomp: Selftest for detection of filter flag support
    - seccomp: Filter flag to log all actions except SECCOMP_RET_ALLOW

  * Backport recent bbr bugfixes to 4.10 kernel (LP: #1708604)
    - tcp_bbr: cut pacing rate only if filled pipe
    - tcp_bbr: introduce bbr_bw_to_pacing_rate() helper
    - tcp_bbr: introduce bbr_init_pacing_rate_from_rtt() helper
    - tcp_bbr: remove sk_pacing_rate=0 transient during init
    - tcp_bbr: init pacing rate on first RTT sample

  * [SRU][Zesty] Fix lscpu segfault on ARM64 with SMBIOS v2.0 (LP: #1716483)
    - arm64: kernel: restrict /dev/mem read() calls to linear region

 -- Kleber Sacilotto de Souza <email address hidden>  Tue, 10 Oct 2017 13:49:34 +0200

Upload details

Uploaded by:
Kleber Sacilotto de Souza on 2017-10-10
Uploaded to:
Zesty
Original maintainer:
Ubuntu Kernel Team
Architectures:
all i386 amd64 armhf arm64 x32 ppc64el s390x
Section:
devel
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
linux_4.10.0.orig.tar.gz 137.2 MiB 1221bcded9062e5740e7cd1b047479494312b13a2a3ba8a48c820d12276c417d
linux_4.10.0-38.42.diff.gz 7.3 MiB 25a9b35ef49093c7eacb9f4b81f04b20773e49a9644a06f2118e542fbc8ed1fb
linux_4.10.0-38.42.dsc 5.6 KiB 6252fa2191088e12bfa0952a51fed2303ed3d41d93350f42c26887f908e35ed4

View changes file

Binary packages built by this source

block-modules-4.10.0-38-generic-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

block-modules-4.10.0-38-generic-lpae-di: Block storage devices

 This package contains the block storage devices, including DAC960 and
 paraide.

crypto-modules-4.10.0-38-generic-di: crypto modules

 This package contains crypto modules.

crypto-modules-4.10.0-38-generic-lpae-di: crypto modules

 This package contains crypto modules.

dasd-extra-modules-4.10.0-38-generic-di: DASD storage support -- extras
dasd-modules-4.10.0-38-generic-di: DASD storage support
fat-modules-4.10.0-38-generic-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fat-modules-4.10.0-38-generic-lpae-di: FAT filesystem support

 This includes Windows FAT and VFAT support.

fb-modules-4.10.0-38-generic-di: Framebuffer modules
firewire-core-modules-4.10.0-38-generic-di: Firewire (IEEE-1394) Support
floppy-modules-4.10.0-38-generic-di: Floppy driver support
fs-core-modules-4.10.0-38-generic-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-core-modules-4.10.0-38-generic-lpae-di: Base filesystem modules

 This includes jfs, reiserfs and xfs.

fs-secondary-modules-4.10.0-38-generic-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

fs-secondary-modules-4.10.0-38-generic-lpae-di: Extra filesystem modules

 This includes support for Windows NTFS and MacOS HFS/HFSPlus

input-modules-4.10.0-38-generic-di: Support for various input methods
input-modules-4.10.0-38-generic-lpae-di: Support for various input methods
ipmi-modules-4.10.0-38-generic-di: ipmi modules
ipmi-modules-4.10.0-38-generic-lpae-di: ipmi modules
irda-modules-4.10.0-38-generic-di: Support for Infrared protocols
irda-modules-4.10.0-38-generic-lpae-di: Support for Infrared protocols
kernel-image-4.10.0-38-generic-di: kernel image and system map
kernel-image-4.10.0-38-generic-lpae-di: kernel image and system map
linux-cloud-tools-4.10.0-38: Linux kernel version specific cloud tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 4.10.0-38 on
 64 bit x86.
 You probably want to install linux-cloud-tools-4.10.0-38-<flavour>.

linux-cloud-tools-4.10.0-38-dbgsym: debug symbols for package linux-cloud-tools-4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud tools for version 4.10.0-38 on
 64 bit x86.
 You probably want to install linux-cloud-tools-4.10.0-38-<flavour>.

linux-cloud-tools-4.10.0-38-generic: Linux kernel version specific cloud tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.10.0-38 on
 64 bit x86.

linux-cloud-tools-4.10.0-38-lowlatency: Linux kernel version specific cloud tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools for cloud for version 4.10.0-38 on
 64 bit x86.

linux-cloud-tools-common: Linux kernel version specific cloud tools for version 4.10.0

 This package provides the architecture independent parts for kernel
 version locked tools for cloud tools for version PGKVER.

linux-doc: Linux kernel specific documentation for version 4.10.0

 This package provides the various documents in the 4.10.0 kernel
 Documentation/ subdirectory. These document kernel subsystems, APIs, device
 drivers, and so on. See
 /usr/share/doc/linux-doc/00-INDEX for a list of what is
 contained in each file.

linux-headers-4.10.0-38: Header files related to Linux kernel version 4.10.0

 This package provides kernel header files for version 4.10.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.10.0-38/debian.README.gz for details

linux-headers-4.10.0-38-generic: Linux kernel headers for version 4.10.0 on ARM (hard float) SMP

 This package provides kernel header files for version 4.10.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.10.0-38/debian.README.gz for details.

linux-headers-4.10.0-38-generic-lpae: Linux kernel headers for version 4.10.0 on ARM (hard float) SMP

 This package provides kernel header files for version 4.10.0 on
 ARM (hard float) SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.10.0-38/debian.README.gz for details.

linux-headers-4.10.0-38-lowlatency: Linux kernel headers for version 4.10.0 on 64 bit x86 SMP

 This package provides kernel header files for version 4.10.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.10.0-38/debian.README.gz for details.

linux-image-4.10.0-38-generic: Linux kernel image for version 4.10.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 4.10.0 on
 ARM (hard float) SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.10.0-38-generic-dbgsym: Linux kernel debug image for version 4.10.0 on ARM (hard float) SMP

 This package provides a kernel debug image for version 4.10.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-4.10.0-38-generic-lpae: Linux kernel image for version 4.10.0 on ARM (hard float) SMP

 This package contains the Linux kernel image for version 4.10.0 on
 ARM (hard float) SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic LPAE processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic-lpae meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.10.0-38-generic-lpae-dbgsym: Linux kernel debug image for version 4.10.0 on ARM (hard float) SMP

 This package provides a kernel debug image for version 4.10.0 on
 ARM (hard float) SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-4.10.0-38-lowlatency: Linux kernel image for version 4.10.0 on 64 bit x86 SMP

 This package contains the Linux kernel image for version 4.10.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Lowlatency processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-lowlatency meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-4.10.0-38-lowlatency-dbgsym: Linux kernel debug image for version 4.10.0 on 64 bit x86 SMP

 This package provides a kernel debug image for version 4.10.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-image-extra-4.10.0-38-generic: Linux kernel extra modules for version 4.10.0 on 64 bit x86 SMP

 This package contains the Linux kernel extra modules for version 4.10.0 on
 64 bit x86 SMP.
 .
 Also includes the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Generic processors.
 .
 Geared toward desktop and server systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-generic meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-libc-dev: Linux Kernel Headers for development

 This package provides headers from the Linux kernel. These headers
 are used by the installed headers for GNU glibc and other system
 libraries. They are NOT meant to be used to build third-party modules for
 your kernel. Use linux-headers-* packages for that.

linux-source-4.10.0: Linux kernel source for version 4.10.0 with Ubuntu patches

 This package provides the source code for the Linux kernel version
 4.10.0.
 .
 This package is mainly meant for other packages to use, in order to build
 custom flavours.
 .
 If you wish to use this package to create a custom Linux kernel, then it
 is suggested that you investigate the package kernel-package, which has
 been designed to ease the task of creating kernel image packages.
 .
 If you are simply trying to build third-party modules for your kernel,
 you do not want this package. Install the appropriate linux-headers
 package instead.

linux-tools-4.10.0-38: Linux kernel version specific tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.10.0-38 on
 ARM (hard float).
 You probably want to install linux-tools-4.10.0-38-<flavour>.

linux-tools-4.10.0-38-dbgsym: debug symbols for package linux-tools-4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.10.0-38 on
 ARM (hard float).
 You probably want to install linux-tools-4.10.0-38-<flavour>.

linux-tools-4.10.0-38-generic: Linux kernel version specific tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.10.0-38 on
 ARM (hard float).

linux-tools-4.10.0-38-generic-lpae: Linux kernel version specific tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.10.0-38 on
 ARM (hard float).

linux-tools-4.10.0-38-lowlatency: Linux kernel version specific tools for version 4.10.0-38

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.10.0-38 on
 64 bit x86.

linux-tools-common: Linux kernel version specific tools for version 4.10.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version PGKVER.

linux-udebs-generic: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

linux-udebs-generic-lpae: Metapackage depending on kernel udebs

 This package depends on the all udebs that the kernel build generated,
 for easier version and migration tracking.

md-modules-4.10.0-38-generic-di: Multi-device support (raid, device-mapper, lvm)
md-modules-4.10.0-38-generic-lpae-di: Multi-device support (raid, device-mapper, lvm)
message-modules-4.10.0-38-generic-di: Fusion and i2o storage modules

 This package containes the fusion and i2o storage modules.

mouse-modules-4.10.0-38-generic-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

mouse-modules-4.10.0-38-generic-lpae-di: Mouse support

 This package contains mouse drivers for the Linux kernel.

multipath-modules-4.10.0-38-generic-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

multipath-modules-4.10.0-38-generic-lpae-di: DM-Multipath support

  This package contains modules for device-mapper multipath support.

nfs-modules-4.10.0-38-generic-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nfs-modules-4.10.0-38-generic-lpae-di: NFS filesystem drivers

 Includes the NFS client driver, and supporting modules.

nic-modules-4.10.0-38-generic-di: Network interface support
nic-modules-4.10.0-38-generic-lpae-di: Network interface support
nic-pcmcia-modules-4.10.0-38-generic-di: PCMCIA network interface support
nic-shared-modules-4.10.0-38-generic-di: nic shared modules

  This package contains modules which support nic modules

nic-shared-modules-4.10.0-38-generic-lpae-di: nic shared modules

  This package contains modules which support nic modules

nic-usb-modules-4.10.0-38-generic-di: USB network interface support
nic-usb-modules-4.10.0-38-generic-lpae-di: USB network interface support
parport-modules-4.10.0-38-generic-di: Parallel port support
parport-modules-4.10.0-38-generic-lpae-di: Parallel port support
pata-modules-4.10.0-38-generic-di: PATA support modules
pcmcia-modules-4.10.0-38-generic-di: PCMCIA Modules
pcmcia-storage-modules-4.10.0-38-generic-di: PCMCIA storage support
plip-modules-4.10.0-38-generic-di: PLIP (parallel port) networking support
plip-modules-4.10.0-38-generic-lpae-di: PLIP (parallel port) networking support
ppp-modules-4.10.0-38-generic-di: PPP (serial port) networking support
ppp-modules-4.10.0-38-generic-lpae-di: PPP (serial port) networking support
sata-modules-4.10.0-38-generic-di: SATA storage support
sata-modules-4.10.0-38-generic-lpae-di: SATA storage support
scsi-modules-4.10.0-38-generic-di: SCSI storage support
scsi-modules-4.10.0-38-generic-lpae-di: SCSI storage support
serial-modules-4.10.0-38-generic-di: Serial port support
storage-core-modules-4.10.0-38-generic-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

storage-core-modules-4.10.0-38-generic-lpae-di: Core storage support

 Includes core SCSI, LibATA, USB-Storage. Also includes related block
 devices for CD, Disk and Tape medium (and IDE Floppy).

usb-modules-4.10.0-38-generic-di: Core USB support
usb-modules-4.10.0-38-generic-lpae-di: Core USB support
virtio-modules-4.10.0-38-generic-di: VirtIO Modules

 Includes modules for VirtIO (virtual machine, generally kvm guests)

vlan-modules-4.10.0-38-generic-di: vlan modules

 This package contains vlan (8021.Q) modules.

vlan-modules-4.10.0-38-generic-lpae-di: vlan modules

 This package contains vlan (8021.Q) modules.