Ubuntu

Wrong driver for GigE Net Cards RTL8111/8168B

Reported by Rodrigue V. on 2012-05-11
124
This bug affects 25 people
Affects Status Importance Assigned to Milestone
HWE Next
High
AceLan Kao
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
AceLan Kao
Precise
Medium
Unassigned
Quantal
Medium
Unassigned
r8169 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Symptoms : Wireless connection ultra slow, but working

r8169 module was loaded in modprobe, but r8168 was needed for better performances.

lspci lines:
01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 (rev 34)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

OS: ubuntu 12.04 64bit (new install)
Hardware: samsung series 5 NP530U3B-A02FR

see also :

http://askubuntu.com/questions/96343/internet-unusably-slow-with-realtek-semiconductor-co-ltd-rtl8111-8168b-card
http://amk1.wordpress.com/2009/06/09/realtek-8168-module-issue/

Driver I used to get it work : LINUX driver for kernel 2.6.x and 2.4.x (Support x86 and x64)
 8.029.00 2012/3/29 @ http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: norbert 1816 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf0700000 irq 48'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,144dc0c7,00100202 HDA:80862805,80860101,00100000'
   Controls : 25
   Simple ctrls : 12
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=870a0871-aafe-49c4-9ea8-d05af6aec76c
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 530U3BI/530U4BI/530U4BH
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=cea150a2-afd6-4955-859e-e5ed68cccea1 ro quiet splash pcie_aspm=force vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
Tags: precise staging precise staging
Uname: Linux 3.2.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 01/18/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 04XK
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 530U3BI/530U4BI/530U4BH
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr04XK:bd01/18/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn530U3BI/530U4BI/530U4BH:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn530U3BI/530U4BI/530U4BH:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 530U3BI/530U4BI/530U4BH
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/998200/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
tags: added: kernel-wifi precise
tags: added: kernel-wifi-needsdriver
removed: wifi
Changed in linux (Ubuntu):
status: New → Confirmed

idem as #839393 which is not solved in Ubuntu 12.04
I have tried the R8168 driver but still a lot of disconnections with en0 interface (once per minute)
It is ok with my ISP but failed with the enterprise network

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc7-precise/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: needs-upstream-testing

tested linux mainstream kernel v3.4rc6 (rc7 amd64 image was not found) :

linux-headers-3.4.0-030400rc6_3.4.0-030400rc6.201205061835_all.deb
linux-headers-3.4.0-030400rc6-generic_3.4.0-030400rc6.201205061835_amd64.deb
linux-image-3.4.0-030400rc6-generic_3.4.0-030400rc6.201205061835_amd64.deb

from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc6-precise/

results :

- touchpad not working
- wronk wifi driver loaded (r8169) with poor bandwidth (same problem described at start of this bug)
- 1 minute after unity session loaded : wifi disconnect with no reconnection possible (i’ve not digging though)

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
avejidah (avejidah) wrote :

Coming over from bug 839393.

If I apt-get install linux-backports-modules-net-`uname -r` this problem goes away. I have to do this every time the kernel is upgraded, though. If I boot in to Window$, then boot into Ubuntu 12.04, my connection constantly drops until I either:

1) Install the backports package above.
2) Power off the computer, and unplug it.

I hear this is something with WOL, which I use. Note that I only have this problem after booting into Window$. I can boot up to Ubuntu for 3 months, and everything is fine. One time in Window$ without the backports installed, and bam, my internet drops every 30 seconds.

Tim Cuthbertson (ratcheer) wrote :

@avejidah, I installed the backports-network package on Oneiric, rebooted, and could no longer connect at all. I uninstalled it and now I can connect, again, but I am still having the extreme slowdowns. I am glad I also have wireless.

Also, I have powered down and disconnected the PC from AC power, but in my case, that did not help, either. Maybe our problems are different. My ethernet connection stays up, but it varies from full speed to extremely slow (800 bps or worse) every few seconds, then back to full speed, etc.

Joseph Salisbury (jsalisbury) wrote :

@doddo

Can you run the following, so we can gather additional details about your hardware:

apport-collect 998200

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

apport information

tags: added: apport-collected staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

oups, maybe I’ve stop apport too soon (it seemed blocked…)

tell me if it miss something you need.

regards.

Joseph Salisbury (jsalisbury) wrote :

 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 06)
 Subsystem: Samsung Electronics Co Ltd Device [144d:c0c7]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 44
 Region 0: I/O ports at 2000 [size=256]
 Region 2: Memory at f0404000 (64-bit, prefetchable) [size=4K]
 Region 4: Memory at f0400000 (64-bit, prefetchable) [size=16K]
 Capabilities: <access denied>
 Kernel driver in use: r8168
 Kernel modules: r8168, r8169

Joseph Salisbury (jsalisbury) wrote :

I see that the r8168 driver is not in the upstream kernel. We generally ask bug reporters to first request that the driver be added to the upstream kernel. This can be done by mailing the Linux Kernel Mailing List or opening a bug at bugzilla.kernel.org.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in linux:
status: In Progress → Incomplete
tags: added: blocks-hwcert-enablement
Vittorio G (VittGam) (vittgam) wrote :

The RTL8111/8168B are Gigabit Ethernet PCI-E network cards, not wifi cards.

summary: - wrong driver for wifi RTL8111/8168B
+ Wrong driver for GigE Net Cards RTL8111/8168B

AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: vkulikov 1662 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2b00000 irq 52'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,102804c6,00100100'
   Controls : 20
   Simple ctrls : 12
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Dell Inc. Dell System Vostro 3750
NonfreeKernelModules: wl
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=343a0e2f-0969-4b8f-a321-038606dc5bbb ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
Tags: precise staging precise staging
Uname: Linux 3.2.0-24-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-04-27 (45 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare sudo
dmi.bios.date: 02/22/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0VP036
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd02/22/2012:svnDellInc.:pnDellSystemVostro3750:pvr:rvnDellInc.:rn0VP036:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Dell System Vostro 3750
dmi.sys.vendor: Dell Inc.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Vitaliy Kulikov (slonua) wrote :

have found r8168 for quantal (http://packages.ubuntu.com/quantal/r8168-dkms)
any ideas for precise ?

Vitaliy Kulikov (slonua) wrote :

btw: just downloaded and installed amd64 published version for quantal (https://launchpad.net/ubuntu/quantal/+package/r8168-dkms). seems it's working ;)

Bruno Medeiros (brunojcm) wrote :

I installed the debian version, it's working well:
http://packages.debian.org/sid/r8168-dkms

Tim Edwards (tkedwards) wrote :

I was having problems with the ethernet cable not being detected ('Cable Unplugged' in NetworkManager even when the cable was plugged in) when using the r8169 module. After installing the r8168-dkms Debian package (comment #57) the problem is gone.

David Zweig (david-zweig) wrote :

Please Help!

I have downloaded the correct driver to fix this bug, but the installer won't let me install it.

The "install" button is greyed out, with the note: "You likely do not want to install this package directly. Instead, install the unix-backports-modules-net-generic-pae metapackage, which will ensure that upgrades work correctly, and that supporting packages are also installed. Dependency is not satisfiable: linux-image-3.2.0-generic-pae."

This is a catch-22 situation! My wired internet doesn't work for Ubuntu so of course I cannot go to the internet for my download.

The correct file on sitting on my Ubuntu desktop (which I brought over from my USB drive), but installation is blocked: linux-backports-modules-net-3.2.0-29-generic (3.2.0-29.14) [security] Linux ethernet modules for version 3.2.0 on x86/x86_64.

(I assume the pae version is not for a 64 bit Ubuntu installation of the operating system, so is it correct that I should not use the pae version?)

Dylan Borg (borgdylan) wrote :

in quantal internet under r8169 driver gets really slow and is only fixed with one or two router reboots. The problem repeats and persists.

Hadlock (chad-hedstrom) wrote :

This bug has been active for five years!!! Why is it listed as Triaged still? Broken in 12.04.1 LTS

Changed in hwe-next:
assignee: nobody → AceLan Kao (acelankao)
importance: Undecided → High
status: New → In Progress
Gabriel Mazetto (brodock) wrote :

The problem persists on Ubuntu 12.10

Changed in linux (Ubuntu):
assignee: nobody → AceLan Kao (acelankao)
Daniel Aleksandersen (aeyoun) wrote :

The problem did not affect me in 12.10, but it appeared when I updated to 13.04 nightlies.

AceLan Kao (acelankao) on 2013-04-01
Changed in hwe-next:
status: In Progress → Triaged
Changed in linux:
status: Incomplete → Fix Released
Anthony Wong (anthonywong) wrote :

Hi Rodrigue, from the information that upstream provided in kernel bugzilla, the codes that needed to fix this bug are already in the 3.8 kernel in Ubuntu 13.04. Would you be able to try Ubuntu 13.04 and see if it can fix your problem?

Changed in linux (Ubuntu):
status: Triaged → Incomplete
AceLan Kao (acelankao) wrote :

verified on kernel 3.8.0-27 #40, it works well.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in hwe-next:
status: Triaged → Fix Released
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
vsespb (vsespb) wrote :

I have RTL8111/8168/8411 which loads r8169 too (in Ubuntu 12.04). Raised separated ticket just in case https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1266725 pls merge if it's duplicate or pls fix driver for my card too if it's separate but similar issues.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Changed in linux (Ubuntu Quantal):
status: New → Confirmed
Changed in r8169 (Ubuntu Precise):
status: New → Confirmed
Changed in r8169 (Ubuntu Quantal):
status: New → Confirmed
Changed in r8169 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.