Ubuntu

zcache should be built-in instead of kernel module

Reported by Marc Dietrich on 2012-05-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Medium
Unassigned

Bug Description

zcache cannot work if it is compiled as a kernel module. See upstream commit bec25dfd (staging: zcache: make zcache builtin only). Please change the kernel config to CONFIG_ZCACHE=y
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marc 2103 F.... pulseaudio
CRDA:
 country DE:
  (2400 - 2483 @ 40), (N/A, 20)
  (5150 - 5250 @ 40), (N/A, 20), NO-OUTDOOR
  (5250 - 5350 @ 40), (N/A, 20), NO-OUTDOOR, DFS
  (5470 - 5725 @ 40), (N/A, 26), DFS
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfbbf4000 irq 16'
   Mixer name : 'Realtek ALC883'
   Components : 'HDA:10ec0883,1043829f,00100002'
   Controls : 46
   Simple ctrls : 22
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=a97e3b05-28cd-4379-98f1-381c5de2238d
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: System manufacturer System Product Name
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=e480ad62-7a78-4f29-a24d-b096ae0ebf75 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.80
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: zcache zram
Tags: precise staging precise staging
Uname: Linux 3.2.0-24-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-04-29 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 10/26/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1201
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M3A78-EMH HDMI
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1201:bd10/26/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3A78-EMHHDMI:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 995163

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected precise staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Marc Dietrich (marvin24) wrote :

yeah, I like talking to bots!

apport-collect reports ...

marc@ax5200p:~$ apport-collect 995163
Kein Paket gefunden, das auf linux passt.
ERROR: hook /usr/share/apport/general-hooks/ubuntu.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 718, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 45, in add_info
    match_error_messages(report)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 129, in match_error_messages
    if report['ProblemType'] == 'Package':
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'

... and results in a nice endless loop of unsuccessful bug reporting :-)

The kernel is linux-image-3.2.0-24-generic running on a precise x86_64 system.

Setting to 'Confirmed' and waiting for a humanoid response.

BugLink: http://bugs.launchpad.net/bugs/995163

Since an extra kernel boot parameter must be provided
to enable zcache functionality, making it builtin would
not harm users who do not use it.

Jesse Sung (1):
  Set CONFIG_ZCACHE to y

Seth Jennings (1):
  staging: zcache: make zcache builtin only

 debian.master/config/config.common.ubuntu | 2 +-
 drivers/staging/zcache/Kconfig | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

--
1.7.10

BugLink: http://bugs.launchpad.net/bugs/995163

Since an extra kernel boot parameter must be provided
to enable zcache functionality, making it builtin would
not harm users who do not use it.

Signed-off-by: Jesse Sung <email address hidden>
---
 debian.master/config/config.common.ubuntu | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

BugLink: http://bugs.launchpad.net/bugs/995163

zcache cannot currently be loaded as a module. However
the Kconfig allows it to be built as a module; something that
the user probably does not intend since the module is not
loadable.

This patch switches zcache from a tristate to a bool in the Kconfig

Signed-off-by: Seth Jennings <email address hidden>
Acked-by: Dan Magenheimer <email address hidden>
Signed-off-by: Greg Kroah-Hartman <email address hidden>
(backported from commit bec25dfd850cf92cba894c94d6660fc18d3a7447 upstream)
Signed-off-by: Jesse Sung <email address hidden>
---
 drivers/staging/zcache/Kconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

tags: added: patch
Jesse Sung (wenchien) wrote :

Hi,

I think it's reasonable to ask for a strong reason to make a staging driver built-in. If anyone really needs this, please reply
https://lists.ubuntu.com/archives/kernel-team/2012-May/020222.html

Thanks,
Jesse

Marc Dietrich (marvin24) wrote :

Sorry, I'm not subscribed to this mailing list so it's hard to reply...

I use ZCACHE as a backend for cleancache on a low mem (512 MB) ARM machine (Tegra2/AC100) and I found it very useful (note: this machine not officially supported by Canonical, I just mentioned it as a usecase). Similar for ZRAM (also in staging and included in the Ubuntu kernel). On the other hand, I guess on x86 class machines it doesn't make much sense yet (except for visualization environments). But I still like it on my 2GB desktop because I often run huge compile jobs which benefit from more buffer cache.

Also as pointed out by already, it is disabled by default and the remaining code seems to be safe to be included. So if you really feel uncomfortable with building it in, it may be disabled for x86 and enabled for ARMs.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

@Jesse

Do you happen to know if this change will be submitted to the linux-stable tree?

tags: added: kernel-da-key
Jesse Sung (wenchien) wrote :

@jsalisbury

It's not in 3.2.18 and 3.3.6, and due to zcache is in staging currently, guess that it's not going to be included in linux-stable.

Marc Dietrich (marvin24) wrote :

"stable" also includes fixes to "staging" drivers. I think there are two reasons why it is not included (yet):
  - no one submitted it to <email address hidden> yet
  - because it doesn't fix a bug (which is stable requirement)
It is up to the distros to fix their kernel configs (which are not part of the upstream kernel).

So I propose to either disable it (if risk is to high) or make it builtin.

Jesse Sung (wenchien) wrote :

Forgot to CC launchpad in the reply to kernel-team list...
https://lists.ubuntu.com/archives/kernel-team/2012-May/020239.html

Tim Gardner (timg-tpi) wrote :

We're not going to fix this for Precise. Its a built-in staging driver with some serious issues. Quantal is in much better shape with respect to zcache.

Changed in linux (Ubuntu Precise):
status: New → Won't Fix
Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.