Ubuntu

[Dell XT3] Firewire does not work

Reported by Jeff Lane on 2012-05-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Chen
Precise
Medium
Unassigned

Bug Description

12.04 LTS on the Dell XT3. During certification testing, it was observed that the firewire port does not seem to be functioning properly. No messages are generated on insert or remove events with a known working firewire drive.

What more can I say? Firewire, which has worked on other systems with 12.04, is not working on the XT3.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1545 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x7ec60000 irq 45'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:111d76e7,102804b4,00100102 HDA:80862805,80860101,00100000'
   Controls : 37
   Simple ctrls : 13
Date: Fri May 4 15:30:44 2012
HibernationDevice: RESUME=UUID=b9fd2e94-b33a-4efa-8bbe-fcb012c89461
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Latitude XT3
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=8c709e0e-33a3-4b2c-8e13-09af0ac2afda ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/20/2011
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X23
dmi.board.name: 0462TK
dmi.board.vendor: Dell Inc.
dmi.board.version: X00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX23:bd04/20/2011:svnDellInc.:pnLatitudeXT3:pvr01:rvnDellInc.:rn0462TK:rvrX00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude XT3
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Jeff Lane (bladernr) wrote :
Brad Figg (brad-figg) on 2012-05-04
Changed in linux (Ubuntu):
status: New → Confirmed
Jeff Lane (bladernr) on 2012-05-04
tags: added: blocks-hwcert
Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernels, as well as the latest Quantal kernel?

The latest upstream kernel can be downloaded from:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/

The latest Quantal kernel can be downloaded from(Arch specific links are under "Builds"):
https://launchpad.net/ubuntu/+source/linux/3.4.0-3.8

tags: added: kernel-da-key
Jeff Lane (bladernr) wrote :

Greg, can you or Jeff take a look at this?

Changed in linux (Ubuntu):
assignee: nobody → Greg Vallande (gvallande)
Ara Pulido (apulido) on 2012-06-13
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ara Pulido (apulido) on 2012-06-26
Changed in linux (Ubuntu):
assignee: Greg Vallande (gvallande) → Tim Chen (ctf)
Tim Chen (ctf) wrote :

I'm waiting for the 1394-B cable to do the test.

Tim Chen (ctf) wrote :

confirmed, firewire doesn't work in precise with kernel 3.2.0-27.43

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Tim Chen (ctf) wrote :

Tried both kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-quantal/ , https://launchpad.net/ubuntu/+source/linux/3.4.0-3.8

Both can't boot into ubuntu desktop, the screen stays at the ubuntu splash screen.

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

The v3.6-rc1[0] kernel is now out. Can you test this kernel and report back if it has the bug or not?

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc1-quantal/

Changed in linux (Ubuntu Precise):
status: New → Incomplete
Ara Pulido (apulido) on 2012-08-22
tags: added: quantal
Tim Chen (ctf) wrote :

bug is fixed with kernel 3.2.0-30.48 in Precise, 3.6.0-030600rc1 also works.

Thanks Tim! Since bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/994809 remains, we can't certify the system just yet, but at least we know another issue is out of the way!

I'm guessing this might be fixed in Quantal too. Can you confirm it?

Changed in linux (Ubuntu Precise):
status: Incomplete → Fix Released
Tim Chen (ctf) wrote :

Tested under Quantal Beta1, firewire works.

Ara Pulido (apulido) on 2012-09-19
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Po-Hsu Lin (cypressyew) on 2013-05-29
tags: added: 201104-7598 taipei-lab
Filofel (filofel) wrote :

I see a similar problem with 12.04 on an HP EliteBook 8530w:
Kernel Linux 3.5.0-45-generic
Release 12.04 (precise) 32-bit

On Firewire insertion, nothing happens and the disk does not start.

If I then plug the disk using USB 2, the disk starts and works.
If I then unplug the USB cable, then plug the Firewire cable again, this time, the disk starts, gets properly automounted, and works perfectly until shutdown.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers