No sound from Front Panel Headphone jack (ALC892 HD Audio)

Bug #993162 reported by Chirag Chhatriwala on 2012-05-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
David Henningsson
Precise
Undecided
Unassigned

Bug Description

I use the following:
Motherboard: Zotac Z68ITX-A-E (http://www.zotacusa.com/zotac-z68-itx-wifi-z68itx-a-e.html)
Case: Lian Li PCQ08B (http://www.lian-li.com/v2/tw/product/upload/manual/PC-Q8.rar)

I have had issues getting the front panel headphone jack to successfully work. The connection works just fine in Windows 7 Ultimate. In Windows 7, the installed Realtek ALC892 Codec drivers are able to sense when a device gets plugged into the front panel jacks. I have verified through the manuals that the Motherboard Front Panel Audio is spcifially HD Audio and the Case Front Panel Audio Plug is HD Audio plug.

I have tried the latest linux drivers from Realtek (5.17rc1) from the realtek website to no avail.

If there is anything more that I can provide please let me know.

PS. Additionally I am providing the Windows 7 Ultimate screenshots for the actions "plugged in" and "removed" along with the Driver information.

I've performed a sound-tone test where I've answered that the sounds works because my rear-panel sound output works splendidly (front/center+sub/rear, no problem).
Front Panel HeadPhone jack however doesn't do anything at all.

Here are the required info:

chirag@zoidberg:~$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: alsa-base 1.0.25+dfsg-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: chirag 1593 F.... pulseaudio
 /dev/snd/controlC0: chirag 1593 F.... pulseaudio
 /dev/snd/controlC1: chirag 1593 F.... pulseaudio
 /dev/snd/pcmC1D0c: chirag 1593 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe700000 irq 50'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0892,19daa198,00100302 HDA:80862805,80862805,00100000'
   Controls : 54
   Simple ctrls : 20
Card1.Amixer.info:
 Card hw:1 'U0x46d0x821'/'USB Device 0x46d:0x821 at usb-0000:00:1d.0-1.6, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0821'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 52
   Mono: Capture 40 [77%] [-31.00dB] [on]
Card2.Amixer.info:
 Card hw:2 'Generic'/'HD-Audio Generic at 0xfe640000 irq 51'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed May 2 05:42:10 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_AlsaPlaybackTest: ALSA playback test through plughw:PCH successful
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_DevicesInUse:
 1593 1593 1593 1593 chirag F.... pulseaudio
 /dev/snd/controlC0: chirag F.... pulseaudio
 /dev/snd/controlC1: chirag F.... pulseaudio
 /dev/snd/pcmC1D0c: chirag F...m pulseaudio
Symptom_Jack: Green Line Out, Front
Symptom_PulsePlaybackTest: PulseAudio playback test successful
Symptom_Type: No sound at all
Title: [Unknown, Realtek ALC892, Green Line Out, Front] No sound at all
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/11/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Z68ITX-A-E
dmi.board.vendor: ZOTAC
dmi.chassis.type: 3
dmi.chassis.vendor: Unknown
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.4:bd10/11/2011:svnUnknown:pnUnknown:pvr:rvnZOTAC:rnZ68ITX-A-E:rvr:cvnUnknown:ct3:cvr:
dmi.product.name: Unknown
dmi.sys.vendor: Unknown

Chirag Chhatriwala (cchhat01-f) wrote :
description: updated
Chirag Chhatriwala (cchhat01-f) wrote :

Can anyone help?

Chirag Chhatriwala (cchhat01-f) wrote :

I have realized that there is certain problem with the front panel headphone jack... hence it is completely unrecognized and there is no setting to enable Headphone. So it seems that somewhere along the lines while determining what functionality needs to be enabled, alsa decided that there is no Front Panel Headphone Jack available ? How do i fix this?

Thanks.
Please help.

Chirag Chhatriwala (cchhat01-f) wrote :

i have tested that the ASRock H67M-ITX/HT which uses the same chipset (ALC892) and HD Audio, on the same Case (LianLi PCQ08B), the front panel Headphones works perfectly. However, no Front Panel Headphone setting in "Sound Settings" in my Zotac Z68ITX-A-E motherboard...
In both motherboard setups, Windows 7 has no problems with the Headphone jack on the front panel.

Thanks,
C

David Henningsson (diwic) wrote :

Hello Chirag,

According to your BIOS, you don't have a headphone jack, but a front line-out jack. You can try correcting this using the hda-jack-retask program: see http://voices.canonical.com/david.henningsson/2011/11/29/turn-your-mic-jack-into-a-headphone-jack/ for an introduction to this software.

It's likely node 0x1b that's the front headphone jack, try overriding it from "Line-Out" to "Headphone" in hda-jack-retask and let us know if this resolved your problem. Thanks!

Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Chirag Chhatriwala (cchhat01-f) wrote :

David,

Thanks for the recommendation. Currently, I'm using another motherboard. I'm waiting for a part (heatsink) to arrive tomorrow, at which point I will re-install the problematic board and give feedback on your suggestion.
You'll be hearing from me soon enough.

Chirag

Chirag Chhatriwala (cchhat01-f) wrote :

Hi David,

UPDATE:
I now have working sound after retasking the Green, Ext Front (Line out) as a Headphone.
I've applied "apply boot override" so that this change sticks after reboot.

I have one problem now. As soon as I unplug the headphones from the jack, the Sound Settings don't show a "Headphone (built in audio)" setting under the Output tab. Its only visible for the duration that the headphones are plugged in. This wasn't the case while I was using the ASRock Motherboard.

Is there a way to get this to stay even if the headphones aren't currently plugged in.

many thanks,
Chirag

David Henningsson (diwic) wrote :

Hi Chirag,

why would you need a headphone device to show up, if it's not plugged in? Are you using the headphone device to control something else than your headphones?

Chirag Chhatriwala (cchhat01-f) wrote :

David,

Sorry for the late response. I understand what you're saying.
However, I'm just going on what I've seen while using the ASRock H67M-ITX/HT board.
In that particular case, irrespective of connecting a headphone in the Front Green jack, Sound Settings "ALWAYS" showed a headphone output setup.

So just some food for though.

Apart from that, I think my problem is temporarily solved up until a new release of ubuntu comes along (at which point I will have to re-task the pin).

Thanks,
Chirag

Pin 0x1b was connected to the front panel connector, which according to
the HDA standard should contain a mic and a headphone. In this case,
the headphone was listed as "line out" by BIOS.

Cc: <email address hidden>
BugLink: https://bugs.launchpad.net/bugs/993162
Signed-off-by: David Henningsson <email address hidden>
---
 sound/pci/hda/patch_realtek.c | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/sound/pci/hda/patch_realtek.c b/sound/pci/hda/patch_realtek.c
index 224410e..b896681 100644
--- a/sound/pci/hda/patch_realtek.c
+++ b/sound/pci/hda/patch_realtek.c
@@ -6439,6 +6439,7 @@ enum {
  ALC662_FIXUP_ASUS_MODE7,
  ALC662_FIXUP_ASUS_MODE8,
  ALC662_FIXUP_NO_JACK_DETECT,
+ ALC662_FIXUP_ZOTAC_Z68,
 };

 static const struct alc_fixup alc662_fixups[] = {
@@ -6588,6 +6589,13 @@ static const struct alc_fixup alc662_fixups[] = {
   .type = ALC_FIXUP_FUNC,
   .v.func = alc_fixup_no_jack_detect,
  },
+ [ALC662_FIXUP_ZOTAC_Z68] = {
+ .type = ALC_FIXUP_PINS,
+ .v.pins = (const struct alc_pincfg[]) {
+ { 0x1b, 0x02214020 }, /* Front HP */
+ { }
+ }
+ },
 };

 static const struct snd_pci_quirk alc662_fixup_tbl[] = {
@@ -6601,6 +6609,7 @@ static const struct snd_pci_quirk alc662_fixup_tbl[] = {
  SND_PCI_QUIRK(0x144d, 0xc051, "Samsung R720", ALC662_FIXUP_IDEAPAD),
  SND_PCI_QUIRK(0x17aa, 0x38af, "Lenovo Ideapad Y550P", ALC662_FIXUP_IDEAPAD),
  SND_PCI_QUIRK(0x17aa, 0x3a0d, "Lenovo Ideapad Y550", ALC662_FIXUP_IDEAPAD),
+ SND_PCI_QUIRK(0x19da, 0xa130, "Zotac Z68", ALC662_FIXUP_ZOTAC_Z68),
  SND_PCI_QUIRK(0x1b35, 0x2206, "CZC P10T", ALC662_FIXUP_CZC_P10T),

 #if 0
--
1.7.9.5

Changed in alsa-driver (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
affects: alsa-driver (Ubuntu) → linux (Ubuntu)
David Henningsson (diwic) wrote :

I'm sending a patch that will retask the pin permanently, for everyone having this particular motherboard. Unless anything unexpected happens, it will be fixed in the next version of Ubuntu, or perhaps even 12.04 later on.

Thank you for helping out with improving Ubuntu :-)

(As for headphones disappearing when you unplug them, that's a feature - we're trying to keep the GUI simple by removing things that the user is unlikely to need)

madbiologist (me-again) wrote :

The above patch is in the upstream kernel 3.5-rc3 - commit edfe3bfc1b779ddda9bcff523eb022dda37b93c8

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-1.1

---------------
linux (3.5.0-1.1) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * [Config] highbank -- enable CONFIG_RFKILL=y and CONFIG_CAN=m

  [ Leann Ogasawara ]

  * Rebase to v3.5-rc1
  * [Config] Remove USB_DEVICEFS from the config enforcer
  * [Config] Updateconfigs after rebase to v3.5-rc1
  * [Config] Temporarily disable CONFIG_MACH_NOKIA_RX51 on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EETI on arm
  * [Config] Temporarily disable CONFIG_TOUCHSCREEN_EGALAX on arm
  * [Config] Temporarily disable CONFIG_EZX_PCAP on arm
  * [Config] Temporarily disable CONFIG_LIS3L02DQ on arm
  * [Config] Temporarily disable CONFIG_TI_CPSW on arm
  * [Config] Temporarily disable CONFIG_GPIO_EM on arm
  * [Config] Temporarily disable CONFIG_SERIAL_8250_EM on armhf
  * [Config] Temporarily disable CONFIG_STMMAC_ETH on armhf
  * [Config] Temporarily disable CONFIG_HW_RANDOM_ATMEL on armhf
  * Rebase to v3.5-rc2
  * [Config] Updateconfigs after rebase to v3.5-rc2
  * [Config] Temporarily disable CONFIG_MV643XX_ETH on powerpc
  * Rebase to v3.5-rc3
  * [Config] Updateconfigs after rebase to v3.5-rc3

  [ Paul Mundt ]

  * SAUCE: fix bug.h's inclusion of kernel.h

  [ Stefan Bader ]

  * SAUCE: Fix compile failures of dm-raid45
  * [Config] Enable dm-raid45
  * Move dependency on crda to extra package
    - LP: #657901
  * SAUCE: Mask CR4 writes on older Xen hypervisors

  [ Upstream Kernel Changes ]

  * rebase to v3.5-rc3
    - LP: #993162
    - LP: #925577
  * rebase to v3.5-rc2
  * rebase to v3.5-rc1
    - LP: #955892
    - LP: #978038
    - LP: #987371
    - LP: #929545
    - LP: #942316
    - LP: #903853
 -- Leann Ogasawara <email address hidden> Fri, 08 Jun 2012 14:28:46 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Luis Henriques (henrix) wrote :

The commit for this issue came in via a stable upstream release. As such it is not subject to the standard bug verification process.

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-27.43

---------------
linux (3.2.0-27.43) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020016

linux (3.2.0-27.42) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020016

  [ Chris J Arges ]

  * PACKAGING: add .gnu_debuglink sections to .ko files
    - LP: #669641

  [ Ike Panhc ]

  * [Config] Updateconfigs
    - LP: #1008345

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800
  * SAUCE: ocfs2: Fix NULL pointer dereferrence in
    __ocfs2_change_file_space
    - LP: #1006012

  [ Rob Herring ]

  * SAUCE: net: calxedaxgmac: enable rx cut-thru mode
    - LP: #1008345
  * SAUCE: EDAC: Add support for the highbank platform memory
    - LP: #1008345
  * SAUCE: EDAC: add support for highbank platform L2 cache ecc
    - LP: #1008345

  [ Seth Forshee ]

  * (pre-stable): bcma: add ext PA workaround for BCM4331 and BCM43431
    - LP: #925577

  [ Takashi Iwai ]

  * SAUCE: ALSA: hda - Fix power-map regression for HP dv6 & co
    - LP: #1013183

  [ Tim Gardner ]

  * [Config] Enable CONFIG_CGROUPS for highbank
    - LP: #1014692

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013723
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * Input: wacom - use BTN_TOOL_FINGER to indicate touch device type
    - LP: #1009435
  * Input: wacom - use switch statement for wacom_tpc_irq()
    - LP: #1009435
  * Input: wacom - isolate input registration
    - LP: #1009435
  * Input: wacom - wireless monitor framework
    - LP: #1009435
  * Input: wacom - create inputs when wireless connect
    - LP: #1009435
  * Input: wacom - wireless battery status
    - LP: #1009435
  * Input: wacom - check for allocation failure in probe()
    - LP: #1009435
  * Input: wacom - add basic Intuos5 support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring/ExpressKey support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring LED support
    - LP: #1009435
  * Input: wacom - add Intuos5 multitouch sensor support
    - LP: #1009435
  * iommu/amd: Add workaround for event log erratum
    - LP: #1013723
  * MIPS: BCM63XX: Add missing include for bcm63xx_gpio.h
    - LP: #1013723
  * cifs: Include backup intent search flags during searches {try #2)
    - LP: #1013723
  * sunrpc: fix loss of task->tk_status after rpc_delay call in
    xprt_alloc_slot
    - LP: #1013723
  * exofs: Fix CRASH on very early IO errors.
    - LP: #1013723
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013723
  * Fix dm-multipath starvation when scsi host is busy
    - LP: #1013723
  * ixp4xx: fix compilation by adding gpiolib support
    - LP: #1013723
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013723
...

Changed in linux (Ubuntu Precise):
status: New → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers